summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjarke Istrup Pedersen <gurligebis@gentoo.org>2012-09-15 20:53:56 +0000
committerBjarke Istrup Pedersen <gurligebis@gentoo.org>2012-09-15 20:53:56 +0000
commit9aec9ef1e382f9b84a31aa771a11a1f105eab21a (patch)
treeb16c234e0216700923ecbad1ac8ff77a0bdb6d22 /net-misc/miniupnpd
parentVersion bump. (diff)
downloadgentoo-2-9aec9ef1e382f9b84a31aa771a11a1f105eab21a.tar.gz
gentoo-2-9aec9ef1e382f9b84a31aa771a11a1f105eab21a.tar.bz2
gentoo-2-9aec9ef1e382f9b84a31aa771a11a1f105eab21a.zip
Bumping to 1.8_pre20120824
(Portage version: 2.2.0_alpha128/cvs/Linux i686)
Diffstat (limited to 'net-misc/miniupnpd')
-rw-r--r--net-misc/miniupnpd/ChangeLog7
-rw-r--r--net-misc/miniupnpd/miniupnpd-1.8_pre20120824.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/net-misc/miniupnpd/ChangeLog b/net-misc/miniupnpd/ChangeLog
index 71f98b6dc3fc..8068d3a4264e 100644
--- a/net-misc/miniupnpd/ChangeLog
+++ b/net-misc/miniupnpd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/miniupnpd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/miniupnpd/ChangeLog,v 1.27 2012/06/03 16:26:12 gurligebis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/miniupnpd/ChangeLog,v 1.28 2012/09/15 20:53:56 gurligebis Exp $
+
+*miniupnpd-1.8_pre20120824 (15 Sep 2012)
+
+ 15 Sep 2012; <gurligebis@gentoo.org> +miniupnpd-1.8_pre20120824.ebuild:
+ Bumping to 1.8_pre20120824
*miniupnpd-1.7 (03 Jun 2012)
diff --git a/net-misc/miniupnpd/miniupnpd-1.8_pre20120824.ebuild b/net-misc/miniupnpd/miniupnpd-1.8_pre20120824.ebuild
new file mode 100644
index 000000000000..e3601718b47c
--- /dev/null
+++ b/net-misc/miniupnpd/miniupnpd-1.8_pre20120824.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/miniupnpd/miniupnpd-1.8_pre20120824.ebuild,v 1.1 2012/09/15 20:53:56 gurligebis Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+MY_PV=1.7.20120824
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DESCRIPTION="MiniUPnP IGD Daemon"
+SRC_URI="http://miniupnp.free.fr/files/${PN}-${MY_PV}.tar.gz"
+HOMEPAGE="http://miniupnp.free.fr/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=net-firewall/iptables-1.4.6"
+DEPEND="${RDEPEND}
+ net-libs/libnfnetlink
+ sys-apps/util-linux
+ sys-apps/lsb-release"
+
+src_prepare() {
+ mv Makefile.linux Makefile
+ sed -i \
+ -e "s#^CFLAGS = .*-D#CPPFLAGS += -I/usr/include -D#" \
+ -e '/^CFLAGS :=/s/CFLAGS/CPPFLAGS/g' \
+ -e "s/CFLAGS += -ansi/#CFLAGS += -ansi/g" \
+ -e "s/LIBS = -liptc/LIBS = -lip4tc/g" \
+ -e 's/genuuid||//' \
+ Makefile || die
+ sed -i \
+ -e 's/\(strncpy(\([->a-z.]\+\), "[a-zA-Z]\+", \)IPT_FUNCTION_MAXNAMELEN);/\1sizeof(\2));/' \
+ netfilter/iptcrdr.c || die
+
+ emake config.h
+
+ sed -i \
+ -e 's/\/\*#define ENABLE_LEASEFILE\*\//#define ENABLE_LEASEFILE/g' \
+ config.h || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install () {
+ dodir /usr/share/man/man8
+
+ einstall PREFIX="${D}" STRIP="true" || die "einstall failed"
+
+ newinitd "${FILESDIR}"/${PN}-init.d ${PN}
+ newconfd "${FILESDIR}"/${PN}-conf.d ${PN}
+}
+
+pkg_postinst() {
+ elog "Please correct the external interface in the top of the two"
+ elog "scripts in /etc/miniupnpd and edit the config file in there too"
+}