summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2014-08-09 17:07:12 +0000
committerIan Whyman <thev00d00@gentoo.org>2014-08-09 17:07:12 +0000
commitcdb73040a6e0b0693e81f22a14edd96ba6a58e8b (patch)
tree29b00af0ea657b25faea453a00abe2eccb51a779 /net-misc/mediatomb
parentFix issue where builds fail on systems that lack /usr/lib64/mozilla/plugins, ... (diff)
downloadgentoo-2-cdb73040a6e0b0693e81f22a14edd96ba6a58e8b.tar.gz
gentoo-2-cdb73040a6e0b0693e81f22a14edd96ba6a58e8b.tar.bz2
gentoo-2-cdb73040a6e0b0693e81f22a14edd96ba6a58e8b.zip
Add snapshot build, remove old
(Portage version: 2.2.11-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-misc/mediatomb')
-rw-r--r--net-misc/mediatomb/ChangeLog8
-rw-r--r--net-misc/mediatomb/mediatomb-0.12.2_pre20140809.ebuild (renamed from net-misc/mediatomb/mediatomb-0.12.1-r5.ebuild)69
2 files changed, 35 insertions, 42 deletions
diff --git a/net-misc/mediatomb/ChangeLog b/net-misc/mediatomb/ChangeLog
index 2c9394d047c2..f0274c6e72c8 100644
--- a/net-misc/mediatomb/ChangeLog
+++ b/net-misc/mediatomb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/mediatomb
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mediatomb/ChangeLog,v 1.53 2014/05/03 19:51:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mediatomb/ChangeLog,v 1.54 2014/08/09 17:07:12 thev00d00 Exp $
+
+*mediatomb-0.12.2_pre20140809 (09 Aug 2014)
+
+ 09 Aug 2014; Ian Whyman <thev00d00@gentoo.org>
+ +mediatomb-0.12.2_pre20140809.ebuild, -mediatomb-0.12.1-r5.ebuild:
+ Add snapshot build, remove old
*mediatomb-0.12.1-r8 (03 May 2014)
diff --git a/net-misc/mediatomb/mediatomb-0.12.1-r5.ebuild b/net-misc/mediatomb/mediatomb-0.12.2_pre20140809.ebuild
index 0a6e66b07c5d..b3d1b6ef8de9 100644
--- a/net-misc/mediatomb/mediatomb-0.12.1-r5.ebuild
+++ b/net-misc/mediatomb/mediatomb-0.12.2_pre20140809.ebuild
@@ -1,96 +1,83 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mediatomb/mediatomb-0.12.1-r5.ebuild,v 1.7 2013/08/26 15:31:14 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mediatomb/mediatomb-0.12.2_pre20140809.ebuild,v 1.1 2014/08/09 17:07:12 thev00d00 Exp $
-EAPI="4"
-inherit autotools eutils linux-info user
+EAPI=5
+inherit autotools eutils linux-info user vcs-snapshot
-DEB_VER="4"
DESCRIPTION="MediaTomb is an open source UPnP MediaServer"
HOMEPAGE="http://www.mediatomb.cc/"
-SRC_URI="mirror://sourceforge/mediatomb/${P}.tar.gz
- mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}-${DEB_VER}.debian.tar.gz"
+SRC_URI="https://github.com/v00d00/${PN}/archive/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ~arm ~ppc x86"
-IUSE="+curl debug +exif +ffmpeg id3tag inotify +javascript lastfm libextractor +magic +mp4 mysql +sqlite +taglib thumbnail +zlib"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+IUSE="curl debug +exif +ffmpeg flac id3tag +inotify +javascript lastfm
+ +magic +mp4 mysql +sqlite +taglib thumbnail +zlib"
REQUIRED_USE="
|| ( mysql sqlite )
- taglib? ( !id3tag ) id3tag? ( !taglib )
- thumbnail? ( ffmpeg !libextractor )
- ffmpeg? ( !libextractor )
- libextractor? ( !ffmpeg !thumbnail )
+ taglib? ( !id3tag )
+ id3tag? ( !taglib )
+ thumbnail? ( ffmpeg )
"
DEPEND="mysql? ( virtual/mysql )
+ dev-libs/expat
id3tag? ( media-libs/id3lib )
javascript? ( >=dev-lang/spidermonkey-1.8.5:0 )
- dev-libs/expat
taglib? ( media-libs/taglib )
sqlite? ( >=dev-db/sqlite-3 )
lastfm? ( >=media-libs/lastfmlib-0.4 )
exif? ( media-libs/libexif )
- libextractor? ( media-libs/libextractor )
mp4? ( >=media-libs/libmp4v2-1.9.1_p479:0 )
ffmpeg? ( virtual/ffmpeg )
+ flac? ( media-libs/flac )
thumbnail? ( media-video/ffmpegthumbnailer[jpeg] )
- curl? ( net-misc/curl )
+ curl? ( net-misc/curl net-misc/youtube-dl )
magic? ( sys-apps/file )
sys-apps/util-linux
zlib? ( sys-libs/zlib )
- virtual/libiconv"
+ virtual/libiconv
+"
RDEPEND="${DEPEND}"
+CONFIG_CHECK="~INOTIFY_USER"
+
pkg_setup() {
- if use inotify ; then
- if ! linux_config_exists || ! linux_chkconfig_present INOTIFY_USER ; then
- ewarn "Please enable Inotify support in your kernel:"
- ewarn " File systems --->"
- ewarn " [*] Inotify support for userspace"
- fi
- fi
enewgroup mediatomb
enewuser mediatomb -1 -1 /dev/null mediatomb
}
src_prepare() {
- local p dd="${WORKDIR}"/debian/patches
- sed -i -r '/^[-+]{3} /s:[.][.]/::' "${dd}"/* || die
- for p in $(<"${dd}"/series) ; do
- epatch "${dd}"/${p}
- done
- epatch "${FILESDIR}"/${P}-libmp4v2.patch
- epatch "${FILESDIR}"/${P}-system-uuid.patch #270830
+ # Support spidermonkey-187 #423991 #482392
if has_version "~dev-lang/spidermonkey-1.8.7" ; then
- epatch "${FILESDIR}"/${P}-mozjs187.patch #435394
+ epatch "${FILESDIR}"/${PN}-0.12.1-mozjs187.patch
fi
- epatch "${FILESDIR}"/${P}-libextractor.patch #435394
- epatch "${FILESDIR}"/${P}-inotify-hard-links.patch
- epatch "${FILESDIR}"/${P}-thumb-cache.patch
- epatch "${FILESDIR}"/${P}-libav9.patch
- epatch "${FILESDIR}"/${P}-avformatcontext-pointer.patch #446922
+
+ epatch_user
+
eautoreconf
}
src_configure() {
econf \
- $(use_enable curl) $(use_enable curl youtube) \
+ $(use_enable curl) \
+ $(use_enable curl youtube) \
$(use_enable debug tombdebug) \
$(use_enable exif libexif) \
$(use_enable ffmpeg) \
+ $(use_enable flac) \
$(use_enable id3tag id3lib) \
$(use_enable inotify) \
$(use_enable javascript libjs) \
- $(use_enable lastfm lastfmlib) \
- $(use_enable libextractor) \
+ $(use_enable lastfm lastfm) \
$(use_enable magic libmagic) \
$(use_enable mp4 libmp4v2) \
$(use_enable mysql) \
$(use_enable sqlite sqlite3) \
$(use_enable taglib) \
$(use_enable thumbnail ffmpegthumbnailer) \
- $(use_enable zlib) \
--enable-external-transcoding \
--enable-protocolinfo-extension
}