summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2013-01-20 20:35:16 +0000
committerIan Whyman <thev00d00@gentoo.org>2013-01-20 20:35:16 +0000
commit5249096e54aa8a614440403e984454a1442d5f41 (patch)
tree91c59f7814419ef5903c264309689cb05118f307 /net-misc/mediatomb
parentAdd PYTHON_USEDEP to setuptools dep. (diff)
downloadgentoo-2-5249096e54aa8a614440403e984454a1442d5f41.tar.gz
gentoo-2-5249096e54aa8a614440403e984454a1442d5f41.tar.bz2
gentoo-2-5249096e54aa8a614440403e984454a1442d5f41.zip
Update to use REQUIRED_USE, Thanks to BT in #448484, Drop old
(Portage version: 2.2.0_alpha157/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-misc/mediatomb')
-rw-r--r--net-misc/mediatomb/ChangeLog6
-rw-r--r--net-misc/mediatomb/mediatomb-0.12.1-r1.ebuild122
-rw-r--r--net-misc/mediatomb/mediatomb-0.12.1-r3.ebuild134
-rw-r--r--net-misc/mediatomb/mediatomb-0.12.1-r5.ebuild26
4 files changed, 13 insertions, 275 deletions
diff --git a/net-misc/mediatomb/ChangeLog b/net-misc/mediatomb/ChangeLog
index 454108933498..63e904539237 100644
--- a/net-misc/mediatomb/ChangeLog
+++ b/net-misc/mediatomb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/mediatomb
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mediatomb/ChangeLog,v 1.41 2013/01/20 16:28:11 thev00d00 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mediatomb/ChangeLog,v 1.42 2013/01/20 20:35:16 thev00d00 Exp $
+
+ 20 Jan 2013; Ian Whyman <thev00d00@gentoo.org> -mediatomb-0.12.1-r1.ebuild,
+ -mediatomb-0.12.1-r3.ebuild, mediatomb-0.12.1-r5.ebuild:
+ Update to use REQUIRED_USE, Thanks to BT in #448484, Drop old
*mediatomb-0.12.1-r5 (20 Jan 2013)
diff --git a/net-misc/mediatomb/mediatomb-0.12.1-r1.ebuild b/net-misc/mediatomb/mediatomb-0.12.1-r1.ebuild
deleted file mode 100644
index ddd795294125..000000000000
--- a/net-misc/mediatomb/mediatomb-0.12.1-r1.ebuild
+++ /dev/null
@@ -1,122 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mediatomb/mediatomb-0.12.1-r1.ebuild,v 1.4 2012/06/28 17:23:51 axs Exp $
-
-EAPI=2
-inherit autotools eutils linux-info
-
-DESCRIPTION="MediaTomb is an open source UPnP MediaServer"
-HOMEPAGE="http://www.mediatomb.cc/"
-SRC_URI="mirror://sourceforge/mediatomb/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~ppc x86"
-IUSE="debug +exif +ffmpeg inotify +javascript lastfm libextractor +mp4 mysql +taglib thumbnail"
-
-DEPEND="
- mysql? ( virtual/mysql )
- !mysql? ( >=dev-db/sqlite-3 )
- javascript? ( <dev-lang/spidermonkey-1.8.6 )
- dev-libs/expat
- taglib? ( media-libs/taglib )
- !taglib? ( media-libs/id3lib )
- lastfm? ( >=media-libs/lastfmlib-0.4 )
- exif? ( media-libs/libexif )
- libextractor? ( media-libs/libextractor )
- mp4? ( media-libs/libmp4v2:0 )
- ffmpeg? ( virtual/ffmpeg )
- thumbnail? ( media-video/ffmpegthumbnailer[jpeg] )
- net-misc/curl
- sys-apps/file
- sys-libs/zlib
- virtual/libiconv"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- if use inotify; then
- if ! linux_config_exists \
- || ! linux_chkconfig_present INOTIFY_USER; then
- ewarn "Please enable Inotify support in your kernel:"
- ewarn
- ewarn " File systems --->"
- ewarn " [*] Inotify support for userspace"
- ewarn
- fi
- fi
- enewgroup mediatomb
- enewuser mediatomb -1 -1 /dev/null mediatomb
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-gcc46.patch"
- epatch "${FILESDIR}/${P}-libav7.patch"
- if use javascript && has_version ">=dev-lang/spidermonkey-1.8.5" ; then
- epatch "${FILESDIR}"/${P}-mozjs185.patch
- eautoreconf
- fi
-}
-
-src_configure() {
- if use thumbnail; then
- elog "libextrator does not work with thumbnail, disabling libextrator"
- myconf="${myconf} --enable-ffmpegthumbnailer --enable-ffmpeg --disable-libextractor"
- elif ! use thumbnail && use ffmpeg && use libextractor; then
- elog "libextrator does not work with ffmpeg, disabling libextrator"
- myconf="${myconf} --disable-ffmpegthumbnailer --enable-ffmpeg --disable-libextractor"
- else
- myconf="${myconf} $(use_enable thumbnail ffmpegthumbnailer) $(use_enable ffmpeg) $(use_enable libextractor)"
- fi
-
- econf \
- $(use_enable debug tombdebug) \
- $(use_enable exif libexif) \
- $(use_enable inotify) \
- $(use_enable javascript libjs) \
- $(use_enable lastfm lastfmlib) \
- $(use_enable mp4 libmp4v2) \
- $(use_enable mysql) $(use_enable !mysql sqlite3) \
- $(use_enable taglib) $(use_enable !taglib id3lib) \
- --enable-curl \
- --enable-external-transcoding \
- --enable-libmagic \
- --enable-protocolinfo-extension \
- --enable-youtube \
- --enable-zlib \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Install failed!"
-
- dodoc AUTHORS ChangeLog NEWS README TODO
-
- sed -e "s:#MYSQL#:$(use mysql && has_version dev-db/mysql[-minimal] && echo "mysql"):" \
- "${FILESDIR}/${PN}-0.12.0.initd" > "${T}/mediatomb.initd" || die
- newinitd "${T}/mediatomb.initd" mediatomb || die
- newconfd "${FILESDIR}/${PN}-0.12.0.confd" mediatomb || die
-
- insinto /etc/mediatomb
- newins "${FILESDIR}/${PN}-0.12.0.config" config.xml || die
- fperms 0600 /etc/mediatomb/config.xml
- fowners mediatomb:mediatomb /etc/mediatomb/config.xml
-
- keepdir /var/lib/mediatomb
- fowners mediatomb:mediatomb /var/lib/mediatomb
-}
-
-pkg_postinst() {
- if use mysql; then
- elog "MediaTomb has been built with MySQL support and needs"
- elog "to be configured before being started."
- elog "For more information, please consult the MediaTomb"
- elog "documentation: http://mediatomb.cc/pages/documentation"
- elog
- fi
-
- elog "To configure MediaTomb edit:"
- elog "/etc/mediatomb/config.xml"
- elog
- elog "The MediaTomb web interface can be reached at (after the service is started):"
- elog "http://localhost:49152/"
-}
diff --git a/net-misc/mediatomb/mediatomb-0.12.1-r3.ebuild b/net-misc/mediatomb/mediatomb-0.12.1-r3.ebuild
deleted file mode 100644
index 5bb4d76b15c9..000000000000
--- a/net-misc/mediatomb/mediatomb-0.12.1-r3.ebuild
+++ /dev/null
@@ -1,134 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mediatomb/mediatomb-0.12.1-r3.ebuild,v 1.4 2012/10/04 03:52:25 vapier Exp $
-
-EAPI="4"
-inherit autotools eutils linux-info user
-
-DEB_VER="4"
-DESCRIPTION="MediaTomb is an open source UPnP MediaServer"
-HOMEPAGE="http://www.mediatomb.cc/"
-SRC_URI="mirror://sourceforge/mediatomb/${P}.tar.gz
- mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}-${DEB_VER}.debian.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~x86"
-IUSE="+curl debug +exif +ffmpeg id3tag inotify +javascript lastfm libextractor +magic +mp4 mysql +sqlite +taglib thumbnail +zlib"
-REQUIRED_USE="
- || ( mysql sqlite )
- taglib? ( !id3tag ) id3tag? ( !taglib )
-"
-
-DEPEND="mysql? ( virtual/mysql )
- id3tag? ( media-libs/id3lib )
- javascript? ( >=dev-lang/spidermonkey-1.8.5 )
- dev-libs/expat
- taglib? ( media-libs/taglib )
- sqlite? ( >=dev-db/sqlite-3 )
- lastfm? ( >=media-libs/lastfmlib-0.4 )
- exif? ( media-libs/libexif )
- libextractor? ( media-libs/libextractor )
- mp4? ( >=media-libs/libmp4v2-1.9.1_p479:0 )
- ffmpeg? ( virtual/ffmpeg )
- thumbnail? ( media-video/ffmpegthumbnailer[jpeg] )
- curl? ( net-misc/curl )
- magic? ( sys-apps/file )
- sys-apps/util-linux
- zlib? ( sys-libs/zlib )
- virtual/libiconv"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- if use inotify ; then
- if ! linux_config_exists || ! linux_chkconfig_present INOTIFY_USER ; then
- ewarn "Please enable Inotify support in your kernel:"
- ewarn " File systems --->"
- ewarn " [*] Inotify support for userspace"
- fi
- fi
- enewgroup mediatomb
- enewuser mediatomb -1 -1 /dev/null mediatomb
-}
-
-src_prepare() {
- local p dd="${WORKDIR}"/debian/patches
- sed -i -r '/^[-+]{3} /s:[.][.]/::' "${dd}"/* || die
- for p in $(<"${dd}"/series) ; do
- epatch "${dd}"/${p}
- done
- epatch "${FILESDIR}"/${P}-libmp4v2.patch
- epatch "${FILESDIR}"/${P}-system-uuid.patch #270830
- if has_version ">=dev-lang/spidermonkey-1.8.7" ; then
- epatch "${FILESDIR}"/${P}-mozjs187.patch #435394
- fi
- epatch "${FILESDIR}"/${P}-libextractor.patch #435394
- eautoreconf
-}
-
-src_configure() {
- local myconf=()
- if use thumbnail ; then
- elog "libextrator does not work with thumbnail, disabling libextrator"
- myconf+=( --enable-ffmpegthumbnailer --enable-ffmpeg --disable-libextractor )
- elif ! use thumbnail && use ffmpeg && use libextractor ; then
- elog "libextrator does not work with ffmpeg, disabling libextrator"
- myconf+=( --disable-ffmpegthumbnailer --enable-ffmpeg --disable-libextractor )
- else
- myconf+=(
- $(use_enable thumbnail ffmpegthumbnailer)
- $(use_enable ffmpeg)
- $(use_enable libextractor)
- )
- fi
-
- econf \
- $(use_enable curl) $(use_enable curl youtube) \
- $(use_enable debug tombdebug) \
- $(use_enable exif libexif) \
- $(use_enable id3tag id3lib) \
- $(use_enable inotify) \
- $(use_enable javascript libjs) \
- $(use_enable lastfm lastfmlib) \
- $(use_enable magic libmagic) \
- $(use_enable mp4 libmp4v2) \
- $(use_enable mysql) \
- $(use_enable sqlite sqlite3) \
- $(use_enable taglib) \
- $(use_enable zlib) \
- --enable-external-transcoding \
- --enable-protocolinfo-extension \
- "${myconf[@]}"
-}
-
-src_install() {
- default
-
- newinitd "${FILESDIR}"/${PN}-0.12.1.initd ${PN}
- use mysql || sed -i -e "/use mysql/d" "${ED}"/etc/init.d/${PN}
- newconfd "${FILESDIR}"/${PN}-0.12.0.confd ${PN}
-
- insinto /etc/mediatomb
- newins "${FILESDIR}/${PN}-0.12.0.config" config.xml
- fperms 0600 /etc/mediatomb/config.xml
- fowners mediatomb:mediatomb /etc/mediatomb/config.xml
-
- keepdir /var/lib/mediatomb
- fowners mediatomb:mediatomb /var/lib/mediatomb
-}
-
-pkg_postinst() {
- if use mysql ; then
- elog "MediaTomb has been built with MySQL support and needs"
- elog "to be configured before being started."
- elog "For more information, please consult the MediaTomb"
- elog "documentation: http://mediatomb.cc/pages/documentation"
- elog
- fi
-
- elog "To configure MediaTomb edit:"
- elog "/etc/mediatomb/config.xml"
- elog
- elog "The MediaTomb web interface can be reached at (after the service is started):"
- elog "http://localhost:49152/"
-}
diff --git a/net-misc/mediatomb/mediatomb-0.12.1-r5.ebuild b/net-misc/mediatomb/mediatomb-0.12.1-r5.ebuild
index 33c8b3ee41fd..1aebdb9520e0 100644
--- a/net-misc/mediatomb/mediatomb-0.12.1-r5.ebuild
+++ b/net-misc/mediatomb/mediatomb-0.12.1-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mediatomb/mediatomb-0.12.1-r5.ebuild,v 1.1 2013/01/20 16:28:11 thev00d00 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mediatomb/mediatomb-0.12.1-r5.ebuild,v 1.2 2013/01/20 20:35:16 thev00d00 Exp $
EAPI="4"
inherit autotools eutils linux-info user
@@ -18,6 +18,9 @@ IUSE="+curl debug +exif +ffmpeg id3tag inotify +javascript lastfm libextractor +
REQUIRED_USE="
|| ( mysql sqlite )
taglib? ( !id3tag ) id3tag? ( !taglib )
+ thumbnail? ( ffmpeg !libextractor )
+ ffmpeg? ( !libextractor )
+ libextractor? ( !ffmpeg !thumbnail )
"
DEPEND="mysql? ( virtual/mysql )
@@ -72,38 +75,25 @@ src_prepare() {
}
src_configure() {
- local myconf=()
- if use thumbnail ; then
- elog "libextrator does not work with thumbnail, disabling libextrator"
- myconf+=( --enable-ffmpegthumbnailer --enable-ffmpeg --disable-libextractor )
- elif ! use thumbnail && use ffmpeg && use libextractor ; then
- elog "libextrator does not work with ffmpeg, disabling libextrator"
- myconf+=( --disable-ffmpegthumbnailer --enable-ffmpeg --disable-libextractor )
- else
- myconf+=(
- $(use_enable thumbnail ffmpegthumbnailer)
- $(use_enable ffmpeg)
- $(use_enable libextractor)
- )
- fi
-
econf \
$(use_enable curl) $(use_enable curl youtube) \
$(use_enable debug tombdebug) \
$(use_enable exif libexif) \
+ $(use_enable ffmpeg) \
$(use_enable id3tag id3lib) \
$(use_enable inotify) \
$(use_enable javascript libjs) \
$(use_enable lastfm lastfmlib) \
+ $(use_enable libextractor) \
$(use_enable magic libmagic) \
$(use_enable mp4 libmp4v2) \
$(use_enable mysql) \
$(use_enable sqlite sqlite3) \
$(use_enable taglib) \
+ $(use_enable thumbnail ffmpegthumbnailer) \
$(use_enable zlib) \
--enable-external-transcoding \
- --enable-protocolinfo-extension \
- "${myconf[@]}"
+ --enable-protocolinfo-extension
}
src_install() {