summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-06-13 09:00:21 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-06-13 09:00:21 +0000
commit534e72f48e159c9fc64e2b3abdf4ef7e5834b7ab (patch)
tree738572627a2c1644a86423285b127c83be8071f2 /net-misc/logmein-hamachi
parentVersion Bump, Fixed dependency version of headers and libc, #351110 (diff)
downloadgentoo-2-534e72f48e159c9fc64e2b3abdf4ef7e5834b7ab.tar.gz
gentoo-2-534e72f48e159c9fc64e2b3abdf4ef7e5834b7ab.tar.bz2
gentoo-2-534e72f48e159c9fc64e2b3abdf4ef7e5834b7ab.zip
Version bump thanks to Simone Scanzoni <nonno.cicala@libero.it>
(Portage version: 2.1.9.49/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/logmein-hamachi')
-rw-r--r--net-misc/logmein-hamachi/ChangeLog8
-rw-r--r--net-misc/logmein-hamachi/logmein-hamachi-2.0.1.15.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/net-misc/logmein-hamachi/ChangeLog b/net-misc/logmein-hamachi/ChangeLog
index 604f42a2d5a3..7166c799baf8 100644
--- a/net-misc/logmein-hamachi/ChangeLog
+++ b/net-misc/logmein-hamachi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/logmein-hamachi
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/logmein-hamachi/ChangeLog,v 1.1 2011/01/15 21:13:25 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/logmein-hamachi/ChangeLog,v 1.2 2011/06/13 09:00:21 hwoarang Exp $
+
+*logmein-hamachi-2.0.1.15 (13 Jun 2011)
+
+ 13 Jun 2011; Markos Chandras <hwoarang@gentoo.org>
+ +logmein-hamachi-2.0.1.15.ebuild:
+ Version bump thanks to Simone Scanzoni <nonno.cicala@libero.it>
*logmein-hamachi-2.0.1.13 (15 Jan 2011)
diff --git a/net-misc/logmein-hamachi/logmein-hamachi-2.0.1.15.ebuild b/net-misc/logmein-hamachi/logmein-hamachi-2.0.1.15.ebuild
new file mode 100644
index 000000000000..315089ff3f65
--- /dev/null
+++ b/net-misc/logmein-hamachi/logmein-hamachi-2.0.1.15.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/logmein-hamachi/logmein-hamachi-2.0.1.15.ebuild,v 1.1 2011/06/13 09:00:21 hwoarang Exp $
+
+inherit eutils linux-info
+
+DESCRIPTION="LogMeIn Hamachi VPN tunneling engine"
+HOMEPAGE="https://secure.logmein.com/products/hamachi2"
+SRC_URI="x86? ( https://secure.logmein.com/labs/${P}-x86.tgz )
+ amd64? ( https://secure.logmein.com/labs/${P}-x64.tgz )"
+
+LICENSE="LogMeIn"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!net-misc/hamachi"
+
+RESTRICT="mirror"
+
+QA_PRESTRIPPED="/opt/${PN}/bin/hamachid"
+
+pkg_setup() {
+ einfo "Checking your kernel configuration for TUN/TAP support."
+ CONFIG_CHECK="~TUN"
+ check_extra_config
+}
+
+src_unpack() {
+ unpack ${A}
+ mv ${P}-$(use x86 && echo x86 || echo x64) "${S}" || die
+}
+
+src_install() {
+ into /opt/${PN}
+ dobin hamachid dnsup dnsdown || die
+ dosym /opt/${PN}/bin/hamachid /usr/bin/hamachi || die "Couldn't create hamachi symlink"
+
+ dodir /var/run/${PN} || die
+
+ # Config and log directory
+ dodir /var/lib/${PN} || die
+
+ newconfd "${FILESDIR}"/${PN}.confd ${PN} || die
+ newinitd "${FILESDIR}"/${PN}.initd ${PN} || die
+
+ dodoc CHANGES README || die
+}
+
+pkg_postinst() {
+ elog "LogMeIn Hamachi2 is installed."
+ elog "Consult the README file on how to configure your client."
+ elog "You can run the client 'hamachi' as root,"
+ elog "or as a user if you add a line:"
+ elog "Ipc.User <login name>"
+ elog "to the file '/var/lib/${PN}/h2-engine-override.cfg'"
+ elog "and restart the daemon with"
+ elog "/etc/init.d/${PN} restart"
+ elog "To enable auto-login when the service starts set a nickname in"
+ elog "/etc/conf.d/${PN}"
+ elog "Running 'hamachi' without arguments may crash the daemon."
+}