summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-01-02 09:23:53 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-01-02 09:23:53 +0000
commit0ce72457d30a56c59f88b2e80bc896d4bc7f44cb (patch)
tree15acd699d2b5deb144edcd2ae3d4cd5e95178538 /net-misc/logmein-hamachi
parentVersion bump mercurial to 2.4.2. (diff)
downloadgentoo-2-0ce72457d30a56c59f88b2e80bc896d4bc7f44cb.tar.gz
gentoo-2-0ce72457d30a56c59f88b2e80bc896d4bc7f44cb.tar.bz2
gentoo-2-0ce72457d30a56c59f88b2e80bc896d4bc7f44cb.zip
Version bump, wrt bug #449712. Drop old versions, cause they are not available anymore, thanks to Matthias Blümel for discovering this issue
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-misc/logmein-hamachi')
-rw-r--r--net-misc/logmein-hamachi/ChangeLog12
-rw-r--r--net-misc/logmein-hamachi/logmein-hamachi-2.1.0.76.ebuild62
-rw-r--r--net-misc/logmein-hamachi/logmein-hamachi-2.1.0.86.ebuild (renamed from net-misc/logmein-hamachi/logmein-hamachi-2.1.0.76-r1.ebuild)4
3 files changed, 12 insertions, 66 deletions
diff --git a/net-misc/logmein-hamachi/ChangeLog b/net-misc/logmein-hamachi/ChangeLog
index 63b64d861ff0..cf451fcbea1a 100644
--- a/net-misc/logmein-hamachi/ChangeLog
+++ b/net-misc/logmein-hamachi/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/logmein-hamachi
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/logmein-hamachi/ChangeLog,v 1.9 2012/11/22 19:29:20 hwoarang Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/logmein-hamachi/ChangeLog,v 1.10 2013/01/02 09:23:53 pinkbyte Exp $
+
+*logmein-hamachi-2.1.0.86 (02 Jan 2013)
+
+ 02 Jan 2013; Sergey Popov <pinkbyte@gentoo.org>
+ -logmein-hamachi-2.1.0.76.ebuild, -logmein-hamachi-2.1.0.76-r1.ebuild,
+ +logmein-hamachi-2.1.0.86.ebuild:
+ Version bump, wrt bug #449712. Drop old versions, cause they are not
+ available anymore, thanks to Matthias Blümel for discovering this issue
*logmein-hamachi-2.1.0.81 (22 Nov 2012)
diff --git a/net-misc/logmein-hamachi/logmein-hamachi-2.1.0.76.ebuild b/net-misc/logmein-hamachi/logmein-hamachi-2.1.0.76.ebuild
deleted file mode 100644
index 09887dbcbe7a..000000000000
--- a/net-misc/logmein-hamachi/logmein-hamachi-2.1.0.76.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/logmein-hamachi/logmein-hamachi-2.1.0.76.ebuild,v 1.1 2012/10/03 21:11:40 hwoarang Exp $
-
-inherit eutils linux-info
-
-DESCRIPTION="LogMeIn Hamachi VPN tunneling engine"
-HOMEPAGE="https://secure.logmein.com/products/hamachi2"
-SRC_URI="x86? ( https://secure.logmein.com/labs/${P}-x86.tgz )
- amd64? ( https://secure.logmein.com/labs/${P}-x64.tgz )"
-
-LICENSE="LogMeIn"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
-IUSE=""
-
-RDEPEND="!net-misc/hamachi"
-
-RESTRICT="mirror"
-
-QA_PREBUILT="/opt/${PN}/bin/hamachid"
-QA_PRESTRIPPED="/opt/${PN}/bin/hamachid"
-
-pkg_setup() {
- einfo "Checking your kernel configuration for TUN/TAP support."
- CONFIG_CHECK="~TUN"
- check_extra_config
-}
-
-src_unpack() {
- unpack ${A}
- mv ${P}-$(use x86 && echo x86 || echo x64) "${S}" || die
-}
-
-src_install() {
- into /opt/${PN}
- dobin hamachid dnsup dnsdown || die
- dosym /opt/${PN}/bin/hamachid /usr/bin/hamachi || die "Couldn't create hamachi symlink"
-
- dodir /var/run/${PN} || die
-
- # Config and log directory
- dodir /var/lib/${PN} || die
-
- newconfd "${FILESDIR}"/${PN}.confd ${PN} || die
- newinitd "${FILESDIR}"/${PN}.initd ${PN} || die
-
- dodoc CHANGES README || die
-}
-
-pkg_postinst() {
- elog "LogMeIn Hamachi2 is installed."
- elog "Consult the README file on how to configure your client."
- elog "You can run the client 'hamachi' as root,"
- elog "or as a user if you add a line:"
- elog "Ipc.User <login name>"
- elog "to the file '/var/lib/${PN}/h2-engine-override.cfg'"
- elog "and restart the daemon with"
- elog "/etc/init.d/${PN} restart"
- elog "To enable auto-login when the service starts set a nickname in"
- elog "/etc/conf.d/${PN}"
-}
diff --git a/net-misc/logmein-hamachi/logmein-hamachi-2.1.0.76-r1.ebuild b/net-misc/logmein-hamachi/logmein-hamachi-2.1.0.86.ebuild
index 5da862f11b51..9e1c5bafa6a2 100644
--- a/net-misc/logmein-hamachi/logmein-hamachi-2.1.0.76-r1.ebuild
+++ b/net-misc/logmein-hamachi/logmein-hamachi-2.1.0.86.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/logmein-hamachi/logmein-hamachi-2.1.0.76-r1.ebuild,v 1.1 2012/10/15 18:22:42 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/logmein-hamachi/logmein-hamachi-2.1.0.86.ebuild,v 1.1 2013/01/02 09:23:53 pinkbyte Exp $
inherit eutils linux-info