summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2015-02-18 10:18:51 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2015-02-18 10:18:51 +0000
commitcbdadf316837af1697dae93dfa0c5c9c0d742b57 (patch)
tree4ce3e4d931aa9ef85cb3fcd17c4dad70cd92d440 /net-misc/linuxptp
parentmake the build log verbose (diff)
downloadgentoo-2-cbdadf316837af1697dae93dfa0c5c9c0d742b57.tar.gz
gentoo-2-cbdadf316837af1697dae93dfa0c5c9c0d742b57.tar.bz2
gentoo-2-cbdadf316837af1697dae93dfa0c5c9c0d742b57.zip
Initial commit
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 0x762053D5)
Diffstat (limited to 'net-misc/linuxptp')
-rw-r--r--net-misc/linuxptp/ChangeLog10
-rw-r--r--net-misc/linuxptp/Manifest4
-rw-r--r--net-misc/linuxptp/linuxptp-1.5.ebuild37
-rw-r--r--net-misc/linuxptp/metadata.xml11
4 files changed, 62 insertions, 0 deletions
diff --git a/net-misc/linuxptp/ChangeLog b/net-misc/linuxptp/ChangeLog
new file mode 100644
index 000000000000..1304f79bdfc1
--- /dev/null
+++ b/net-misc/linuxptp/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-misc/linuxptp
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/linuxptp/ChangeLog,v 1.1 2015/02/18 10:18:51 tomjbe Exp $
+
+*linuxptp-1.5 (18 Feb 2015)
+
+ 18 Feb 2015; Thomas Beierlein <tomjbe@gentoo.org> +linuxptp-1.5.ebuild,
+ +metadata.xml:
+ Initial commit
+
diff --git a/net-misc/linuxptp/Manifest b/net-misc/linuxptp/Manifest
new file mode 100644
index 000000000000..a29aa4c370c7
--- /dev/null
+++ b/net-misc/linuxptp/Manifest
@@ -0,0 +1,4 @@
+DIST linuxptp-1.5.tgz 139127 SHA256 ecebc8503a9fd2340299f8015e520527c32cf3760d34849fa0e855bbbf4b1090 SHA512 03ec0c3a283e08f9e62dfa7d059326887db541aa53b5c65e03534079083f39666a441a4303f428f3b972976483e683e603bdc2ec232495ccab46153531124974 WHIRLPOOL e5fb5398cf239221f08ec52830252aa4eeaabcef6341cc9c04a9ff3794d4d93f18247323b0a1fd26a088e00d6816087d7149e8625e7b25d91882be9dc034dec1
+EBUILD linuxptp-1.5.ebuild 730 SHA256 1be2064fde35aab9a9bd21c14a8652aa2a9ad999d8c9091f69b3dc963552db3d SHA512 362f34458b63c3524198a40e0f2c208514ee4cbd8c77158ff800038d420f8fe1134bd2890d3479249315865d472a075ba08a77cd6fc1eef750dfee5f3e5644d0 WHIRLPOOL f86a4940075d4495816ee869bcc03531ddc115c30d7e52ab19acc221bfed1ac5051110c4e969f903d37d37e59296819f52f123058cbe90a63e8e1dc0727a7102
+MISC ChangeLog 256 SHA256 72ea6f84becbf2eb59e6a437598486e7a403e9261ac22c6b6b677bda52951c39 SHA512 7e2a2ddbb7bd06b361cea29f3f5bb71ab8507e82671f213be169f2ace33658882adde87acea88bfb3fc2e0085da21e26b8b0d82a912a08d704badb61a32dd47f WHIRLPOOL 110500157e64d1896ab11cdd0bc4a6555cd0bf217d9c51a01280c4ea4a53c696ef3153654f329e1b387906c9c1a2efca7823254d1dee4840fb72b04b56875fa2
+MISC metadata.xml 349 SHA256 39924bc7a3fec1a964d08c7dcaed302899b6cec22bec00f447bb364a89ddad23 SHA512 1bad11b83f4b1a46aab7f5944bd8fee52feb87edfab10d16aaf81ecdcf701b0665850fe913d3e4db20e5dab5d0c3976d742698535db97f95ae339a0a926c89a6 WHIRLPOOL 44d176e2fe8775ffd6377744b190e7af7dafbe5d0561f6c4bfee4170e911737d5abdcb89a37b5dca60e83f99317158c07ae03227b2cc9ce37949df6b06a55455
diff --git a/net-misc/linuxptp/linuxptp-1.5.ebuild b/net-misc/linuxptp/linuxptp-1.5.ebuild
new file mode 100644
index 000000000000..40d74383cc4e
--- /dev/null
+++ b/net-misc/linuxptp/linuxptp-1.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/linuxptp/linuxptp-1.5.ebuild,v 1.1 2015/02/18 10:18:51 tomjbe Exp $
+
+EAPI=5
+
+inherit linux-info
+
+DESCRIPTION="The Linux Precision Time Protocol (PTP) implementation"
+HOMEPAGE="http://linuxptp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/v${PV}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="PPS NETWORK_PHY_TIMESTAMPING PTP_1588_CLOCK"
+
+src_compile() {
+ export EXTRA_CFLAGS=${CFLAGS}
+ emake prefix=/usr mandir=/usr/share/man
+}
+
+src_install() {
+ emake \
+ prefix="${D}"/usr \
+ mandir="${D}"/usr/share/man \
+ infodir="${D}"/usr/share/info \
+ libdir="${D}"/usr/$(get_libdir) \
+ install
+
+ dodoc README.org
+}
diff --git a/net-misc/linuxptp/metadata.xml b/net-misc/linuxptp/metadata.xml
new file mode 100644
index 000000000000..9f9188af6008
--- /dev/null
+++ b/net-misc/linuxptp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>tomjbe@gentoo.org</email>
+ <name>Thomas Beierlein</name>
+</maintainer>
+ <longdescription>The package implements the Linux version of the
+ Precision Time Protocol (PTP)
+ </longdescription>
+</pkgmetadata>