summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-11-28 03:48:15 +0000
committerDonny Davies <woodchip@gentoo.org>2001-11-28 03:48:15 +0000
commit9fbf47f67af47bfd75f2bdbb227b7cec2b425ee9 (patch)
treeff1a588e0dc065508dffce456b043dac3aba3677 /net-misc/linesrv
parentTidied up the manpage install stuff bu supplying --mandir to the (diff)
downloadgentoo-2-9fbf47f67af47bfd75f2bdbb227b7cec2b425ee9.tar.gz
gentoo-2-9fbf47f67af47bfd75f2bdbb227b7cec2b425ee9.tar.bz2
gentoo-2-9fbf47f67af47bfd75f2bdbb227b7cec2b425ee9.zip
Added package for the daemon at http://linecontrol.sourceforge.net.
Neat client/server solution to controlling a masq'ing server's Internet Link. TODO: Packages for the linux console and KDE clients.
Diffstat (limited to 'net-misc/linesrv')
-rw-r--r--net-misc/linesrv/files/digest-linesrv-2.1.61
-rw-r--r--net-misc/linesrv/files/lcshutdown.pam4
-rw-r--r--net-misc/linesrv/files/linecontrol.pam5
-rw-r--r--net-misc/linesrv/files/linesrv.conf46
-rw-r--r--net-misc/linesrv/files/linesrv.rc626
-rw-r--r--net-misc/linesrv/linesrv-2.1.6.ebuild59
6 files changed, 141 insertions, 0 deletions
diff --git a/net-misc/linesrv/files/digest-linesrv-2.1.6 b/net-misc/linesrv/files/digest-linesrv-2.1.6
new file mode 100644
index 000000000000..0ea17a936d92
--- /dev/null
+++ b/net-misc/linesrv/files/digest-linesrv-2.1.6
@@ -0,0 +1 @@
+MD5 bc4fc987fc57ad21860fce4ec5c53e66 linesrv-2.1.6.src.tar.bz2 122880
diff --git a/net-misc/linesrv/files/lcshutdown.pam b/net-misc/linesrv/files/lcshutdown.pam
new file mode 100644
index 000000000000..082f6758d460
--- /dev/null
+++ b/net-misc/linesrv/files/lcshutdown.pam
@@ -0,0 +1,4 @@
+# All clients that are able to send a shutdown command should
+# already be authenticated with the pam service linecontrol.
+# so in this service we do only an additional check.
+auth required pam_listfile.so item=user sense=allow file=/etc/linesrv.shutdown.users onerr=fail
diff --git a/net-misc/linesrv/files/linecontrol.pam b/net-misc/linesrv/files/linecontrol.pam
new file mode 100644
index 000000000000..21ced2079097
--- /dev/null
+++ b/net-misc/linesrv/files/linecontrol.pam
@@ -0,0 +1,5 @@
+# linesrv login requires auth and a valid account
+# uncomment the following line only if you have a list of allowed users in a certain file.
+#auth required pam_listfile.so item=user sense=allow file=/etc/linesrv.users onerr=fail
+auth required pam_pwdb.so
+account required pam_pwdb.so
diff --git a/net-misc/linesrv/files/linesrv.conf b/net-misc/linesrv/files/linesrv.conf
new file mode 100644
index 000000000000..8ba666ab8a23
--- /dev/null
+++ b/net-misc/linesrv/files/linesrv.conf
@@ -0,0 +1,46 @@
+#
+# LineServer Global Settings
+#
+bind_to 192.168.1.1
+port 16007
+user_accounting yes
+logfile /var/log/linesrv/linesrv.log
+pidfile /var/run/linesrv.pid
+html_status /usr/share/linesrv/logpipe
+filter_type allow
+filter_mask 127.0.0.0 255.255.255.0
+#filter_mask 192.168.1.1 255.255.255.0
+#filter_mask 192.168.2.0 255.255.255.0
+#filter_mask 192.168.3.0 255.255.255.0
+#filter_mask 192.168.4.0 255.255.255.0
+script_shutdown /usr/share/linesrv/halt-wrapper
+limit_shutdown_mask 127.0.0.0 255.255.255.0
+#limit_shutdown_ip 192.168.1.1
+#limit_shutdown_ip 192.168.0.1 192.168.0.4
+#limit_shutdown_ip 192.168.1.1 192.168.1.12
+lptstatus off
+send_throughput yes
+#script_dn /etc/ppp/ppp-dn
+#script_esc /etc/ppp/ppp-esc
+#client_online /etc/ppp/client_has_gone_online
+#client_offline /etc/ppp/client_has_gone_offline
+
+#
+# Sample Line Section
+#
+#line myline1
+#interface ppp0
+#con_type netdev
+#script_up /etc/ppp/isdn-on
+#script_dn /etc/ppp/isdn-off
+#line_baud_up 33600
+#line_baud_down 56400
+#allow_manually yes
+#con_timeout 30
+#script_esc /etc/ppp/isdn-esc
+##con_down_timeout 10
+#line_locking no
+#pinger no
+#pinger_hostname linecontrol.sourceforge.net
+#pinger_interval 120
+#pinger_datasize 60
diff --git a/net-misc/linesrv/files/linesrv.rc6 b/net-misc/linesrv/files/linesrv.rc6
new file mode 100644
index 000000000000..78f794e3e790
--- /dev/null
+++ b/net-misc/linesrv/files/linesrv.rc6
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ ! -e /etc/linesrv.conf ] ; then
+ eerror "You need an /etc/linesrv.conf file first"
+ eerror "There is a sample in /usr/share/doc/linesrv
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting linesrv"
+ start-stop-daemon --start --quiet --exec /usr/sbin/linesrv -- ${LINESRV_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping linesrv"
+ start-stop-daemon --stop --signal 3 --quiet --pidfile /var/run/linesrv.pid
+ eend $?
+}
diff --git a/net-misc/linesrv/linesrv-2.1.6.ebuild b/net-misc/linesrv/linesrv-2.1.6.ebuild
new file mode 100644
index 000000000000..a95a16d43541
--- /dev/null
+++ b/net-misc/linesrv/linesrv-2.1.6.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/linesrv/linesrv-2.1.6.ebuild,v 1.1 2001/11/28 03:48:15 woodchip Exp $
+
+DESCRIPTION="Client/Server system to control the Internet link of a masquerading server"
+HOMEPAGE="http://linecontrol.sourceforge.net"
+
+S=${WORKDIR}/linesrv-2.1
+SRC_URI="http://prdownloads.sourceforge.net/linecontrol/${PN}-${PV}.src.tar.bz2"
+#windows client: http://people.ee.ethz.ch/~sfuchs/LineControl/down/wlc-122.zip
+
+DEPEND="virtual/glibc pam? ( >=sys-libs/pam-0.75 )"
+RDEPEND="virtual/glibc net-www/apache"
+
+[ -z "$HTTPD_ROOT" ] && HTTPD_ROOT=/usr/local/httpd
+
+src_unpack() {
+
+ unpack ${PN}-${PV}.src.tar.bz2
+}
+
+src_compile() {
+
+ local myconf
+ use pam || myconf="--disable-pamauth"
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --host=${CHOST} ${myconf} || die "bad configure"
+
+ make CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+
+ dodir /usr/share/linesrv /var/log/linesrv ${HTTPD_ROOT}/htdocs/lclog
+
+ dosbin server/linesrv
+
+ exeinto ${HTTPD_ROOT}/cgi-bin ; doexe lclog/lclog htmlstatus/htmlstatus
+ chmod 4755 ${HTTPD_ROOT}/cgi-bin/htmlstatus
+ insinto ${HTTPD_ROOT}/htdocs/lclog ; doins lclog/html/*
+
+ mknod ${D}/usr/share/linesrv/logpipe p
+ exeinto /usr/share/linesrv ; doexe server/config/complete_syntax/halt-wrapper
+
+ dodoc server/{INSTALL,NEWS,README}
+ newdoc htmlstatus/README README.htmlstatus
+ newdoc lclog/INSTALL INSTALL.lclog
+ docinto complete_syntax ; dodoc server/config/complete_syntax/*
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/linesrv.rc6 linesrv
+ insinto /etc ; newins ${FILESDIR}/linesrv.conf linesrv.conf.sample
+ insinto /etc/pam.d ; newins ${FILESDIR}/linecontrol.pam linecontrol
+ insinto /etc/pam.d ; newins ${FILESDIR}/lcshutdown.pam lcshutdown
+}