summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2011-01-12 23:34:51 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2011-01-12 23:34:51 +0000
commit1b23726355454337ba8333cc8f63c60744b6abd6 (patch)
tree3bf8f0346077d96f0946a3b1461a42191dd9fe98 /net-misc/ksshaskpass/ksshaskpass-0.5.3.ebuild
parentold (diff)
downloadgentoo-2-1b23726355454337ba8333cc8f63c60744b6abd6.tar.gz
gentoo-2-1b23726355454337ba8333cc8f63c60744b6abd6.tar.bz2
gentoo-2-1b23726355454337ba8333cc8f63c60744b6abd6.zip
Initial commit, ebuild by Leo, Jean-Baptiste Rouault and Vadim Fint, bug 159684
(Portage version: 2.2.0_alpha14/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/ksshaskpass/ksshaskpass-0.5.3.ebuild')
-rw-r--r--net-misc/ksshaskpass/ksshaskpass-0.5.3.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/net-misc/ksshaskpass/ksshaskpass-0.5.3.ebuild b/net-misc/ksshaskpass/ksshaskpass-0.5.3.ebuild
new file mode 100644
index 000000000000..8877cf120ea7
--- /dev/null
+++ b/net-misc/ksshaskpass/ksshaskpass-0.5.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ksshaskpass/ksshaskpass-0.5.3.ebuild,v 1.1 2011/01/12 23:34:51 tampakrap Exp $
+
+EAPI="3"
+
+inherit kde4-base
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration."
+HOMEPAGE="http://www.kde-apps.org/content/show.php?content=50971&forumpage=0"
+SRC_URI="http://www.kde-apps.org/CONTENT/content-files/50971-${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="debug"
+
+RDEPEND="net-misc/openssh"
+
+CFG="ksshaskpass.sh"
+
+src_prepare() {
+ STARTUPDIR=/etc/kde/startup
+ SHUTDOWNDIR=/etc/kde/shutdown
+
+ kde4-base_src_prepare
+}
+
+src_install() {
+ kde4-base_src_install
+
+ cat <<-EOF > "${T}/${CFG}"
+export SSH_ASKPASS="${PREFIX}/bin/ksshaskpass"
+EOF
+ insinto "${STARTUPDIR}"
+ doins "${T}/${CFG}"
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ elog
+ elog "In order to have ksshagent start at kde startup,"
+ elog "edit ${STARTUPDIR}/agent-startup.sh and uncomment"
+ elog "the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in ${SHUTDOWNDIR}/agent-shutdown.sh to"
+ elog "properly kill the agent when the session ends."
+ elog
+ elog "${P} has been installed as your default askpass application in KDE4 session."
+ elog "If it's not desired, point the one you want to use in ${STARTUPDIR}/${CFG}"
+ elog
+}