summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-05-27 10:27:54 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-05-27 10:27:54 +0000
commitab6235e253f496c7f363cc61a8b558cf68c4eb59 (patch)
tree985fac1b6dc7aa02f59e86acefad6ed8ece6e111 /net-misc/kphone
parentAdded English and German <longdescription>. (diff)
downloadgentoo-2-ab6235e253f496c7f363cc61a8b558cf68c4eb59.tar.gz
gentoo-2-ab6235e253f496c7f363cc61a8b558cf68c4eb59.tar.bz2
gentoo-2-ab6235e253f496c7f363cc61a8b558cf68c4eb59.zip
New version (#91773). Remove KDE dependency as kphone is a Qt-only application.
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-misc/kphone')
-rw-r--r--net-misc/kphone/ChangeLog8
-rw-r--r--net-misc/kphone/files/digest-kphone-4.1.11
-rw-r--r--net-misc/kphone/files/kphone-4.1.1-gcc34.patch13
-rw-r--r--net-misc/kphone/kphone-4.1.1.ebuild44
-rw-r--r--net-misc/kphone/metadata.xml2
5 files changed, 66 insertions, 2 deletions
diff --git a/net-misc/kphone/ChangeLog b/net-misc/kphone/ChangeLog
index f38d071b9dbc..cd4ca9174c10 100644
--- a/net-misc/kphone/ChangeLog
+++ b/net-misc/kphone/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/kphone
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/kphone/ChangeLog,v 1.30 2005/01/18 19:05:51 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/kphone/ChangeLog,v 1.31 2005/05/27 10:27:54 greg_g Exp $
+
+*kphone-4.1.1 (27 May 2005)
+
+ 27 May 2005; Gregorio Guidi <greg_g@gentoo.org>
+ +files/kphone-4.1.1-gcc34.patch, metadata.xml, +kphone-4.1.1.ebuild:
+ New version (#91773). Remove KDE dependency as kphone is a Qt-only application.
18 Jan 2005; Gustavo Zacarias <gustavoz@gentoo.org> kphone-4.1.0.ebuild:
Stable on sparc
diff --git a/net-misc/kphone/files/digest-kphone-4.1.1 b/net-misc/kphone/files/digest-kphone-4.1.1
new file mode 100644
index 000000000000..a1184f95be70
--- /dev/null
+++ b/net-misc/kphone/files/digest-kphone-4.1.1
@@ -0,0 +1 @@
+MD5 b95252f527e2fbe107f5d3c1159e2e25 kphone-4.1.1.tar.gz 291907
diff --git a/net-misc/kphone/files/kphone-4.1.1-gcc34.patch b/net-misc/kphone/files/kphone-4.1.1-gcc34.patch
new file mode 100644
index 000000000000..830c6cc30107
--- /dev/null
+++ b/net-misc/kphone/files/kphone-4.1.1-gcc34.patch
@@ -0,0 +1,13 @@
+diff -Nur kphone.orig/kphone/dspoutalsa.cpp kphone/kphone/dspoutalsa.cpp
+--- kphone.orig/kphone/dspoutalsa.cpp 2005-04-22 14:09:34.000000000 +0200
++++ kphone/kphone/dspoutalsa.cpp 2005-05-27 11:57:48.000000000 +0200
+@@ -189,7 +189,8 @@
+ #ifdef ALSADEBUG
+ fprintf(stderr, "write %d instead of %d frames !\n", rc, (int)count/2);
+ #endif
+- (int8_t*) buf += rc*4;
++ int8_t *buff = (int8_t*) buf;
++ buff += rc*4;
+ count -= rc*2;
+ continue;
+ }
diff --git a/net-misc/kphone/kphone-4.1.1.ebuild b/net-misc/kphone/kphone-4.1.1.ebuild
new file mode 100644
index 000000000000..343f3773c346
--- /dev/null
+++ b/net-misc/kphone/kphone-4.1.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/kphone/kphone-4.1.1.ebuild,v 1.1 2005/05/27 10:27:54 greg_g Exp $
+
+inherit eutils kde-functions
+
+DESCRIPTION="A SIP user agent for Linux, with which you can initiate VoIP connections over the Internet."
+HOMEPAGE="http://www.wirlab.net/kphone/index.html"
+SRC_URI="http://www.wirlab.net/kphone/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~sparc ~ppc"
+IUSE="alsa debug jack"
+
+S=${WORKDIR}/${PN}
+
+DEPEND="dev-libs/openssl
+ alsa? ( media-libs/alsa-lib )
+ jack? ( media-sound/jack-audio-connection-kit )"
+
+need-qt 3
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Fix compilation with gcc-3.4. Applied in CVS.
+ epatch "${FILESDIR}/${P}-gcc34.patch"
+}
+
+
+src_compile() {
+ local myconf="$(use_enable alsa) $(use_enable jack)
+ $(use_enable debug)"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc CHANGES README
+}
diff --git a/net-misc/kphone/metadata.xml b/net-misc/kphone/metadata.xml
index 8d1e86a9cefb..dc439f7e84f5 100644
--- a/net-misc/kphone/metadata.xml
+++ b/net-misc/kphone/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>kde</herd>
+<herd>qt</herd>
</pkgmetadata>