summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Wever <weeve@gentoo.org>2003-10-31 22:01:34 +0000
committerJason Wever <weeve@gentoo.org>2003-10-31 22:01:34 +0000
commit933e1c647ce1fb0328d8f9c19fedd4d57c56d598 (patch)
treeb5408574b5defc9e3b45137dfc666479ed1395fc /net-misc/jigdo
parentcap => caps, consulted with a user who says `cap` might be misleading..e.g. b... (diff)
downloadgentoo-2-933e1c647ce1fb0328d8f9c19fedd4d57c56d598.tar.gz
gentoo-2-933e1c647ce1fb0328d8f9c19fedd4d57c56d598.tar.bz2
gentoo-2-933e1c647ce1fb0328d8f9c19fedd4d57c56d598.zip
Added fix for bug #32029. Thanks to robbat2 :)
Diffstat (limited to 'net-misc/jigdo')
-rw-r--r--net-misc/jigdo/ChangeLog6
-rw-r--r--net-misc/jigdo/Manifest5
-rw-r--r--net-misc/jigdo/files/jigdo-gentoo-db3.patch11
-rw-r--r--net-misc/jigdo/jigdo-0.7.0.ebuild22
4 files changed, 34 insertions, 10 deletions
diff --git a/net-misc/jigdo/ChangeLog b/net-misc/jigdo/ChangeLog
index 9ed6996a42f5..76475c766fff 100644
--- a/net-misc/jigdo/ChangeLog
+++ b/net-misc/jigdo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/jigdo
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/jigdo/ChangeLog,v 1.1 2003/07/30 00:08:25 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/jigdo/ChangeLog,v 1.2 2003/10/31 22:01:32 weeve Exp $
+
+ 31 Oct 2003; Jason Wever <weeve@gentoo.org> jigdo-0.7.0.ebuild,
+ files/jigdo-gentoo-db3.patch:
+ Added fix for bug #32029. Thanks to robbat2 :)
*jigdo-0.7.0 (29 Jul 2003)
diff --git a/net-misc/jigdo/Manifest b/net-misc/jigdo/Manifest
index 27cf6c7a36e7..2957027feffd 100644
--- a/net-misc/jigdo/Manifest
+++ b/net-misc/jigdo/Manifest
@@ -1,5 +1,6 @@
-MD5 5376ada9f20aa89d511045bbae481ad0 ChangeLog 381
-MD5 691ca6f42923b89798bb35d42fcd434b jigdo-0.7.0.ebuild 1231
+MD5 27ad3d5da2d9a7a17e69c3a815dab58f ChangeLog 530
+MD5 e790afc0f56257c4cb357dea7d5a48da jigdo-0.7.0.ebuild 1451
MD5 de7df99d5dcb2fa3a99617144a7e6257 metadata.xml 637
MD5 ba134b43460d2b9a0378c9ccbfc4fc6e files/digest-jigdo-0.7.0 64
MD5 c49b767331699f22f72518da29438c56 files/makefile.patch 524
+MD5 11774b7665bf0dab10a58d268dcd8b9e files/jigdo-gentoo-db3.patch 311
diff --git a/net-misc/jigdo/files/jigdo-gentoo-db3.patch b/net-misc/jigdo/files/jigdo-gentoo-db3.patch
new file mode 100644
index 000000000000..f3202d1a777f
--- /dev/null
+++ b/net-misc/jigdo/files/jigdo-gentoo-db3.patch
@@ -0,0 +1,11 @@
+--- src/cachefile.hh.orig 2003-10-31 16:17:58.000000000 -0500
++++ src/cachefile.hh 2003-10-31 16:18:17.000000000 -0500
+@@ -48,7 +48,7 @@
+ #include <time.h> /* for time_t */
+
+ #if HAVE_LIBDB
+-#include <db.h>
++#include <db3/db.h>
+ #include <stdlib.h> /* free() */
+ #include <string.h> /* memcpy(), memset() */
+
diff --git a/net-misc/jigdo/jigdo-0.7.0.ebuild b/net-misc/jigdo/jigdo-0.7.0.ebuild
index a02390114394..581675989768 100644
--- a/net-misc/jigdo/jigdo-0.7.0.ebuild
+++ b/net-misc/jigdo/jigdo-0.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/jigdo/jigdo-0.7.0.ebuild,v 1.2 2003/09/05 22:01:48 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/jigdo/jigdo-0.7.0.ebuild,v 1.3 2003/10/31 22:01:32 weeve Exp $
inherit eutils
@@ -10,25 +10,33 @@ SRC_URI="http://home.in.tum.de/~atterer/jigdo/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~sparc"
+KEYWORDS="~x86 ~sparc ~ppc"
-IUSE="gtk nls"
+IUSE="gtk nls berkdb"
DEPEND="gtk? ( >=gtk+-2.0.6 )
nls? ( sys-devel/gettext )
+ berkdb? ( =sys-libs/db-3* )
>=libwww-5.3.2"
src_compile() {
-local myconf
+ local myconf
- use nls || myconf="--disable-nls"
- use gtk || myconf="--without-libdb --without-gui"
+ # Fix for bug #32029.
+ if [ `use berkdb` ]; then
+ cd ${S}
+ epatch ${FILESDIR}/jigdo-gentoo-db3.patch
+ fi
+
+ use nls || myconf="${myconf} --disable-nls"
+ use gtk || myconf="${myconf} --without-libdb --without-gui"
+ use berkdb || myconf="${myconf} --without-libdb"
./configure \
--host=${CHOST} \
--prefix=/usr \
--infodir=/usr/share/info \
- --mandir=/usr/share/man $myconf \
+ --mandir=/usr/share/man ${myconf} \
--datadir=/usr/share || die "./configure failed"
# Patch the Makefile so that when jidgo is installed, jigdo-lite has