summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-01-12 16:41:06 +0000
committerPeter Volkov <pva@gentoo.org>2009-01-12 16:41:06 +0000
commite01c2cee0ac63c55e1d125db6f12d1874c80054f (patch)
tree073437ccf6c489020584ae06df26e9e2a9543e02 /net-misc/ipv6calc/ipv6calc-0.72.1.ebuild
parentMarking hunspell-1.2.8 ppc64 for bug 254634 (diff)
downloadgentoo-2-e01c2cee0ac63c55e1d125db6f12d1874c80054f.tar.gz
gentoo-2-e01c2cee0ac63c55e1d125db6f12d1874c80054f.tar.bz2
gentoo-2-e01c2cee0ac63c55e1d125db6f12d1874c80054f.zip
Version bump. Removed not to became stable version.
(Portage version: 2.2_rc20/cvs/Linux 2.6.26-openvz.git-89451f9 i686)
Diffstat (limited to 'net-misc/ipv6calc/ipv6calc-0.72.1.ebuild')
-rw-r--r--net-misc/ipv6calc/ipv6calc-0.72.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-misc/ipv6calc/ipv6calc-0.72.1.ebuild b/net-misc/ipv6calc/ipv6calc-0.72.1.ebuild
new file mode 100644
index 000000000000..9d70cd63310d
--- /dev/null
+++ b/net-misc/ipv6calc/ipv6calc-0.72.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ipv6calc/ipv6calc-0.72.1.ebuild,v 1.1 2009/01/12 16:41:06 pva Exp $
+
+inherit fixheadtails
+
+DESCRIPTION="IPv6 address calculator"
+HOMEPAGE="http://www.deepspace6.net/projects/ipv6calc.html"
+SRC_URI="ftp://ftp.bieringer.de/pub/linux/IPv6/ipv6calc/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="geoip"
+
+DEPEND="geoip? ( >=dev-libs/geoip-1.4.1 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ ht_fix_file configure
+}
+
+src_compile() {
+ econf $(use_enable geoip)
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog CREDITS README TODO USAGE || die
+}