summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-02-03 22:34:16 +0000
committerMike Frysinger <vapier@gentoo.org>2007-02-03 22:34:16 +0000
commitced28f5e30cbc931db3498685ce117267e3b7a9d (patch)
tree107f079e42356df7fedafa7a2886bad51bb9e9a9 /net-misc/iputils
parentRemove old version. (diff)
downloadgentoo-2-ced28f5e30cbc931db3498685ce117267e3b7a9d.tar.gz
gentoo-2-ced28f5e30cbc931db3498685ce117267e3b7a9d.tar.bz2
gentoo-2-ced28f5e30cbc931db3498685ce117267e3b7a9d.zip
Version bump.
(Portage version: 2.1.2-r6)
Diffstat (limited to 'net-misc/iputils')
-rw-r--r--net-misc/iputils/ChangeLog10
-rw-r--r--net-misc/iputils/files/digest-iputils-200702023
-rw-r--r--net-misc/iputils/files/iputils-20070202-makefile.patch35
-rw-r--r--net-misc/iputils/iputils-20070202.ebuild76
4 files changed, 122 insertions, 2 deletions
diff --git a/net-misc/iputils/ChangeLog b/net-misc/iputils/ChangeLog
index 26e149ca8194..3dbfa0dd4b57 100644
--- a/net-misc/iputils/ChangeLog
+++ b/net-misc/iputils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/iputils
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/iputils/ChangeLog,v 1.44 2006/12/21 05:34:25 vapier Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/iputils/ChangeLog,v 1.45 2007/02/03 22:34:16 vapier Exp $
+
+*iputils-20070202 (03 Feb 2007)
+
+ 03 Feb 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/iputils-20070202-makefile.patch, +iputils-20070202.ebuild:
+ Version bump.
21 Dec 2006; Mike Frysinger <vapier@gentoo.org> iputils-20060512.ebuild:
Only generate man pages for USE=doc until next release where they include
diff --git a/net-misc/iputils/files/digest-iputils-20070202 b/net-misc/iputils/files/digest-iputils-20070202
new file mode 100644
index 000000000000..2884854768ab
--- /dev/null
+++ b/net-misc/iputils/files/digest-iputils-20070202
@@ -0,0 +1,3 @@
+MD5 1d38fb3cfc2b71496e43cf646bfc1d6e iputils-s20070202.tar.bz2 88678
+RMD160 f6c3600a350537210d6ca43d1b82806bc0fa88f7 iputils-s20070202.tar.bz2 88678
+SHA256 86f9f9970b4e2258e5e985d4d74b6ba9145410006c73b6482170525deb0c1957 iputils-s20070202.tar.bz2 88678
diff --git a/net-misc/iputils/files/iputils-20070202-makefile.patch b/net-misc/iputils/files/iputils-20070202-makefile.patch
new file mode 100644
index 000000000000..9426053a16b4
--- /dev/null
+++ b/net-misc/iputils/files/iputils-20070202-makefile.patch
@@ -0,0 +1,35 @@
+--- Makefile
++++ Makefile
+@@ -1,20 +1,17 @@
+ # Path to parent kernel include files directory
+ LIBC_INCLUDE=/usr/include
+
+-DEFINES=
+-
+ #options if you have a bind>=4.9.4 libresolv (or, maybe, glibc)
+ LDLIBS=-lresolv
+-ADDLIB=
+
+ #options if you compile with libc5, and without a bind>=4.9.4 libresolv
+ # NOT AVAILABLE. Please, use libresolv.
+
+-CC=gcc
+ # What a pity, all new gccs are buggy and -Werror does not work. Sigh.
+ #CCOPT=-D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall -g -Werror
+-CCOPT=-D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall -g
+-CFLAGS=$(CCOPT) $(GLIBCFIX) $(DEFINES)
++CFLAGS ?= -O2 -g
++CFLAGS += -Wstrict-prototypes -Wall
++CPPFLAGS += -D_GNU_SOURCE
+
+ IPV4_TARGETS=tracepath ping clockdiff rdisc arping tftpd rarpd
+ IPV6_TARGETS=tracepath6 traceroute6 ping6
+@@ -35,7 +32,7 @@
+ rdisc_srv: rdisc_srv.o
+
+ rdisc_srv.o: rdisc.c
+- $(CC) $(CFLAGS) -DRDISC_SERVER -o rdisc_srv.o rdisc.c
++ $(CC) $(CFLAGS) $(CPPFLAGS) -DRDISC_SERVER -o rdisc_srv.o rdisc.c
+
+
+ check-kernel:
diff --git a/net-misc/iputils/iputils-20070202.ebuild b/net-misc/iputils/iputils-20070202.ebuild
new file mode 100644
index 000000000000..a56f8ab6c6ea
--- /dev/null
+++ b/net-misc/iputils/iputils-20070202.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/iputils/iputils-20070202.ebuild,v 1.1 2007/02/03 22:34:16 vapier Exp $
+
+inherit flag-o-matic eutils toolchain-funcs
+
+DESCRIPTION="Network monitoring tools including ping and ping6"
+HOMEPAGE="http://www.skbuff.net/iputils/"
+SRC_URI="http://www.skbuff.net/iputils/iputils-s${PV}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static ipv6 doc"
+
+DEPEND="virtual/os-headers
+ doc? (
+ app-text/openjade
+ dev-perl/SGMLSpm
+ app-text/docbook-sgml-dtd
+ app-text/docbook-sgml-utils
+ )"
+RDEPEND=""
+
+S=${WORKDIR}/${PN}-s${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-021109-gcc34.patch
+ epatch "${FILESDIR}"/021109-uclibc-no-ether_ntohost.patch
+ epatch "${FILESDIR}"/${PN}-20070202-makefile.patch
+ epatch "${FILESDIR}"/${PN}-20060512-kernel-ifaddr.patch
+ epatch "${FILESDIR}"/${PN}-20060512-linux-headers.patch
+
+ use static && append-ldflags -static
+ use ipv6 || sed -i -e 's:IPV6_TARGETS=:#IPV6_TARGETS=:' Makefile
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "make main failed"
+
+ # We include the extra check for docbook2html
+ # because when we emerge from a stage1/stage2,
+ # it may not exist #23156
+ if use doc && type -p docbook2html ; then
+ emake -j1 html man || die
+ fi
+}
+
+src_install() {
+ into /
+ dobin ping || die "ping"
+ use ipv6 && dobin ping6
+ dosbin arping || die "arping"
+ into /usr
+ dosbin tracepath || die "tracepath"
+ use ipv6 && dosbin trace{path,route}6
+ dosbin clockdiff rarpd rdisc ipg tftpd || die "misc sbin"
+
+ fperms 4711 /bin/ping
+ use ipv6 && fperms 4711 /bin/ping6 /usr/sbin/traceroute6
+
+ dodoc INSTALL RELNOTES
+
+ if use doc ; then
+ rm -f doc/setkey.8
+ use ipv6 \
+ && dosym ping.8 /usr/share/man/man8/ping6.8 \
+ || rm -f doc/*6.8
+ doman doc/*.8
+
+ dohtml doc/*.html
+ fi
+}