summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-04 03:52:15 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-04 03:52:15 +0000
commita7e5f41d694669569eda42646f9312d72a48472f (patch)
tree77aa752bd184f6c0735d36db61514b9235e9a740 /net-misc/iputils
parentold (Manifest recommit) (diff)
downloadgentoo-2-a7e5f41d694669569eda42646f9312d72a48472f.tar.gz
gentoo-2-a7e5f41d694669569eda42646f9312d72a48472f.tar.bz2
gentoo-2-a7e5f41d694669569eda42646f9312d72a48472f.zip
Add support to ipg for newer kernels #71756 by Christoph M.
Diffstat (limited to 'net-misc/iputils')
-rw-r--r--net-misc/iputils/ChangeLog8
-rw-r--r--net-misc/iputils/files/021109-ipg-linux-2.6.patch45
-rw-r--r--net-misc/iputils/iputils-021109-r3.ebuild5
3 files changed, 54 insertions, 4 deletions
diff --git a/net-misc/iputils/ChangeLog b/net-misc/iputils/ChangeLog
index 6f5e2b2e5d29..431cf3e544ea 100644
--- a/net-misc/iputils/ChangeLog
+++ b/net-misc/iputils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/iputils
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/iputils/ChangeLog,v 1.33 2004/10/07 00:47:06 lv Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/iputils/ChangeLog,v 1.34 2005/01/04 03:52:15 vapier Exp $
+
+ 03 Jan 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/021109-ipg-linux-2.6.patch, iputils-021109-r3.ebuild:
+ Add support to ipg for newer kernels #71756 by Christoph M.
06 Oct 2004; Travis Tilley <lv@gentoo.org>
+files/iputils-021109-linux-udp-header.patch, iputils-021109-r3.ebuild:
diff --git a/net-misc/iputils/files/021109-ipg-linux-2.6.patch b/net-misc/iputils/files/021109-ipg-linux-2.6.patch
new file mode 100644
index 000000000000..550a8d584c78
--- /dev/null
+++ b/net-misc/iputils/files/021109-ipg-linux-2.6.patch
@@ -0,0 +1,45 @@
+In newer kernels, the pg file has moved around in /proc/.
+
+http://bugs.gentoo.org/show_bug.cgi?id=71756
+
+--- iputils/ipg.orig 2005-01-03 22:47:26.314393976 -0500
++++ iputils/ipg 2005-01-03 22:49:09.686679000 -0500
+@@ -1,21 +1,31 @@
+-#! /bin/bash
++#!/bin/bash
+
+-modprobe pg3
++modprobe pg3 >& /dev/null
++modprobe pktgen >& /dev/null
++
++PGDEV=/proc/net/pg
++if [[ ! -e ${PGDEV} ]] ; then
++ PGDEV=/proc/net/pktgen/pg0
++ if [[ ! -e ${PGDEV} ]] ; then
++ echo "Couldn't not locate pg in /proc/net :("
++ exit 1
++ fi
++fi
+
+ function pgset() {
+ local result
+
+- echo $1 > /proc/net/pg
++ echo $1 > ${PGDEV}
+
+- result=`cat /proc/net/pg | fgrep "Result: OK:"`
++ result=`cat ${PGDEV} | fgrep "Result: OK:"`
+ if [ "$result" = "" ]; then
+- cat /proc/net/pg | fgrep Result:
++ cat ${PGDEV} | fgrep Result:
+ fi
+ }
+
+ function pg() {
+- echo inject > /proc/net/pg
+- cat /proc/net/pg
++ echo inject > ${PGDEV}
++ cat ${PGDEV}
+ }
+
+ pgset "odev eth0"
diff --git a/net-misc/iputils/iputils-021109-r3.ebuild b/net-misc/iputils/iputils-021109-r3.ebuild
index dc233582596a..adbf10c124f5 100644
--- a/net-misc/iputils/iputils-021109-r3.ebuild
+++ b/net-misc/iputils/iputils-021109-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/iputils/iputils-021109-r3.ebuild,v 1.13 2004/12/08 01:00:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/iputils/iputils-021109-r3.ebuild,v 1.14 2005/01/04 03:52:15 vapier Exp $
inherit flag-o-matic gnuconfig eutils toolchain-funcs
@@ -38,6 +38,7 @@ src_unpack() {
epatch ${FILESDIR}/${PV}-gcc34.patch
epatch ${FILESDIR}/${PV}-no-pfkey-search.patch
+ epatch ${FILESDIR}/${PV}-ipg-linux-2.6.patch #71756
# make iputils work with newer glibc snapshots
epatch ${FILESDIR}/${P}-linux-udp-header.patch