summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2009-01-27 20:23:46 +0000
committerThilo Bangert <bangert@gentoo.org>2009-01-27 20:23:46 +0000
commit4394a29778b57ba3d9d943248c250340c4356c2a (patch)
treed191586b105a099d6249dbe9e020055271b5fb34 /net-misc/ipsvd/ipsvd-1.0.0.ebuild
parentkeyworded ~arch for ppc64, bug 255713 (diff)
downloadgentoo-2-4394a29778b57ba3d9d943248c250340c4356c2a.tar.gz
gentoo-2-4394a29778b57ba3d9d943248c250340c4356c2a.tar.bz2
gentoo-2-4394a29778b57ba3d9d943248c250340c4356c2a.zip
version bump
(Portage version: 2.2_rc20/cvs/Linux 2.6.28-gentoo i686)
Diffstat (limited to 'net-misc/ipsvd/ipsvd-1.0.0.ebuild')
-rw-r--r--net-misc/ipsvd/ipsvd-1.0.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-misc/ipsvd/ipsvd-1.0.0.ebuild b/net-misc/ipsvd/ipsvd-1.0.0.ebuild
new file mode 100644
index 000000000000..83c717502f5e
--- /dev/null
+++ b/net-misc/ipsvd/ipsvd-1.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ipsvd/ipsvd-1.0.0.ebuild,v 1.1 2009/01/27 20:23:46 bangert Exp $
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="ipsvd is a set of internet protocol service daemons for Unix."
+HOMEPAGE="http://smarden.org/ipsvd/"
+SRC_URI="http://smarden.org/ipsvd/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static"
+
+DEPEND="virtual/libc"
+PROVIDE="virtual/inetd"
+
+S="${WORKDIR}/net/${P}"
+
+src_compile() {
+ cd "${S}"/src
+ if use static ; then
+ append-ldflags -static
+ fi
+
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+ emake || die "make failed"
+}
+
+src_install() {
+ dobin src/{tcpsvd,udpsvd,ipsvd-cdb} || die "dobin"
+ dodoc package/{CHANGES,README}
+
+ dohtml doc/*.html
+ doman man/ipsvd-instruct.5 man/ipsvd.7 man/udpsvd.8 \
+ man/tcpsvd.8 man/ipsvd-cdb.8
+}