summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2009-03-30 17:20:05 +0000
committerChristian Faulhammer <fauli@gentoo.org>2009-03-30 17:20:05 +0000
commitc38c76a37178426f6315944c0f6ff71098b55a2a (patch)
treebfe9a807c040af665c199c030f6b226839120f00 /net-misc/icaclient
parentVersion bump. (diff)
downloadgentoo-2-c38c76a37178426f6315944c0f6ff71098b55a2a.tar.gz
gentoo-2-c38c76a37178426f6315944c0f6ff71098b55a2a.tar.bz2
gentoo-2-c38c76a37178426f6315944c0f6ff71098b55a2a.zip
Version bump (see bug 263054 by ulm), ebuild changes include:
* Support for German and Japanese through the LINGUAS system (though not perfect) * fetch restrictions as upstream does not provide a direct download link * introduce motif USE flag: OpenMotif is just needed for the connection client not for the Netscape plugin * introduce nsplugin USE flag for people to only install the Netscape plugin * error out if none of the above is set * Simplify path handling by extending S definition * remove workaround for OpenMotif 2.3 (not needed anymore) (Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'net-misc/icaclient')
-rw-r--r--net-misc/icaclient/ChangeLog27
-rw-r--r--net-misc/icaclient/icaclient-11.0.ebuild130
-rw-r--r--net-misc/icaclient/metadata.xml3
3 files changed, 158 insertions, 2 deletions
diff --git a/net-misc/icaclient/ChangeLog b/net-misc/icaclient/ChangeLog
index 60634764b502..3555bfc6f7d5 100644
--- a/net-misc/icaclient/ChangeLog
+++ b/net-misc/icaclient/ChangeLog
@@ -1,6 +1,29 @@
# ChangeLog for net-misc/icaclient
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/icaclient/ChangeLog,v 1.60 2008/11/28 12:35:32 fauli Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/icaclient/ChangeLog,v 1.61 2009/03/30 17:20:05 fauli Exp $
+
+*icaclient-11.0 (30 Mar 2009)
+
+ 30 Mar 2009; Christian Faulhammer <fauli@gentoo.org> metadata.xml,
+ +icaclient-11.0.ebuild:
+ Version bump (see bug 263054 by ulm), ebuild changes include:
+
+ * Support for German and Japanese through the LINGUAS system (though not
+ perfect)
+
+ * fetch restrictions as upstream does not provide a direct download link
+
+ * introduce motif USE flag: OpenMotif is just needed for the connection
+ client not for the Netscape plugin
+
+ * introduce nsplugin USE flag for people to only install the Netscape
+ plugin
+
+ * error out if none of the above is set
+
+ * Simplify path handling by extending S definition
+
+ * remove workaround for OpenMotif 2.3 (not needed anymore)
28 Nov 2008; Christian Faulhammer <fauli@gentoo.org> metadata.xml:
change my email address
diff --git a/net-misc/icaclient/icaclient-11.0.ebuild b/net-misc/icaclient/icaclient-11.0.ebuild
new file mode 100644
index 000000000000..f7fbbeaf9fc8
--- /dev/null
+++ b/net-misc/icaclient/icaclient-11.0.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/icaclient/icaclient-11.0.ebuild,v 1.1 2009/03/30 17:20:05 fauli Exp $
+
+EAPI=1
+
+inherit eutils multilib rpm
+
+DESCRIPTION="ICA Client for Citrix Presentation servers"
+HOMEPAGE="http://www.citrix.com/"
+# There is no direct download link from upstream, see pkg_nofetch()
+SRC_URI="ICAClient-11.0-1.i386.rpm"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="linguas_de linguas_ja +motif nsplugin"
+RESTRICT="mirror strip userpriv fetch"
+
+QA_TEXTRELS="opt/ICAClient/VDSCARD.DLL
+ opt/ICAClient/TW1.DLL
+ opt/ICAClient/NDS.DLL
+ opt/ICAClient/CHARICONV.DLL
+ opt/ICAClient/PDCRYPT1.DLL
+ opt/ICAClient/VDCM.DLL
+ opt/ICAClient/libctxssl.so
+ opt/ICAClient/PDCRYPT2.DLL
+ opt/ICAClient/npica.so
+ opt/ICAClient/VDSPMIKE.DLL"
+QA_EXECSTACK="opt/ICAClient/wfica.bin
+ opt/ICAClient/libctxssl.so"
+
+RDEPEND="x11-terms/xterm
+ x86? (
+ x11-libs/libXp
+ x11-libs/libXaw
+ x11-libs/libX11
+ x11-libs/libSM
+ x11-libs/libICE
+ motif? ( >=x11-libs/openmotif-2.3.1 )
+ )
+ amd64? ( >=app-emulation/emul-linux-x86-xlibs-20080316 )"
+DEPEND=""
+S="${WORKDIR}/usr/lib/ICAClient"
+
+pkg_setup() {
+ # Binary x86 package
+ has_multilib_profile && ABI="x86"
+ if ! use motif && ! use nsplugin; then
+ eerror "At least one USE flag out of nsplugin and motif must be enabled"
+ die
+ fi
+}
+
+pkg_nofetch() {
+ elog "Download the client RPM file from http://www.citrix.com/English/SS/downloads/details.asp?downloadID=3323"
+ elog "and place it in ${DISTDIR:-/usr/portage/distfiles}."
+}
+
+src_install() {
+ dodir /opt/ICAClient
+
+ insinto /opt/ICAClient
+ doins *.DLL npica.so libctxssl.so libproxy.so nls/en/eula.txt
+
+ insinto /opt/ICAClient/config
+ doins config/* config/.* nls/en/*.ini
+
+ insinto /opt/ICAClient/config/usertemplate
+ doins config/usertemplate/*
+
+ insinto /opt/ICAClient/nls
+ dosym en /opt/ICAClient/nls/C
+
+ insinto /opt/ICAClient/nls/en
+ doins nls/en/*
+
+ insinto /opt/ICAClient/nls/en/UTF-8
+ doins nls/en/UTF-8/*
+
+ if use linguas_de; then
+ insinto /opt/ICAClient/nls/de
+ doins nls/de/*
+
+ insinto /opt/ICAClient/nls/de/UTF-8
+ doins nls/de/UTF-8/*
+ fi
+ if use linguas_ja; then
+ insinto /opt/ICAClient/nls/ja
+ doins nls/ja/*
+
+ insinto /opt/ICAClient/nls/ja/UTF-8
+ doins nls/ja/UTF-8/*
+ fi
+
+ insinto /opt/ICAClient/icons
+ doins icons/*
+
+ insinto /opt/ICAClient/keyboard
+ doins keyboard/*
+
+ insinto /opt/ICAClient/keystore/cacerts
+ doins keystore/cacerts/*
+
+ insinto /opt/ICAClient/util
+ doins util/{echo_cmd,gst_play,icalicense.sh,integrate.sh,libgstflatstm.so,nslaunch,pacexec,pac.js,sunraymac.sh,what,xcapture}
+ dosym /opt/ICAClient/util/integrate.sh /opt/ICAClient/util/disintegrate.sh
+
+ doenvd "${FILESDIR}"/10ICAClient
+
+ use nsplugin && dosym /opt/ICAClient/npica.so /usr/$(get_libdir)/nsbrowser/plugins/npica.so
+
+ if use motif; then
+ # wfica has libxcb locking bugs, so provide a wrapper. It needs to be in
+ # /opt/ICAClient to ensure it gets called, so rename wfica to wfica.bin.
+ exeinto /opt/ICAClient
+ doexe wfcmgr.bin wfica_assoc.sh wfica.sh util/wfcmgr
+ newexe wfica wfica.bin
+ make_wrapper wfica 'env LC_ALL="" LANG="" LIBXCB_ALLOW_SLOPPY_LOCK=1 /opt/ICAClient/wfica.bin' . /opt/ICAClient /opt/ICAClient
+
+ # The .desktop file included in the rpm links to /usr/lib, so we
+ # make a new one. The program gives errors and has slowdowns if
+ # the locale is not English, so strip it since it has no
+ # translations anyway
+ doicon icons/*
+ make_wrapper wfcmgr /opt/ICAClient/wfcmgr . /opt/ICAClient
+ sed -e 's:^\# Configuration items.*:. /opt/ICAClient/nls/en/wfcmgr.msg:g' -i "${D}"/opt/ICAClient/wfcmgr
+ make_desktop_entry wfcmgr 'Citrix ICA Client' manager
+ fi
+}
diff --git a/net-misc/icaclient/metadata.xml b/net-misc/icaclient/metadata.xml
index a868f2a56d66..386e8c556712 100644
--- a/net-misc/icaclient/metadata.xml
+++ b/net-misc/icaclient/metadata.xml
@@ -12,4 +12,7 @@
<longdescription lang="ja">
ICAClient は Citrix Metaframe Server への Linux 用クライアントです。
</longdescription>
+<use>
+ <flag name='motif'>Provide the motif based connection manager</flag>
+</use>
</pkgmetadata>