summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2005-03-13 08:35:46 +0000
committerStefan Knoblich <stkn@gentoo.org>2005-03-13 08:35:46 +0000
commit67f262303c2e4200187afe5acf495efb67cd97b6 (patch)
tree507abc4a4a1490d43df8d7d6727f69ca89704a27 /net-misc/howl
parentapplied joypad emulation patch from Alastair Bridgewater (bug #75391); tid (diff)
downloadgentoo-2-67f262303c2e4200187afe5acf495efb67cd97b6.tar.gz
gentoo-2-67f262303c2e4200187afe5acf495efb67cd97b6.tar.bz2
gentoo-2-67f262303c2e4200187afe5acf495efb67cd97b6.zip
Patch fixes #84030 (missing type declarations)
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-misc/howl')
-rw-r--r--net-misc/howl/ChangeLog7
-rw-r--r--net-misc/howl/files/howl-0.9.8-types.patch11
-rw-r--r--net-misc/howl/howl-0.9.8.ebuild10
3 files changed, 26 insertions, 2 deletions
diff --git a/net-misc/howl/ChangeLog b/net-misc/howl/ChangeLog
index 2ecbbfe34b84..acdfe82dfafa 100644
--- a/net-misc/howl/ChangeLog
+++ b/net-misc/howl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/howl
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/howl/ChangeLog,v 1.23 2005/02/25 02:17:34 kito Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/howl/ChangeLog,v 1.24 2005/03/13 08:35:46 stkn Exp $
+
+ 13 Mar 2005; Stefan Knoblich <stkn@gentoo.org> howl-0.9.8.ebuild:
+ Added patch to fix compilation problems due to missing type declarations
+ (#84030, thanks to Robin Princeley <princely@emirates.net.ae> and Greg Symons
+ <gsymons@gsconsulting.biz> for finding a fix and creating this patch).
24 Feb 2005; Kito <kito@gentoo.org> howl-0.9.8.ebuild:
~ppc-macos keyword
diff --git a/net-misc/howl/files/howl-0.9.8-types.patch b/net-misc/howl/files/howl-0.9.8-types.patch
new file mode 100644
index 000000000000..f6d2fe225ee6
--- /dev/null
+++ b/net-misc/howl/files/howl-0.9.8-types.patch
@@ -0,0 +1,11 @@
+--- howl-0.9.8/src/lib/howl/Posix/posix_interface.c 2004-10-28 16:11:19.000000000 -0400
++++ howl-0.9.8/src/lib/howl/Posix/posix_interface.c 2005-03-12 22:56:36.000000000 -0500
+@@ -41,6 +41,7 @@
+ typedef __uint32_t u32;
+ typedef __uint16_t u16;
+ typedef __uint8_t u8;
++# include <linux/types.h>
+ # include <linux/sockios.h>
+ # include <linux/ethtool.h>
+ #endif
+
diff --git a/net-misc/howl/howl-0.9.8.ebuild b/net-misc/howl/howl-0.9.8.ebuild
index a717e309d5fa..267f7722148b 100644
--- a/net-misc/howl/howl-0.9.8.ebuild
+++ b/net-misc/howl/howl-0.9.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/howl/howl-0.9.8.ebuild,v 1.4 2005/02/25 02:17:34 kito Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/howl/howl-0.9.8.ebuild,v 1.5 2005/03/13 08:35:46 stkn Exp $
inherit eutils flag-o-matic
@@ -16,6 +16,14 @@ IUSE=""
DEPEND="virtual/libc"
# sys-devel/automake - needed if we remove the html docs from /usr/share
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # patch fixes #84030 (missing linux/types.h include)
+ epatch ${FILESDIR}/${P}-types.patch
+}
+
src_compile() {
# The following solves compilation using linux26-headers-2.6.8.1-r2 on ia64.
# It's not relevant for linux-headers-2.4.x or other linux26-headers, but