summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-08-18 14:51:50 +0000
committerRomain Perier <mrpouet@gentoo.org>2009-08-18 14:51:50 +0000
commit4827a8ff8e3fe55c329125058acce1f208698e6c (patch)
tree75bfc0a0e666376094bc9d175cc32ec6a8d99bd6 /net-misc/gwget
parentbe more strict in profile syntax, bug 281838 (diff)
downloadgentoo-2-4827a8ff8e3fe55c329125058acce1f208698e6c.tar.gz
gentoo-2-4827a8ff8e3fe55c329125058acce1f208698e6c.tar.bz2
gentoo-2-4827a8ff8e3fe55c329125058acce1f208698e6c.zip
Version bump to 1.0.2. Fix bug #281900. Several fixes, clean dialog code, remove gnome-vfs and remove old DBus code. Switch to eapi-2 due to sed expression which fix translations problem.
(Portage version: 2.2_rc38/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/gwget')
-rw-r--r--net-misc/gwget/ChangeLog11
-rw-r--r--net-misc/gwget/gwget-1.0.2.ebuild55
2 files changed, 64 insertions, 2 deletions
diff --git a/net-misc/gwget/ChangeLog b/net-misc/gwget/ChangeLog
index 9ded3f18df75..330a0773adb5 100644
--- a/net-misc/gwget/ChangeLog
+++ b/net-misc/gwget/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/gwget
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/gwget/ChangeLog,v 1.16 2009/02/22 19:13:26 eva Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gwget/ChangeLog,v 1.17 2009/08/18 14:51:50 mrpouet Exp $
+
+*gwget-1.0.2 (18 Aug 2009)
+
+ 18 Aug 2009; Romain Perier <mrpouet@gentoo.org> +gwget-1.0.2.ebuild:
+ Version bump to 1.0.2. Fix bug #281900. Several fixes, clean dialog code,
+ remove gnome-vfs and remove old DBus code. Switch to eapi-2 due to sed
+ expression which fix translations problem.
*gwget-1.0.1 (22 Feb 2009)
diff --git a/net-misc/gwget/gwget-1.0.2.ebuild b/net-misc/gwget/gwget-1.0.2.ebuild
new file mode 100644
index 000000000000..7f76bde1766c
--- /dev/null
+++ b/net-misc/gwget/gwget-1.0.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gwget/gwget-1.0.2.ebuild,v 1.1 2009/08/18 14:51:50 mrpouet Exp $
+
+EAPI="2"
+
+inherit gnome2
+
+DESCRIPTION="GTK2 WGet Frontend"
+HOMEPAGE="http://gnome.org/projects/gwget/"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="epiphany libnotify"
+
+# FIXME: dbus should be optional
+# needs patching for linguas/intltool
+RDEPEND="net-misc/wget
+ >=x11-libs/gtk+-2.6
+ >=dev-libs/glib-2.16.0
+ >=gnome-base/gconf-2
+ >=gnome-base/libglade-2
+ >=gnome-base/libgnomeui-2
+ >=dev-libs/dbus-glib-0.70
+ epiphany? ( >=www-client/epiphany-1.4 )
+ libnotify? ( >=x11-libs/libnotify-0.2.2 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35.0
+ >=sys-devel/gettext-0.10.4"
+
+DOCS="AUTHORS ChangeLog NEWS README THANKS TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable epiphany epiphany-extension)
+ $(use_enable libnotify)
+ --disable-static
+ --disable-schemas-install"
+}
+
+src_prepare() {
+ #FIXME: report upstream their package is broken
+ #Fix intltoolize broken file, see upstream #577133
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in \
+ || die "sed failed"
+}
+
+src_install() {
+ gnome2_src_install
+
+ # remove /var/lib, which is created without any reason
+ rm -rf "${D}/var"
+}