summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2006-03-05 06:39:03 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2006-03-05 06:39:03 +0000
commitf51ffe28d0610f1637caa2b4af4c8da07e9e4d36 (patch)
tree898f7982bfedf92a3caeabeeae4dba59c713416c /net-misc/gwget/gwget-0.97.ebuild
parentWhitespace fix (diff)
downloadgentoo-2-f51ffe28d0610f1637caa2b4af4c8da07e9e4d36.tar.gz
gentoo-2-f51ffe28d0610f1637caa2b4af4c8da07e9e4d36.tar.bz2
gentoo-2-f51ffe28d0610f1637caa2b4af4c8da07e9e4d36.zip
Version bump (bug #124105)
(Portage version: 2.1_pre5-r3)
Diffstat (limited to 'net-misc/gwget/gwget-0.97.ebuild')
-rw-r--r--net-misc/gwget/gwget-0.97.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/gwget/gwget-0.97.ebuild b/net-misc/gwget/gwget-0.97.ebuild
new file mode 100644
index 000000000000..b661867af9e1
--- /dev/null
+++ b/net-misc/gwget/gwget-0.97.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gwget/gwget-0.97.ebuild,v 1.1 2006/03/05 06:39:03 compnerd Exp $
+
+inherit gnome2
+
+DESCRIPTION="GTK2 WGet Frontend"
+HOMEPAGE="http://gnome.org/projects/gwget/"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="epiphany"
+
+RDEPEND="net-misc/wget
+ >=x11-libs/gtk+-2.6
+ >=dev-libs/glib-2.4.0
+ >=gnome-base/gconf-2
+ >=gnome-base/libglade-2
+ >=gnome-base/libbonobo-2
+ >=gnome-base/libgnomeui-2
+ epiphany? ( >=www-client/epiphany-1.4 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.29
+ >=sys-devel/gettext-0.10.4"
+
+DOCS="AUTHORS ChangeLog NEWS README THANKS TODO"
+USE_DESTDIR="1"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable epiphany epiphany-extension)"
+}
+
+src_install() {
+ gnome2_src_install
+
+ # remove /var/lib, which is created without any reason
+ rm -rf ${D}/var
+}