summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-05-15 09:51:33 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-05-15 09:51:33 +0000
commit621ada974bc2d16ad795c08d59ebb15c9f69cc6c (patch)
tree428bb75a5205d956e4abd16536f703323099e671 /net-misc/electrum
parentRevision bump: bump EAPI to 5, add epatch_user, do not apply ip-path.patch an... (diff)
downloadgentoo-2-621ada974bc2d16ad795c08d59ebb15c9f69cc6c.tar.gz
gentoo-2-621ada974bc2d16ad795c08d59ebb15c9f69cc6c.tar.bz2
gentoo-2-621ada974bc2d16ad795c08d59ebb15c9f69cc6c.zip
Version bump
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-misc/electrum')
-rw-r--r--net-misc/electrum/ChangeLog7
-rw-r--r--net-misc/electrum/electrum-1.7.4.ebuild86
2 files changed, 92 insertions, 1 deletions
diff --git a/net-misc/electrum/ChangeLog b/net-misc/electrum/ChangeLog
index a9c0ed63be2a..ac25252cc134 100644
--- a/net-misc/electrum/ChangeLog
+++ b/net-misc/electrum/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/electrum
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/electrum/ChangeLog,v 1.7 2013/04/14 10:03:20 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/electrum/ChangeLog,v 1.8 2013/05/15 09:51:33 blueness Exp $
+
+*electrum-1.7.4 (15 May 2013)
+
+ 15 May 2013; Anthony G. Basile <blueness@gentoo.org> +electrum-1.7.4.ebuild:
+ Version bump
*electrum-1.7.3 (14 Apr 2013)
diff --git a/net-misc/electrum/electrum-1.7.4.ebuild b/net-misc/electrum/electrum-1.7.4.ebuild
new file mode 100644
index 000000000000..1ba2016420ef
--- /dev/null
+++ b/net-misc/electrum/electrum-1.7.4.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/electrum/electrum-1.7.4.ebuild,v 1.1 2013/05/15 09:51:33 blueness Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit eutils distutils-r1 gnome2-utils
+
+MY_P=Electrum-${PV}
+DESCRIPTION="User friendly Bitcoin client"
+HOMEPAGE="http://electrum.org/"
+SRC_URI="http://download.electrum.org/download/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk qt4"
+REQUIRED_USE="|| ( gtk qt4 )"
+
+LANGS="br cs de eo es fr it lv nl ru sl vi zh"
+
+for X in ${LANGS}; do
+ IUSE+=" linguas_${X}"
+done
+unset X
+
+RDEPEND="
+ dev-python/setuptools
+ dev-python/ecdsa
+ dev-python/slowaes
+ gtk? ( dev-python/pygtk:2 )
+ qt4? ( dev-python/PyQt4 )"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="RELEASE-NOTES"
+
+src_prepare() {
+ # Prevent icon from being installed in the wrong location:
+ sed -i '/electrum\.png/ d' setup.py || die
+ sed -i "s:^Icon=.*:Icon=${PN}:" "${PN}.desktop" || die
+
+ # Fix .desktop to pass validation
+ sed -i 's:bitcoin$:bitcoin;:' electrum.desktop || die
+
+ # Remove unrequested localization files:
+ local lang
+ for lang in ${LANGS#en}; do
+ if use linguas_$lang; then
+ test -f "locale/$lang/LC_MESSAGES/${PN}.mo" || die
+ else
+ rm -r "locale/$lang" || die
+ fi
+ done
+
+ # Remove unrequested GUI implementations:
+ if use !gtk; then
+ rm gui/gui_gtk.py || die
+ fi
+ if use !qt4; then
+ rm gui/gui_{classic,lite}.py || die
+ sed -i "/config.get('gui','classic')/s/classic/gtk/" electrum \
+ || die
+ fi
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ doicon -s 64 icons/${PN}.png
+ distutils-r1_src_install
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}