summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2003-08-05 04:58:36 +0000
committerPeter Johanson <latexer@gentoo.org>2003-08-05 04:58:36 +0000
commit69065731041d1e2ac562d0d22b7298a82bc62d77 (patch)
tree731cc158abf2ec6d3c7e9151fe68219a81c97c9e /net-misc/dhcpv6/dhcpv6-0.85-r1.ebuild
parentAdded a small iaid patch (diff)
downloadgentoo-2-69065731041d1e2ac562d0d22b7298a82bc62d77.tar.gz
gentoo-2-69065731041d1e2ac562d0d22b7298a82bc62d77.tar.bz2
gentoo-2-69065731041d1e2ac562d0d22b7298a82bc62d77.zip
Added a small iaid patch
Diffstat (limited to 'net-misc/dhcpv6/dhcpv6-0.85-r1.ebuild')
-rw-r--r--net-misc/dhcpv6/dhcpv6-0.85-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-misc/dhcpv6/dhcpv6-0.85-r1.ebuild b/net-misc/dhcpv6/dhcpv6-0.85-r1.ebuild
new file mode 100644
index 000000000000..120fcb6af76e
--- /dev/null
+++ b/net-misc/dhcpv6/dhcpv6-0.85-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpv6/dhcpv6-0.85-r1.ebuild,v 1.1 2003/08/05 04:58:29 latexer Exp $
+
+DESCRIPTION="Server and client for DHCPv6"
+
+MY_P=${P/dhcpv6/dhcp6}
+HOMEPAGE="http://www.sourceforge.net/projects/dhcp6/"
+SRC_URI="mirror://sourceforge/dhcpv6/${MY_P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=""
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/patch-iaid-dhcp6-${PV}
+}
+
+src_install() {
+ einstall || die
+ dodoc Install ReadMe docs/draft-ietf-dhc-dhcpv6-28.txt \
+ docs/draft-ietf-dhc-dhcpv6-interop-{00,01}.txt \
+ docs/draft-ietf-dhc-dhcpv6-opt-dnsconfig-03.txt \
+ docs/draft-ietf-dhc-dhcpv6-opt-prefix-delegation-{02,03}.txt \
+ dhcp6c.conf dhcp6s.conf
+
+ dodir /var/lib/dhcpv6
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/dhcp6s.rc dhcp6s
+}
+pkg_postinst() {
+ einfo "Sample dhcp6c.conf and dhcp6s.conf files are in"
+ einfo "/usr/share/doc/${P}/"
+}