summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2009-12-29 20:58:10 +0000
committerWilliam Hubbs <williamh@gentoo.org>2009-12-29 20:58:10 +0000
commitc8b4923b23f2c6be3e944fcf21ef9089ac8cdcca (patch)
treeb74380b0c4cf8dae5a1309a98d737e05def5de33 /net-misc/dhcpcd
parentstable x86, bug 298767 (diff)
downloadgentoo-2-c8b4923b23f2c6be3e944fcf21ef9089ac8cdcca.tar.gz
gentoo-2-c8b4923b23f2c6be3e944fcf21ef9089ac8cdcca.tar.bz2
gentoo-2-c8b4923b23f2c6be3e944fcf21ef9089ac8cdcca.zip
version bump
(Portage version: 2.2_rc61/cvs/Linux i686)
Diffstat (limited to 'net-misc/dhcpcd')
-rw-r--r--net-misc/dhcpcd/ChangeLog7
-rw-r--r--net-misc/dhcpcd/dhcpcd-5.1.4.ebuild84
2 files changed, 90 insertions, 1 deletions
diff --git a/net-misc/dhcpcd/ChangeLog b/net-misc/dhcpcd/ChangeLog
index 0462a57613ed..0471758b3f2d 100644
--- a/net-misc/dhcpcd/ChangeLog
+++ b/net-misc/dhcpcd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/dhcpcd
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.273 2009/12/28 18:41:32 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.274 2009/12/29 20:58:10 williamh Exp $
+
+*dhcpcd-5.1.4 (29 Dec 2009)
+
+ 29 Dec 2009; William Hubbs <williamh@gentoo.org> +dhcpcd-5.1.4.ebuild:
+ version bump
28 Dec 2009; nixnut <nixnut@gentoo.org> dhcpcd-4.0.15.ebuild:
ppc stable #293502
diff --git a/net-misc/dhcpcd/dhcpcd-5.1.4.ebuild b/net-misc/dhcpcd/dhcpcd-5.1.4.ebuild
new file mode 100644
index 000000000000..21549342d478
--- /dev/null
+++ b/net-misc/dhcpcd/dhcpcd-5.1.4.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-5.1.4.ebuild,v 1.1 2009/12/29 20:58:10 williamh Exp $
+
+EAPI=1
+
+inherit eutils
+
+MY_P="${P/_alpha/-alpha}"
+MY_P="${MY_P/_beta/-beta}"
+MY_P="${MY_P/_rc/-rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
+HOMEPAGE="http://roy.marples.name/projects/dhcpcd/"
+SRC_URI="http://roy.marples.name/downloads/${PN}/${MY_P}.tar.bz2"
+LICENSE="BSD-2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+SLOT="0"
+IUSE="+zeroconf"
+
+DEPEND=""
+PROVIDE="virtual/dhcpc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if ! use zeroconf; then
+ elog "Disabling zeroconf support"
+ {
+ echo
+ echo "# dhcpcd ebuild requested no zeroconf"
+ echo "noipv4ll"
+ } >> dhcpcd.conf
+ fi
+}
+
+src_compile() {
+ local hooks="--with-hook=ntp.conf"
+ use elibc_glibc && hooks="${hooks} --with-hook=yp.conf"
+ econf --prefix= --libexecdir=/lib/dhcpcd --dbdir=/var/lib/dhcpcd \
+ --localstatedir=/var ${hooks}
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+}
+
+pkg_postinst() {
+ # Upgrade the duid file to the new format if needed
+ local old_duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
+ local new_duid="${ROOT}"/etc/dhcpcd.duid
+ if [ -e "${old_duid}" ] && ! grep -q '..:..:..:..:..:..' "${old_duid}"; then
+ sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_duid}"
+ fi
+
+ # Move the duid to /etc, a more sensible location
+ if [ -e "${old_duid}" -a ! -e "${new_duid}" ]; then
+ cp -p "${old_duid}" "${new_duid}"
+ fi
+
+ if use zeroconf; then
+ elog "You have installed dhcpcd with zeroconf support."
+ elog "This means that it will always obtain an IP address even if no"
+ elog "DHCP server can be contacted, which will break any existing"
+ elog "failover support you may have configured in your net configuration."
+ elog "This behaviour can be controlled with the -L flag."
+ elog "See the dhcpcd man page for more details."
+ fi
+
+ elog
+ elog "Users transfering from 4.0 series should pay attention to removal"
+ elog "of compat useflag. This changes behavior of dhcp in wide manner:"
+ elog "dhcpcd no longer sends a default ClientID for ethernet interfaces."
+ elog "This is so we can re-use the address the kernel DHCP client found."
+ elog "To retain the old behaviour of sending a default ClientID based on the"
+ elog "hardware address for interface, simply add the keyword clientid"
+ elog "to dhcpcd.conf or use commandline parameter -I ''"
+}