summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-10-04 11:57:04 +0000
committerRoy Marples <uberlord@gentoo.org>2007-10-04 11:57:04 +0000
commita1f0172e2a7fbcc11d7acf53041c53d3fe3e8e1d (patch)
treea3f0ea3d8cd09c1a1f5d844f26e1cc5a2f23eb38 /net-misc/dhcpcd
parenttouchup patches (diff)
downloadgentoo-2-a1f0172e2a7fbcc11d7acf53041c53d3fe3e8e1d.tar.gz
gentoo-2-a1f0172e2a7fbcc11d7acf53041c53d3fe3e8e1d.tar.bz2
gentoo-2-a1f0172e2a7fbcc11d7acf53041c53d3fe3e8e1d.zip
Bumpage.
(Portage version: 2.1.3.11)
Diffstat (limited to 'net-misc/dhcpcd')
-rw-r--r--net-misc/dhcpcd/ChangeLog7
-rw-r--r--net-misc/dhcpcd/dhcpcd-3.1.6.ebuild60
-rw-r--r--net-misc/dhcpcd/files/digest-dhcpcd-3.1.63
3 files changed, 69 insertions, 1 deletions
diff --git a/net-misc/dhcpcd/ChangeLog b/net-misc/dhcpcd/ChangeLog
index bba4567b0ae0..bf2f45d1836f 100644
--- a/net-misc/dhcpcd/ChangeLog
+++ b/net-misc/dhcpcd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/dhcpcd
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.163 2007/10/01 09:36:07 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.164 2007/10/04 11:57:04 uberlord Exp $
+
+*dhcpcd-3.1.6 (04 Oct 2007)
+
+ 04 Oct 2007; Roy Marples <uberlord@gentoo.org> +dhcpcd-3.1.6.ebuild:
+ Bumpage.
01 Oct 2007; Roy Marples <uberlord@gentoo.org> dhcpcd-3.1.5.ebuild:
Add a warning about DUID behaviour vs buggy servers.
diff --git a/net-misc/dhcpcd/dhcpcd-3.1.6.ebuild b/net-misc/dhcpcd/dhcpcd-3.1.6.ebuild
new file mode 100644
index 000000000000..5bb13451ad18
--- /dev/null
+++ b/net-misc/dhcpcd/dhcpcd-3.1.6.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-3.1.6.ebuild,v 1.1 2007/10/04 11:57:04 uberlord Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A DHCP client"
+HOMEPAGE="http://dhcpcd.berlios.de"
+SRC_URI="http://download.berlios.de/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="vram"
+
+DEPEND=""
+PROVIDE="virtual/dhcpc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Redefine the location of ntp.drift
+ sed -i -e 's,#define NTPDRIFTFILE[:space:]*,#define NTPDRIFTFILE\t\"/var/lib/ntp/ntp.drift\",' \
+ config.h || die "sed failed"
+
+ # Disable DUID support if we have volatile storage.
+ # LiveCD's *should* enable this USE flag
+ if use vram; then
+ einfo "Disabling DUID support in dhcpcd"
+ echo "#undef ENABLE_DUID" >> config.h
+ else
+ einfo "DUID support enabled"
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog
+}
+
+pkg_postinst() {
+ use vram && return 0
+
+ ewarn "You have installed dhcpcd with DUID support."
+ einfo "This means that we will generate a DUID in /var/lib/dhcpcd/dhcpcd.duid"
+ einfo "This is generated from a MAC address of the card and a timestamp."
+ einfo "It will be used in every subsequent DHCP transaction, along with a IAID"
+ einfo "in the ClientID option. This is required by RFC 4361."
+ echo
+ ewarn "Some DHCP server implementations require a MAC address only in the"
+ ewarn "ClientID field. These DHCP servers should be updated to be RFC"
+ ewarn "conformant. If you cannot do this, you can revert to the old"
+ ewarn "behaviour by using the -I '' option OR building dhcpcd with the"
+ ewarn "vram USE flag enabled."
+}
diff --git a/net-misc/dhcpcd/files/digest-dhcpcd-3.1.6 b/net-misc/dhcpcd/files/digest-dhcpcd-3.1.6
new file mode 100644
index 000000000000..56e4ad42b51a
--- /dev/null
+++ b/net-misc/dhcpcd/files/digest-dhcpcd-3.1.6
@@ -0,0 +1,3 @@
+MD5 7ef676d17c2bb012389e7c0fb295796e dhcpcd-3.1.6.tar.bz2 42593
+RMD160 006019a62cd5319ccad0ad449a85958b4d17505e dhcpcd-3.1.6.tar.bz2 42593
+SHA256 065c9f828c838c20fc8d05835796a30863f9810921894af6cb6126e7914ca030 dhcpcd-3.1.6.tar.bz2 42593