summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-09-25 13:12:57 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-09-25 13:12:57 +0000
commit0dc8464ce3ddc9a9109d1d883988acb42cf54bfb (patch)
tree8f13f2a3263991498a736213a4ef75b8a2e1b6d9 /net-misc/dhcpcd
parent* bump (diff)
downloadgentoo-2-0dc8464ce3ddc9a9109d1d883988acb42cf54bfb.tar.gz
gentoo-2-0dc8464ce3ddc9a9109d1d883988acb42cf54bfb.tar.bz2
gentoo-2-0dc8464ce3ddc9a9109d1d883988acb42cf54bfb.zip
Minor version bump to fix bug 285505 and bug 277095
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/dhcpcd')
-rw-r--r--net-misc/dhcpcd/ChangeLog7
-rw-r--r--net-misc/dhcpcd/dhcpcd-4.0.15.ebuild95
2 files changed, 101 insertions, 1 deletions
diff --git a/net-misc/dhcpcd/ChangeLog b/net-misc/dhcpcd/ChangeLog
index 6b0f18dc3224..2913e7602c72 100644
--- a/net-misc/dhcpcd/ChangeLog
+++ b/net-misc/dhcpcd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/dhcpcd
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.259 2009/09/24 03:53:27 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.260 2009/09/25 13:12:57 darkside Exp $
+
+*dhcpcd-4.0.15 (25 Sep 2009)
+
+ 25 Sep 2009; Jeremy Olexa <darkside@gentoo.org> +dhcpcd-4.0.15.ebuild:
+ Minor version bump to fix bug 285505 and bug 277095
*dhcpcd-5.1.1 (24 Sep 2009)
diff --git a/net-misc/dhcpcd/dhcpcd-4.0.15.ebuild b/net-misc/dhcpcd/dhcpcd-4.0.15.ebuild
new file mode 100644
index 000000000000..0561dc58b733
--- /dev/null
+++ b/net-misc/dhcpcd/dhcpcd-4.0.15.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-4.0.15.ebuild,v 1.1 2009/09/25 13:12:57 darkside Exp $
+
+EAPI=1
+
+inherit toolchain-funcs eutils
+
+MY_P="${P/_alpha/-alpha}"
+MY_P="${MY_P/_beta/-beta}"
+MY_P="${MY_P/_rc/-rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
+HOMEPAGE="http://roy.marples.name/projects/dhcpcd"
+SRC_URI="http://roy.marples.name/downloads/${PN}/${MY_P}.tar.bz2"
+LICENSE="BSD-2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+
+SLOT="0"
+IUSE="+compat +zeroconf"
+
+DEPEND=""
+PROVIDE="virtual/dhcpc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if ! use zeroconf; then
+ elog "Disabling zeroconf support"
+ {
+ echo
+ echo "# dhcpcd ebuild requested no zeroconf"
+ echo "noipv4ll"
+ } >> dhcpcd.conf
+ fi
+
+ if use compat; then
+ elog "dhcpcd-3 command line support enabled"
+ {
+ echo
+ echo "/* User indicated command line compatability */"
+ echo "#define CMDLINE_COMPAT"
+ } >> config.h
+ fi
+}
+
+pkg_setup() {
+ MAKE_ARGS="DBDIR=/var/lib/dhcpcd LIBEXECDIR=/lib/dhcpcd"
+}
+
+src_compile() {
+ [ -z "${MAKE_ARGS}" ] && die "MAKE_ARGS is empty"
+ emake CC="$(tc-getCC)" ${MAKE_ARGS} || die
+}
+
+src_install() {
+ local hooks="50-ntp.conf"
+ use elibc_glibc && hooks="${hooks} 50-yp.conf"
+ use compat && hooks="${hooks} 50-dhcpcd-compat"
+ emake ${MAKE_ARGS} HOOKSCRIPTS="${hooks}" DESTDIR="${D}" install || die
+}
+
+pkg_postinst() {
+ # Upgrade the duid file to the new format if needed
+ local old_duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
+ local new_duid="${ROOT}"/etc/dhcpcd.duid
+ if [ -e "${old_duid}" ] && ! grep -q '..:..:..:..:..:..' "${old_duid}"; then
+ sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_duid}"
+ fi
+
+ # Move the duid to /etc, a more sensible location
+ if [ -e "${old_duid}" -a ! -e "${new_duid}" ]; then
+ cp -p "${old_duid}" "${new_duid}"
+ fi
+
+ if use zeroconf; then
+ elog "You have installed dhcpcd with zeroconf support."
+ elog "This means that it will always obtain an IP address even if no"
+ elog "DHCP server can be contacted, which will break any existing"
+ elog "failover support you may have configured in your net configuration."
+ elog "This behaviour can be controlled with the -L flag."
+ elog "See the dhcpcd man page for more details."
+ fi
+ if ! use compat; then
+ elog
+ elog "dhcpcd no longer sends a default ClientID for ethernet interfaces."
+ elog "This is so we can re-use the address the kernel DHCP client found."
+ elog "To retain the old behaviour of sending a default ClientID based on the"
+ elog "hardware address for interface, simply add the keyword clientid"
+ elog "to dhcpcd.conf or use commandline parameter -I ''"
+ fi
+}