summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-11-10 07:24:38 +0000
committerTravis Tilley <lv@gentoo.org>2004-11-10 07:24:38 +0000
commit82a7a76714a714c3514ce3bcd3e13c267577d562 (patch)
tree5119bbbcb909c76de558d6751564969be34d60be /net-misc/dhcp
parentinitial commit of an experimental uclibc-hardened profile (diff)
downloadgentoo-2-82a7a76714a714c3514ce3bcd3e13c267577d562.tar.gz
gentoo-2-82a7a76714a714c3514ce3bcd3e13c267577d562.tar.bz2
gentoo-2-82a7a76714a714c3514ce3bcd3e13c267577d562.zip
fixed some invalid attributes in includes/dhcpd.h so that dhcp compiles using gcc 3.4 again. closes bug 69555
Diffstat (limited to 'net-misc/dhcp')
-rw-r--r--net-misc/dhcp/ChangeLog7
-rw-r--r--net-misc/dhcp/dhcp-3.0.1.ebuild3
-rw-r--r--net-misc/dhcp/files/dhcp-3.0.1-fix-invalid-attribute.patch15
3 files changed, 23 insertions, 2 deletions
diff --git a/net-misc/dhcp/ChangeLog b/net-misc/dhcp/ChangeLog
index 01e56dfac665..e7f053d30cea 100644
--- a/net-misc/dhcp/ChangeLog
+++ b/net-misc/dhcp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/dhcp
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/ChangeLog,v 1.45 2004/10/17 12:42:14 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/ChangeLog,v 1.46 2004/11/10 07:24:38 lv Exp $
+
+ 10 Nov 2004; Travis Tilley <lv@gentoo.org>
+ +files/dhcp-3.0.1-fix-invalid-attribute.patch, dhcp-3.0.1.ebuild:
+ fixed some invalid attributes in includes/dhcpd.h so that dhcp compiles
+ using gcc 3.4 again. closes bug 69555
17 Oct 2004; Dylan Carlson <absinthe@gentoo.org> dhcp-3.0.1.ebuild:
keywords ~amd64.
diff --git a/net-misc/dhcp/dhcp-3.0.1.ebuild b/net-misc/dhcp/dhcp-3.0.1.ebuild
index f633c6276440..b891034b12b0 100644
--- a/net-misc/dhcp/dhcp-3.0.1.ebuild
+++ b/net-misc/dhcp/dhcp-3.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/dhcp-3.0.1.ebuild,v 1.9 2004/11/04 03:47:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/dhcp-3.0.1.ebuild,v 1.10 2004/11/10 07:24:38 lv Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -24,6 +24,7 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/dhcp-3.0+paranoia.patch
epatch ${FILESDIR}/dhcp-3.0pl2-fix-perms.patch
+ epatch ${FILESDIR}/dhcp-3.0.1-fix-invalid-attribute.patch
has noman ${FEATURES} && sed -i 's:nroff:echo:' */Makefile.dist
}
diff --git a/net-misc/dhcp/files/dhcp-3.0.1-fix-invalid-attribute.patch b/net-misc/dhcp/files/dhcp-3.0.1-fix-invalid-attribute.patch
new file mode 100644
index 000000000000..20efa532620a
--- /dev/null
+++ b/net-misc/dhcp/files/dhcp-3.0.1-fix-invalid-attribute.patch
@@ -0,0 +1,15 @@
+--- includes/dhcpd.h.old 2004-11-10 02:18:44.201012888 -0500
++++ includes/dhcpd.h 2004-11-10 02:19:11.411876208 -0500
+@@ -306,9 +306,9 @@
+ # define EPHEMERAL_FLAGS (MS_NULL_TERMINATION | \
+ UNICAST_BROADCAST_HACK)
+
+- binding_state_t __attribute__ ((mode (__byte__))) binding_state;
+- binding_state_t __attribute__ ((mode (__byte__))) next_binding_state;
+- binding_state_t __attribute__ ((mode (__byte__))) desired_binding_state;
++ binding_state_t binding_state;
++ binding_state_t next_binding_state;
++ binding_state_t desired_binding_state;
+
+ struct lease_state *state;
+