summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-06-12 16:45:13 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-06-12 16:45:13 +0000
commitca7a6c305df880ca37574ebb62d275d1cfa5a1d8 (patch)
treef9bdc5ea0d35ced7c8aa2e5b57b619dff2593992 /net-misc/curl
parentMissing Libs.private in lcms2.pc to gain -lm for static linking. (diff)
downloadgentoo-2-ca7a6c305df880ca37574ebb62d275d1cfa5a1d8.tar.gz
gentoo-2-ca7a6c305df880ca37574ebb62d275d1cfa5a1d8.tar.bz2
gentoo-2-ca7a6c305df880ca37574ebb62d275d1cfa5a1d8.zip
Remove overshadowed old version and patches.
(Portage version: 2.2.0_alpha39/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/curl')
-rw-r--r--net-misc/curl/ChangeLog6
-rw-r--r--net-misc/curl/curl-7.20.0-r2.ebuild114
-rw-r--r--net-misc/curl/files/curl-7.20.0-libcurlm4.patch11
-rw-r--r--net-misc/curl/files/curl-7.21.3-buffer-overflow.patch30
4 files changed, 5 insertions, 156 deletions
diff --git a/net-misc/curl/ChangeLog b/net-misc/curl/ChangeLog
index ee5ffb792977..dc9f2c7b4377 100644
--- a/net-misc/curl/ChangeLog
+++ b/net-misc/curl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/curl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.182 2011/06/12 14:39:31 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.183 2011/06/12 16:45:13 scarabeus Exp $
+
+ 12 Jun 2011; Tomáš Chvátal <scarabeus@gentoo.org> -curl-7.20.0-r2.ebuild,
+ -files/curl-7.20.0-libcurlm4.patch, -files/curl-7.21.3-buffer-overflow.patch:
+ Remove overshadowed old version and patches.
12 Jun 2011; Raúl Porcel <armin76@gentoo.org> curl-7.21.4.ebuild:
ia64/s390/sh/sparc stable wrt #355595
diff --git a/net-misc/curl/curl-7.20.0-r2.ebuild b/net-misc/curl/curl-7.20.0-r2.ebuild
deleted file mode 100644
index d5f859db73eb..000000000000
--- a/net-misc/curl/curl-7.20.0-r2.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.20.0-r2.ebuild,v 1.7 2010/07/18 04:42:35 dragonheart Exp $
-
-# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
-
-inherit multilib eutils
-
-#MY_P=${P/_pre/-}
-DESCRIPTION="A Client that groks URLs"
-HOMEPAGE="http://curl.haxx.se/"
-#SRC_URI="http://cool.haxx.se/curl-daily/${MY_P}.tar.bz2"
-SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="ares gnutls idn ipv6 kerberos ldap libssh2 nss ssl test"
-
-RDEPEND="ldap? ( net-nds/openldap )
- ssl? (
- gnutls? ( net-libs/gnutls app-misc/ca-certificates )
- nss? ( !gnutls? ( dev-libs/nss app-misc/ca-certificates ) )
- !gnutls? ( !nss? ( dev-libs/openssl ) )
- )
- idn? ( net-dns/libidn )
- ares? ( >=net-dns/c-ares-1.4.0 )
- kerberos? ( virtual/krb5 )
- libssh2? ( >=net-libs/libssh2-0.16 )"
-
-# fbopenssl (not in gentoo) --with-spnego
-# krb4 http://web.mit.edu/kerberos/www/krb4-end-of-life.html
-
-DEPEND="${RDEPEND}
- test? (
- sys-apps/diffutils
- dev-lang/perl
- )"
-# used - but can do without in self test: net-misc/stunnel
-
-pkg_setup() {
- if ! use ssl && ( use gnutls || use nss ) ; then
- ewarn "USE='gnutls nss' are ignored without USE='ssl'."
- ewarn "Please review the local USE flags for this package."
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-strip-ldflags.patch
- epatch "${FILESDIR}"/${PN}-7.19.7-test241.patch \
- "${FILESDIR}"/${P}-libcurlm4.patch
-}
-
-src_compile() {
-
- myconf="$(use_enable ldap)
- $(use_enable ldap ldaps)
- $(use_with idn libidn)
- $(use_with kerberos gssapi /usr)
- $(use_with libssh2)
- $(use_enable ipv6)
- $(use_enable ares)
- --enable-http
- --enable-ftp
- --enable-gopher
- --enable-file
- --enable-dict
- --enable-manual
- --enable-telnet
- --enable-smtp
- --enable-pop3
- --enable-imap
- --enable-rtsp
- --enable-nonblocking
- --enable-largefile
- --enable-maintainer-mode
- --disable-sspi
- --without-krb4
- --without-spnego"
-
- if use ssl ; then
- if use gnutls; then
- myconf="${myconf} --without-ssl --with-gnutls --without-nss"
- myconf="${myconf} --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt"
- elif use nss; then
- myconf="${myconf} --without-ssl --without-gnutls --with-nss"
- myconf="${myconf} --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt"
- else
- myconf="${myconf} --without-gnutls --without-nss --with-ssl"
- myconf="${myconf} --without-ca-bundle --with-ca-path=/etc/ssl/certs"
- fi
- else
- myconf="${myconf} --without-gnutls --without-nss --without-ssl"
- fi
-
- econf ${myconf} || die 'configure failed'
-
- emake || die "install failed for current version"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "installed failed for current version"
- rm -rf "${D}"/etc/
-
- # https://sourceforge.net/tracker/index.php?func=detail&aid=1705197&group_id=976&atid=350976
- insinto /usr/share/aclocal
- doins docs/libcurl/libcurl.m4
-
- dodoc CHANGES README
- dodoc docs/FEATURES docs/INTERNALS
- dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
-}
diff --git a/net-misc/curl/files/curl-7.20.0-libcurlm4.patch b/net-misc/curl/files/curl-7.20.0-libcurlm4.patch
deleted file mode 100644
index 16220b87d91e..000000000000
--- a/net-misc/curl/files/curl-7.20.0-libcurlm4.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- docs/libcurl/libcurl.m4.old 2010-03-21 15:50:23.000000000 +0100
-+++ docs/libcurl/libcurl.m4 2010-03-21 15:51:41.000000000 +0100
-@@ -198,7 +198,7 @@
-
- # We don't have --protocols, so just assume that all
- # protocols are available
-- _libcurl_protocols="HTTP FTP FILE TELNET LDAP DICT TFTP
-+ _libcurl_protocols="HTTP FTP FILE TELNET LDAP DICT TFTP"
-
- if test x$libcurl_feature_SSL = xyes ; then
- _libcurl_protocols="$_libcurl_protocols HTTPS"
diff --git a/net-misc/curl/files/curl-7.21.3-buffer-overflow.patch b/net-misc/curl/files/curl-7.21.3-buffer-overflow.patch
deleted file mode 100644
index 53541891d401..000000000000
--- a/net-misc/curl/files/curl-7.21.3-buffer-overflow.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 1df74d886d764115944d40fbc79bfd51ec7d714a Mon Sep 17 00:00:00 2001
-From: Paul Howarth <paul@city-fan.org>
-Date: Fri, 17 Dec 2010 19:07:45 +0100
-Subject: [PATCH 01/90] tftpd: avoid buffer overflow report from glibc
-
----
- tests/server/tftpd.c | 6 ++++--
- 1 files changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/tests/server/tftpd.c b/tests/server/tftpd.c
-index b9a0562..701b3e9 100644
---- a/tests/server/tftpd.c
-+++ b/tests/server/tftpd.c
-@@ -1291,9 +1291,11 @@ static void nak(int error)
- pe->e_msg = strerror(error - 100);
- tp->th_code = EUNDEF; /* set 'undef' errorcode */
- }
-- strcpy(tp->th_msg, pe->e_msg);
- length = (int)strlen(pe->e_msg);
-- tp->th_msg[length] = '\0';
-+
-+ /* we use memcpy() instead of strcpy() in order to avoid buffer overflow
-+ * report from glibc with FORTIFY_SOURCE */
-+ memcpy(tp->th_msg, pe->e_msg, length + 1);
- length += 5;
- if (swrite(peer, &buf.storage[0], length) != length)
- logmsg("nak: fail\n");
---
-1.7.4.rc2
-