summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2005-04-27 14:45:45 +0000
committerAlastair Tse <liquidx@gentoo.org>2005-04-27 14:45:45 +0000
commit905f02b2d2ea214f36d61f2c30731b2203d05679 (patch)
tree3811d376c584637f87e9ef983b5d5c58f350440e /net-misc/curl
parentcleaning (diff)
downloadgentoo-2-905f02b2d2ea214f36d61f2c30731b2203d05679.tar.gz
gentoo-2-905f02b2d2ea214f36d61f2c30731b2203d05679.tar.bz2
gentoo-2-905f02b2d2ea214f36d61f2c30731b2203d05679.zip
version bump. added c-ares support. added old library if we detect it on compile, which stops broken dependencies on major lib upgrades from 7.11.x to 7.12.x.
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-misc/curl')
-rw-r--r--net-misc/curl/ChangeLog9
-rw-r--r--net-misc/curl/Manifest6
-rw-r--r--net-misc/curl/curl-7.13.2.ebuild89
-rw-r--r--net-misc/curl/files/digest-curl-7.13.22
4 files changed, 103 insertions, 3 deletions
diff --git a/net-misc/curl/ChangeLog b/net-misc/curl/ChangeLog
index 335cbd362b45..39c7bd598c0b 100644
--- a/net-misc/curl/ChangeLog
+++ b/net-misc/curl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/curl
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.31 2005/04/24 04:32:13 kito Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.32 2005/04/27 14:45:45 liquidx Exp $
+
+*curl-7.13.2 (27 Apr 2005)
+
+ 27 Apr 2005; Alastair Tse <liquidx@gentoo.org> +curl-7.13.2.ebuild:
+ version bump. added c-ares support. added old library if we detect it on
+ compile, which stops broken dependencies on major lib upgrades from 7.11.x
+ to 7.12.x.
23 Apr 2005; Kito <kito@gentoo.org> curl-7.13.1.ebuild:
~ppc-macos keyword
diff --git a/net-misc/curl/Manifest b/net-misc/curl/Manifest
index 4bdb35ba7473..0dc1b8d8e18f 100644
--- a/net-misc/curl/Manifest
+++ b/net-misc/curl/Manifest
@@ -1,11 +1,12 @@
-MD5 67451428ea495e45ce101b306870ca19 ChangeLog 8137
MD5 2964306ed6c7eae2f10a4b51ab0d1951 curl-7.10.8-r1.ebuild 1087
MD5 dc117f992b3951d6034bf197e87af661 curl-7.11.0.ebuild 978
MD5 15b11562a35a25f57c11882625925d1f curl-7.11.1.ebuild 1025
+MD5 8f906ffe0aa837e5e26fe03af3043461 metadata.xml 219
MD5 ddeadcb2f1766f7b1a125c436a37a7ac curl-7.12.0-r2.ebuild 1290
MD5 60132aceae3f343c6e3dd478d956f1e9 curl-7.12.3.ebuild 1135
+MD5 67451428ea495e45ce101b306870ca19 ChangeLog 8137
+MD5 afc119a077b2b451aed9a6637ec13c0b curl-7.13.2.ebuild 2322
MD5 dfa06a2730dee8379693ee68fa9690cd curl-7.13.1.ebuild 1138
-MD5 8f906ffe0aa837e5e26fe03af3043461 metadata.xml 219
MD5 dc352925b526421b92ff81fc9b8315da files/7.12.0-no-fputc.patch 312
MD5 e2795c792b9a04fd73ca556ce257f39f files/curl-7.10.5-badssl.patch 343
MD5 05e37478314d224f2ce5840f2e1f31c9 files/curl-7.10.8-transfer-segv.patch 744
@@ -15,3 +16,4 @@ MD5 960d346648779ac90316a39974aff792 files/digest-curl-7.11.1 65
MD5 b1be312bb3cb53a17c9ba9683bda165a files/digest-curl-7.12.0-r2 65
MD5 d667046d2f490bf2dec632acd537248c files/digest-curl-7.12.3 65
MD5 159b437588320b2a3f726d3aa55890e5 files/digest-curl-7.13.1 65
+MD5 71c346cc704727e0bdaef7333521adeb files/digest-curl-7.13.2 130
diff --git a/net-misc/curl/curl-7.13.2.ebuild b/net-misc/curl/curl-7.13.2.ebuild
new file mode 100644
index 000000000000..09200def544a
--- /dev/null
+++ b/net-misc/curl/curl-7.13.2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.13.2.ebuild,v 1.1 2005/04/27 14:45:45 liquidx Exp $
+
+# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
+
+inherit eutils
+
+# NOTE: To prevent breakages when upgrading, we compile all the prev
+# versions we know. We can't slot them because only the libraries
+# have versioning, all the binaries, manpages don't have versions.
+
+OLD_PV=7.11.2
+OLD_PV_LIB=libcurl.so.2
+
+DESCRIPTION="A Client that groks URLs"
+HOMEPAGE="http://curl.haxx.se/"
+SRC_URI="http://curl.haxx.se/download/${PN}-${OLD_PV}.tar.bz2
+http://curl.haxx.se/download/${P}.tar.bz2"
+
+LICENSE="MIT X11"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sparc ~x86"
+IUSE="ssl ipv6 ldap ares"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6a )
+ ldap? ( net-nds/openldap )
+ x86? ( ares? ( net-dns/c-ares ) )"
+
+_curl_has_old_ver() {
+ if test -s ${ROOT}/usr/$(get_libdir)/${OLD_PV_LIB}; then
+ return 0 # /bin/true
+ else
+ return 1
+ fi
+}
+
+src_compile() {
+
+ myconf="$(use_enable ldap)
+ $(use_with ssl)
+ --enable-http
+ --enable-ftp
+ --enable-gopher
+ --enable-file
+ --enable-dict
+ --enable-manual
+ --enable-telnet
+ --enable-nonblocking
+ --enable-largefile"
+
+ if use ipv6 && use ares; then
+ ewarn "c-ares support disabled because it is incompatible with ipv6."
+ ewarn "To enable ares support, emerge with USE='-ipv6'."
+ myconf="${myconf} $(use_enable ipv6)"
+ else
+ if use x86; then
+ myconf="${myconf} $(use_enable ipv6) $(use_enable ares)"
+ fi
+ fi
+
+ if _curl_has_old_ver; then
+ einfo "Detected old version of curl - installing compat libs"
+ cd ${WORKDIR}/${PN}-${OLD_PV}
+ econf ${myconf}
+ emake || die "make for old version failed"
+ fi
+
+ cd ${S}
+ econf ${myconf}
+ emake || die "install failed for current version"
+}
+
+src_install() {
+ if _curl_has_old_ver; then
+ cd ${WORKDIR}/${PN}-${OLD_PV}/lib
+ make DESTDIR=${D} install-libLTLIBRARIES || die "install failed for old version"
+ fi
+
+ cd ${S}
+ make DESTDIR="${D}" install || die "installed failed for current version"
+
+ insinto /usr/share/aclocal
+ doins docs/libcurl/libcurl.m4
+
+ dodoc CHANGES README
+ dodoc docs/FEATURES docs/INSTALL docs/INTERNALS docs/LIBCURL
+ dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
+}
diff --git a/net-misc/curl/files/digest-curl-7.13.2 b/net-misc/curl/files/digest-curl-7.13.2
new file mode 100644
index 000000000000..833fa116dd4b
--- /dev/null
+++ b/net-misc/curl/files/digest-curl-7.13.2
@@ -0,0 +1,2 @@
+MD5 542fbdafd2fb051477fa544770b566de curl-7.11.2.tar.bz2 1141204
+MD5 5916bb359223800afa234a1cf5145b78 curl-7.13.2.tar.bz2 1891406