summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2010-07-01 20:46:54 +0000
committerJeremy Olexa <darkside@gentoo.org>2010-07-01 20:46:54 +0000
commit853a7b8ee28f586fdae0e515c0633915e50acec5 (patch)
tree70be750e19a4842643fe36c9c2f3e1e496a2ddd6 /net-misc/curl
parentVersion bump. (diff)
downloadgentoo-2-853a7b8ee28f586fdae0e515c0633915e50acec5.tar.gz
gentoo-2-853a7b8ee28f586fdae0e515c0633915e50acec5.tar.bz2
gentoo-2-853a7b8ee28f586fdae0e515c0633915e50acec5.zip
Add modifications for Gentoo Prefix as tested in the Gentoo Prefix overlay. Add keywords, add EPREFIX/ED, add patch for prefix offset instead of hardcoded paths. Approved by spatz
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/curl')
-rw-r--r--net-misc/curl/ChangeLog8
-rw-r--r--net-misc/curl/curl-7.21.0.ebuild25
-rw-r--r--net-misc/curl/files/curl-7.18.2-prefix.patch20
3 files changed, 42 insertions, 11 deletions
diff --git a/net-misc/curl/ChangeLog b/net-misc/curl/ChangeLog
index a2f4aadeb0d1..b9aa555db255 100644
--- a/net-misc/curl/ChangeLog
+++ b/net-misc/curl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/curl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.161 2010/07/01 20:14:54 spatz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.162 2010/07/01 20:46:53 darkside Exp $
+
+ 01 Jul 2010; Jeremy Olexa <darkside@gentoo.org>
+ +files/curl-7.18.2-prefix.patch, curl-7.21.0.ebuild:
+ Add modifications for Gentoo Prefix as tested in the Gentoo Prefix
+ overlay. Add keywords, add EPREFIX/ED, add patch for prefix offset instead
+ of hardcoded paths. Approved by spatz
*curl-7.21.0 (01 Jul 2010)
diff --git a/net-misc/curl/curl-7.21.0.ebuild b/net-misc/curl/curl-7.21.0.ebuild
index 2bc94f8e99cc..f7baa69ebe1c 100644
--- a/net-misc/curl/curl-7.21.0.ebuild
+++ b/net-misc/curl/curl-7.21.0.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.21.0.ebuild,v 1.1 2010/07/01 20:14:54 spatz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.21.0.ebuild,v 1.2 2010/07/01 20:46:53 darkside Exp $
# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
-EAPI=2
+EAPI=3
-inherit multilib eutils
+inherit multilib eutils libtool prefix
#MY_P=${P/_pre/-}
DESCRIPTION="A Client that groks URLs"
@@ -17,7 +17,7 @@ SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="ares gnutls idn ipv6 kerberos ldap libssh2 nss ssl test threads"
RDEPEND="ldap? ( net-nds/openldap )
@@ -56,14 +56,19 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/${PN}-7.20.0-strip-ldflags.patch \
- "${FILESDIR}"/${PN}-7.19.7-test241.patch
+ "${FILESDIR}"/${PN}-7.19.7-test241.patch \
+ "${FILESDIR}"/${PN}-7.18.2-prefix.patch
+
+ eprefixify curl-config.in
+ # for FreeMiNT
+ elibtoolize
}
src_configure() {
myconf="$(use_enable ldap)
$(use_enable ldap ldaps)
$(use_with idn libidn)
- $(use_with kerberos gssapi /usr)
+ $(use_with kerberos gssapi "${EPREFIX}"/usr)
$(use_with libssh2)
$(use_enable ipv6)
$(use_enable ares)
@@ -89,13 +94,13 @@ src_configure() {
if use ssl ; then
if use gnutls; then
myconf="${myconf} --without-ssl --with-gnutls --without-nss"
- myconf="${myconf} --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt"
+ myconf="${myconf} --with-ca-bundle=${EPREFIX}/etc/ssl/certs/ca-certificates.crt"
elif use nss; then
myconf="${myconf} --without-ssl --without-gnutls --with-nss"
- myconf="${myconf} --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt"
+ myconf="${myconf} --with-ca-bundle=${EPREFIX}/etc/ssl/certs/ca-certificates.crt"
else
myconf="${myconf} --without-gnutls --without-nss --with-ssl"
- myconf="${myconf} --without-ca-bundle --with-ca-path=/etc/ssl/certs"
+ myconf="${myconf} --without-ca-bundle --with-ca-path=${EPREFIX}/etc/ssl/certs"
fi
else
myconf="${myconf} --without-gnutls --without-nss --without-ssl"
@@ -106,7 +111,7 @@ src_configure() {
src_install() {
emake DESTDIR="${D}" install || die "installed failed for current version"
- rm -rf "${D}"/etc/
+ rm -rf "${ED}"/etc/
# https://sourceforge.net/tracker/index.php?func=detail&aid=1705197&group_id=976&atid=350976
insinto /usr/share/aclocal
diff --git a/net-misc/curl/files/curl-7.18.2-prefix.patch b/net-misc/curl/files/curl-7.18.2-prefix.patch
new file mode 100644
index 000000000000..9f7761f4edc8
--- /dev/null
+++ b/net-misc/curl/files/curl-7.18.2-prefix.patch
@@ -0,0 +1,20 @@
+--- curl-config.in.orig 2008-10-10 13:43:19.000000000 +0200
++++ curl-config.in 2008-10-10 13:43:56.000000000 +0200
+@@ -181,7 +181,7 @@
+ ;;
+
+ --cflags)
+- if test "X@includedir@" = "X/usr/include"; then
++ if test "X@includedir@" = "X@GENTOO_PORTAGE_EPREFIX@/usr/include"; then
+ echo ""
+ else
+ echo "-I@includedir@"
+@@ -189,7 +189,7 @@
+ ;;
+
+ --libs)
+- if test "X@libdir@" != "X/usr/lib" -a "X@libdir@" != "X/usr/lib64"; then
++ if test "X@libdir@" != "X@GENTOO_PORTAGE_EPREFIX@/usr/lib" -a "X@libdir@" != "X@GENTOO_PORTAGE_EPREFIX@/usr/lib64"; then
+ CURLLIBDIR="-L@libdir@ "
+ else
+ CURLLIBDIR=""