summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Piasek <dagger@gentoo.org>2009-08-25 15:17:21 +0000
committerRobert Piasek <dagger@gentoo.org>2009-08-25 15:17:21 +0000
commitb4794fe862dc28f23915e0b57b7f1a6d6f747418 (patch)
treedc88cca4eeec6d8eb9644066b8da3bc58ac84e04 /net-misc/connman
parentFix media-libs/jpeg dependency, alpha/arm/sh/sparc/x86 stable (diff)
downloadgentoo-2-b4794fe862dc28f23915e0b57b7f1a6d6f747418.tar.gz
gentoo-2-b4794fe862dc28f23915e0b57b7f1a6d6f747418.tar.bz2
gentoo-2-b4794fe862dc28f23915e0b57b7f1a6d6f747418.zip
Version bump
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/connman')
-rw-r--r--net-misc/connman/ChangeLog8
-rw-r--r--net-misc/connman/connman-0.39.ebuild81
-rw-r--r--net-misc/connman/files/connman-0.39-fix-parallel-build.patch30
3 files changed, 118 insertions, 1 deletions
diff --git a/net-misc/connman/ChangeLog b/net-misc/connman/ChangeLog
index 6d5d4961fcde..ccf75f21c958 100644
--- a/net-misc/connman/ChangeLog
+++ b/net-misc/connman/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/connman
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/ChangeLog,v 1.1 2009/08/24 13:24:08 dagger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/ChangeLog,v 1.2 2009/08/25 15:17:21 dagger Exp $
+
+*connman-0.39 (25 Aug 2009)
+
+ 25 Aug 2009; Robert Piasek <dagger@gentoo.org> +connman-0.39.ebuild,
+ +files/connman-0.39-fix-parallel-build.patch:
+ Version bump
*connman-0.38 (13 Aug 2009)
diff --git a/net-misc/connman/connman-0.39.ebuild b/net-misc/connman/connman-0.39.ebuild
new file mode 100644
index 000000000000..f23314d7e548
--- /dev/null
+++ b/net-misc/connman/connman-0.39.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/connman-0.39.ebuild,v 1.1 2009/08/25 15:17:21 dagger Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="Provides a daemon for managing internet connections"
+HOMEPAGE="http://connman.net"
+SRC_URI="mirror://kernel/linux/network/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~arm ~amd64 ~x86"
+IUSE="3G bluetooth debug +dhclient dnsproxy doc +ethernet modemmanager ofono policykit ppp resolvconf threads tools +udev +wifi"
+# ospm wimax
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=sys-apps/dbus-1.2
+ bluetooth? ( net-wireless/bluez )
+ dhclient? ( net-misc/dhcp )
+ modemmanager? ( net-misc/modemmanager )
+ ofono? ( net-misc/ofono )
+ policykit? ( >=sys-auth/policykit-0.7 )
+ ppp? ( net-dialup/ppp )
+ resolvconf? ( net-dns/openresolv )
+ udev? ( >=sys-fs/udev-141 )
+ wifi? ( net-wireless/wpa_supplicant[dbus] )"
+
+DEPEND="${RDEPEND}
+ doc? ( dev-util/gtk-doc )"
+
+src_prepare() {
+
+ cd "${S}"
+ # fixes parallel build
+ epatch "${FILESDIR}"/${P}-fix-parallel-build.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --enable-loopback \
+ --enable-client \
+ --enable-fake \
+ --enable-datafiles \
+ $(use_enable 3G novatel) \
+ $(use_enable 3G huawei) \
+ $(use_enable 3G hso) \
+ $(use_enable 3G mbm) \
+ $(use_enable bluetooth) \
+ $(use_enable debug) \
+ $(use_enable dhclient) \
+ $(use_enable dnsproxy) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable ethernet) \
+ $(use_enable modemmanager modemmgr) \
+ $(use_enable ofono) \
+ $(use_enable policykit polkit) \
+ $(use_enable ppp) \
+ $(use_enable resolvconf) \
+ $(use_enable threads) \
+ $(use_enable tools) \
+ $(use_enable udev) \
+ $(use_enable wifi) \
+ --disable-udhcp \
+ --disable-iwmx \
+ --disable-iospm
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dobin client/cm || die "client installation failed"
+
+ keepdir /var/lib/${PN} || die
+ newinitd "${FILESDIR}"/${PN}.initd ${PN} || die
+
+}
+
diff --git a/net-misc/connman/files/connman-0.39-fix-parallel-build.patch b/net-misc/connman/files/connman-0.39-fix-parallel-build.patch
new file mode 100644
index 000000000000..ab0da1a10f38
--- /dev/null
+++ b/net-misc/connman/files/connman-0.39-fix-parallel-build.patch
@@ -0,0 +1,30 @@
+diff --git a/Makefile.am b/Makefile.am
+index b825874..0e13bf5 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -187,11 +187,11 @@ endif
+ $(src_connmand_OBJECTS) $(plugin_objects): $(local_headers)
+
+ include/connman/version.h: include/version.h
+- $(AM_V_at)if [ ! -e include/connman ] ; then mkdir include/connman ; fi
++ $(AM_V_at)$(MKDIR_P) include/connman
+ $(AM_V_GEN)$(LN_S) $(abs_top_builddir)/$< $@
+
+ include/connman/%.h: include/%.h
+- $(AM_V_at)if [ ! -e include/connman ] ; then mkdir include/connman ; fi
++ $(AM_V_at)$(MKDIR_P) include/connman
+ $(AM_V_GEN)$(LN_S) $(abs_top_srcdir)/$< $@
+
+ clean-local: include/connman
+diff --git a/configure.ac b/configure.ac
+index 4b81cbe..a5d8ed5 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -25,6 +25,7 @@ AC_PROG_CC_PIE
+ AC_PROG_INSTALL
+ AC_PROG_SED
+ AC_PROG_AWK
++AM_PROG_MKDIR_P
+
+ m4_define([_LT_AC_TAGCONFIG], [])
+ m4_ifdef([AC_LIBTOOL_TAGS], [AC_LIBTOOL_TAGS([])])