summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Piasek <dagger@gentoo.org>2010-12-17 14:46:07 +0000
committerRobert Piasek <dagger@gentoo.org>2010-12-17 14:46:07 +0000
commit9b99b11fea3556521157cda1fe6fda9d1739623d (patch)
treef0d2c636d3ce6d2f01e7f762a0485a2ad38e3bb1 /net-misc/connman
parentversion bump (diff)
downloadgentoo-2-9b99b11fea3556521157cda1fe6fda9d1739623d.tar.gz
gentoo-2-9b99b11fea3556521157cda1fe6fda9d1739623d.tar.bz2
gentoo-2-9b99b11fea3556521157cda1fe6fda9d1739623d.zip
Fixed dependencies. Thanks to Benedikt Sauer <filmor@gmail.com> for
pointing it out (bug #345851). Added version 0.64 (bug #347732) (Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/connman')
-rw-r--r--net-misc/connman/ChangeLog9
-rw-r--r--net-misc/connman/connman-0.63-r2.ebuild (renamed from net-misc/connman/connman-0.63-r1.ebuild)5
-rw-r--r--net-misc/connman/connman-0.64.ebuild77
3 files changed, 88 insertions, 3 deletions
diff --git a/net-misc/connman/ChangeLog b/net-misc/connman/ChangeLog
index 3cd4cac78466..bc1bdc294dea 100644
--- a/net-misc/connman/ChangeLog
+++ b/net-misc/connman/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/connman
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/ChangeLog,v 1.27 2010/11/17 10:01:45 dagger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/ChangeLog,v 1.28 2010/12/17 14:46:07 dagger Exp $
+
+*connman-0.64 (17 Dec 2010)
+*connman-0.63-r2 (17 Dec 2010)
+
+ 17 Dec 2010; Robert Piasek <dagger@gentoo.org> -connman-0.63-r1.ebuild,
+ +connman-0.63-r2.ebuild, +connman-0.64.ebuild:
+ Upgraded dependency - Thanks to Benedikt Sauer <filmor@gmail.com>
*connman-0.63-r1 (17 Nov 2010)
diff --git a/net-misc/connman/connman-0.63-r1.ebuild b/net-misc/connman/connman-0.63-r2.ebuild
index d41c529f7c88..fc9dc6b50595 100644
--- a/net-misc/connman/connman-0.63-r1.ebuild
+++ b/net-misc/connman/connman-0.63-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/connman-0.63-r1.ebuild,v 1.1 2010/11/17 10:01:45 dagger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/connman-0.63-r2.ebuild,v 1.1 2010/12/17 14:46:07 dagger Exp $
EAPI="2"
@@ -19,7 +19,8 @@ IUSE="bluetooth +caps debug +dhclient dnsproxy doc examples +ethernet google ofo
RDEPEND=">=dev-libs/glib-2.16
>=sys-apps/dbus-1.2.24
>=dev-libs/libnl-1.1
- net-firewall/iptables
+ >=net-firewall/iptables-1.4.8
+ >=sys-kernel/linux-headers-2.6.30
bluetooth? ( net-wireless/bluez )
caps? ( sys-libs/libcap-ng )
dhclient? ( net-misc/dhcp )
diff --git a/net-misc/connman/connman-0.64.ebuild b/net-misc/connman/connman-0.64.ebuild
new file mode 100644
index 000000000000..8245fd8e109b
--- /dev/null
+++ b/net-misc/connman/connman-0.64.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/connman-0.64.ebuild,v 1.1 2010/12/17 14:46:07 dagger Exp $
+
+EAPI="2"
+
+inherit multilib eutils
+
+DESCRIPTION="Provides a daemon for managing internet connections"
+HOMEPAGE="http://connman.net"
+SRC_URI="mirror://kernel/linux/network/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="bluetooth +caps debug +dhclient dnsproxy doc examples +ethernet google ofono openvpn policykit threads tools +wifi wimax"
+# gps meego ospm openconnect
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=sys-apps/dbus-1.2.24
+ >=dev-libs/libnl-1.1
+ >=net-firewall/iptables-1.4.8
+ >=sys-kernel/linux-headers-2.6.30
+ bluetooth? ( net-wireless/bluez )
+ caps? ( sys-libs/libcap-ng )
+ dhclient? ( net-misc/dhcp )
+ ofono? ( net-misc/ofono )
+ policykit? ( sys-auth/polkit )
+ openvpn? ( net-misc/openvpn )
+ wifi? ( >=net-wireless/wpa_supplicant-0.7[dbus] )
+ wimax? ( net-wireless/wimax )"
+
+DEPEND="${RDEPEND}
+ doc? ( dev-util/gtk-doc )"
+
+#src_prepare() {
+# epatch "${FILESDIR}/${P}-fix-iptables-test.patch"
+#}
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --enable-client \
+ --enable-fake \
+ --enable-datafiles \
+ --enable-loopback=builtin \
+ $(use_enable caps capng) \
+ $(use_enable examples test) \
+ $(use_enable ethernet ethernet builtin) \
+ $(use_enable wifi wifi builtin) \
+ $(use_enable bluetooth bluetooth builtin) \
+ $(use_enable ofono ofono builtin) \
+ $(use_enable dhclient dhclient builtin) \
+ $(use_enable dnsproxy dnsproxy builtin) \
+ $(use_enable google google builtin) \
+ $(use_enable openvpn openvpn builtin) \
+ $(use_enable policykit polkit builtin) \
+ $(use_enable wimax iwmx builtin) \
+ $(use_enable debug) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable threads) \
+ $(use_enable tools) \
+ --disable-iospm \
+ --disable-hh2serial-gps \
+ --disable-portal \
+ --disable-meego \
+ --disable-openconnect
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dobin client/cm || die "client installation failed"
+
+ keepdir /var/"$(get_libdir)"/${PN} || die
+ newinitd "${FILESDIR}"/${PN}.initd ${PN} || die
+ newconfd "${FILESDIR}"/${PN}.confd ${PN} || die
+}