summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2010-05-27 14:37:32 +0000
committerJim Ramsay <lack@gentoo.org>2010-05-27 14:37:32 +0000
commitc245c2fc699f468a4542e2d0cdca5f4e7b98641d (patch)
tree73347778a0e5fb9a8c200ad9683a71733f32dac2 /net-misc/clamz
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-c245c2fc699f468a4542e2d0cdca5f4e7b98641d.tar.gz
gentoo-2-c245c2fc699f468a4542e2d0cdca5f4e7b98641d.tar.bz2
gentoo-2-c245c2fc699f468a4542e2d0cdca5f4e7b98641d.zip
New package: clamz is a command-line downloader for the Amazon.com MP3 music store (Bug #267873)
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/clamz')
-rw-r--r--net-misc/clamz/ChangeLog11
-rw-r--r--net-misc/clamz/clamz-0.4.ebuild44
-rw-r--r--net-misc/clamz/metadata.xml10
3 files changed, 65 insertions, 0 deletions
diff --git a/net-misc/clamz/ChangeLog b/net-misc/clamz/ChangeLog
new file mode 100644
index 000000000000..08d615d661f8
--- /dev/null
+++ b/net-misc/clamz/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-misc/clamz
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/clamz/ChangeLog,v 1.1 2010/05/27 14:37:32 lack Exp $
+
+*clamz-0.4 (27 May 2010)
+
+ 27 May 2010; Jim Ramsay <lack@gentoo.org> +clamz-0.4.ebuild,
+ +metadata.xml:
+ New package: clamz is a command-line downloader for the Amazon.com MP3
+ music store (Bug #267873)
+
diff --git a/net-misc/clamz/clamz-0.4.ebuild b/net-misc/clamz/clamz-0.4.ebuild
new file mode 100644
index 000000000000..1794689fa460
--- /dev/null
+++ b/net-misc/clamz/clamz-0.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/clamz/clamz-0.4.ebuild,v 1.1 2010/05/27 14:37:32 lack Exp $
+
+EAPI=3
+inherit fdo-mime
+
+DESCRIPTION="Command-line downloader for the Amazon.com MP3 music store"
+HOMEPAGE="http://code.google.com/p/clamz/"
+SRC_URI="http://clamz.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND="dev-libs/expat
+ net-misc/curl
+ dev-libs/libgcrypt"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ UPDATE_MIME_DATABASE=true \
+ UPDATE_DESKTOP_DATABASE=true \
+ econf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ dodoc README
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ einfo "To link clamz with your amazon.com account, visit:"
+ einfo " http://www.amazon.com/gp/dmusic/after_download_manager_install.html"
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
diff --git a/net-misc/clamz/metadata.xml b/net-misc/clamz/metadata.xml
new file mode 100644
index 000000000000..13c3c93a929c
--- /dev/null
+++ b/net-misc/clamz/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <maintainer>
+ <email>lack@gentoo.org</email>
+ <name>Jim Ramsay</name>
+ </maintainer>
+</pkgmetadata>
+