summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2003-09-03 09:27:57 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2003-09-03 09:27:57 +0000
commit0563332c3ab67740cdc9d3754ac2be2cdc333a6e (patch)
treeb28b8d81060dc3ba35004d03c3f0e7249f7add9d /net-misc/cidr
parentFixing 27848 (diff)
downloadgentoo-2-0563332c3ab67740cdc9d3754ac2be2cdc333a6e.tar.gz
gentoo-2-0563332c3ab67740cdc9d3754ac2be2cdc333a6e.tar.bz2
gentoo-2-0563332c3ab67740cdc9d3754ac2be2cdc333a6e.zip
Fixing 27848
Diffstat (limited to 'net-misc/cidr')
-rw-r--r--net-misc/cidr/ChangeLog10
-rw-r--r--net-misc/cidr/Manifest4
-rw-r--r--net-misc/cidr/cidr-2.3.1-r1.ebuild31
-rw-r--r--net-misc/cidr/files/cidr-2.3.1.patch46
-rw-r--r--net-misc/cidr/files/digest-cidr-2.3.1-r11
5 files changed, 89 insertions, 3 deletions
diff --git a/net-misc/cidr/ChangeLog b/net-misc/cidr/ChangeLog
index 48721d8ccecd..6c669eaf2a02 100644
--- a/net-misc/cidr/ChangeLog
+++ b/net-misc/cidr/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/cidr
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/cidr/ChangeLog,v 1.6 2003/02/12 08:20:29 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cidr/ChangeLog,v 1.7 2003/09/03 09:27:52 phosphan Exp $
+
+*cidr-2.3.1-r1 (03 Sep 2003)
+
+ 03 Sep 2003; Patrick Kursawe <phosphan@gentoo.org> cidr-2.3.1-r1.ebuild,
+ files/cidr-2.3.1.patch:
+ Fixing bug 27848. Fix was provided by edi <xerox@trmz.org>.
+ Did a few other cleanups in the ebuild (no need to
+ keep another copy of the GPL, you can get rfc 1878 by using rfcutil).
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/net-misc/cidr/Manifest b/net-misc/cidr/Manifest
index 3595808f4872..c32b87f5ebfb 100644
--- a/net-misc/cidr/Manifest
+++ b/net-misc/cidr/Manifest
@@ -1,6 +1,6 @@
MD5 c142a89b021be5e8807a8d2483ef1d52 cidr-2.3.1.ebuild 626
-MD5 07864336037173207b800c7219cfcf66 cidr-2.3.1-r1.ebuild 709
-MD5 8c89feb9b9545984a6e431335f353c2e ChangeLog 851
+MD5 28af9d3329e36d627756505174bdcf8b cidr-2.3.1-r1.ebuild 728
+MD5 7775b035ecd5b921923c51a00ec90c23 ChangeLog 1173
MD5 9b40c019a40f162c064b5d51eb73dd85 files/digest-cidr-2.3.1-r1 63
MD5 0214de5ab88bfffe5c4759a5600b8e3b files/cidr-2.3.1.patch 841
MD5 9b40c019a40f162c064b5d51eb73dd85 files/digest-cidr-2.3.1 63
diff --git a/net-misc/cidr/cidr-2.3.1-r1.ebuild b/net-misc/cidr/cidr-2.3.1-r1.ebuild
new file mode 100644
index 000000000000..3a4da57d011c
--- /dev/null
+++ b/net-misc/cidr/cidr-2.3.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cidr/cidr-2.3.1-r1.ebuild,v 1.1 2003/09/03 09:27:52 phosphan Exp $
+
+TARBALL="cidr-current.tar.gz"
+S=${WORKDIR}/${PN}-2.3
+DESCRIPTION="command line util to assist in calculating subnets."
+SRC_URI="http://home.netcom.com/~naym/cidr/${TARBALL}"
+HOMEPAGE="http://home.netcom.com/~naym/cidr/"
+DEPEND=""
+KEYWORDS="x86 sparc "
+LICENSE="GPL-2"
+SLOT="0"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}.patch || die "patch failed"
+}
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install () {
+
+ dobin cidr
+ dodoc README ChangeLog
+ doman cidr.1
+}
+
diff --git a/net-misc/cidr/files/cidr-2.3.1.patch b/net-misc/cidr/files/cidr-2.3.1.patch
new file mode 100644
index 000000000000..f27b2b52c6f4
--- /dev/null
+++ b/net-misc/cidr/files/cidr-2.3.1.patch
@@ -0,0 +1,46 @@
+--- cidr.c 2001-07-03 09:23:23.000000000 +0200
++++ patched 2003-09-03 11:11:18.000000000 +0200
+@@ -142,18 +142,7 @@
+ }
+ }
+
+- if( (holdaddress=malloc(strlen(argv[1])+1)) == NULL )
+- {
+- fprintf(stderr,"holdaddress malloc() failed.\n");
+- exit(EXIT_FAILURE);
+- }
+
+- if( (holdprefix=malloc(strlen(argv[1])+1)) == NULL )
+- {
+- fprintf(stderr,"holdprefix malloc() failed.\n");
+- exit(EXIT_FAILURE);
+- }
+-
+ strncpy(ip[2],argv[1],18);
+
+
+@@ -166,7 +155,6 @@
+ invalid(1);
+
+
+-
+ holdprefix=strtok(NULL,sep);
+ if(holdprefix==NULL)
+ invalid(1);
+@@ -413,15 +401,12 @@
+ hosts(i,temp,mask,hostlist,lowhost,highhost);
+ else
+ hosts(i,temp,mask,cidrhostlist,lowhost,highhost);
+-
++
+ for(i=0;i<3;i++)
+ {
+ free(ip[i]);
+ }
+
+- free(holdaddress);
+- free(holdprefix);
+-
+ return EXIT_SUCCESS;
+ }
+
diff --git a/net-misc/cidr/files/digest-cidr-2.3.1-r1 b/net-misc/cidr/files/digest-cidr-2.3.1-r1
new file mode 100644
index 000000000000..f2ac46d5b65a
--- /dev/null
+++ b/net-misc/cidr/files/digest-cidr-2.3.1-r1
@@ -0,0 +1 @@
+MD5 5954588563509305df07fd437b51e24a cidr-current.tar.gz 16898