summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2006-08-19 16:00:45 +0000
committerTorsten Veller <tove@gentoo.org>2006-08-19 16:00:45 +0000
commitf75b6627a74b97fc5ec0757ba35493e3946e85c0 (patch)
treef2ff557f2edd922d11fd3735761da17bbbacc82f /net-misc/chrony
parentVersion bump. (diff)
downloadgentoo-2-f75b6627a74b97fc5ec0757ba35493e3946e85c0.tar.gz
gentoo-2-f75b6627a74b97fc5ec0757ba35493e3946e85c0.tar.bz2
gentoo-2-f75b6627a74b97fc5ec0757ba35493e3946e85c0.zip
Updated upstream patches
(Portage version: 2.1-r2)
Diffstat (limited to 'net-misc/chrony')
-rw-r--r--net-misc/chrony/ChangeLog8
-rw-r--r--net-misc/chrony/chrony-1.21-r1.ebuild63
-rw-r--r--net-misc/chrony/files/chrony-1.21-makefile.diff15
-rw-r--r--net-misc/chrony/files/digest-chrony-1.21-r16
4 files changed, 91 insertions, 1 deletions
diff --git a/net-misc/chrony/ChangeLog b/net-misc/chrony/ChangeLog
index cb74488093f6..21942402eade 100644
--- a/net-misc/chrony/ChangeLog
+++ b/net-misc/chrony/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/chrony
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/ChangeLog,v 1.26 2006/07/02 20:52:45 chriswhite Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/ChangeLog,v 1.27 2006/08/19 16:00:45 tove Exp $
+
+*chrony-1.21-r1 (19 Aug 2006)
+
+ 19 Aug 2006; Torsten Veller <tove@gentoo.org>
+ +files/chrony-1.21-makefile.diff, +chrony-1.21-r1.ebuild:
+ Added more patches from upstream.
02 Jul 2006; Chris White <chriswhite@gentoo.org> metadata.xml:
Japanese metdata.xml translation. Thanks to Yoshino-san in bug #134047.
diff --git a/net-misc/chrony/chrony-1.21-r1.ebuild b/net-misc/chrony/chrony-1.21-r1.ebuild
new file mode 100644
index 000000000000..a6c2c4ce4ae7
--- /dev/null
+++ b/net-misc/chrony/chrony-1.21-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/chrony-1.21-r1.ebuild,v 1.1 2006/08/19 16:00:45 tove Exp $
+
+inherit eutils toolchain-funcs
+
+PATCH_VER=1
+PATCHDIR="${WORKDIR}/patch"
+
+DESCRIPTION="NTP client and server programs"
+HOMEPAGE="http://chrony.sunsite.dk/"
+SRC_URI="http://chrony.sunsite.dk/download/${P}.tar.gz
+ mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="readline"
+
+DEPEND="readline? ( >=sys-libs/readline-4.1-r4 )"
+
+src_unpack() {
+ unpack ${A} ; cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.20-conf.c-gentoo.diff
+ epatch "${FILESDIR}"/${PN}-1.20-chrony.conf.example-gentoo.diff
+ epatch "${FILESDIR}"/${P}-makefile.diff
+
+ # patches from chrony git repo: <http://chrony.sunsite.dk/git>
+ EPATCH_MULTI_MSG="Applying patches from upstream..."
+ EPATCH_EXCLUDE="chrony-1.21-quash_compile_warnings.diff"
+ EPATCH_FORCE="yes"
+ EPATCH_SUFFIX="diff" epatch "${PATCHDIR}"
+
+ # Allow Hz=200 detection (#21058, Alexander Papaspyrou)
+# epatch "${FILESDIR}"/${PN}-1.20-sys_linux.c-gentoo.diff
+
+ sed -i "s:/etc/chrony:/etc/chrony/chrony:g" \
+ chrony*.{1,5,8} faq.txt chrony.texi || die "sed failed"
+}
+
+src_compile() {
+ export CC="$(tc-getCC)"
+ econf $(use_enable readline) || die "configure failed"
+ emake all || die "make failed"
+ emake docs || die "make docs failed"
+}
+
+src_install() {
+ dobin chronyc || die "dobin failed"
+ dosbin chronyd || die "dosbin failed"
+
+ dodoc chrony.txt README examples/chrony.{conf,keys}.example || die "dodoc failed"
+ dohtml chrony.html || die "dohtml failed"
+ doman *.{1,5,8}
+ doinfo chrony.info*
+
+ newinitd "${FILESDIR}"/chronyd.rc chronyd || die "newinitd failed"
+ dosed "s:the documentation directory:/usr/share/doc/${PF}/:" \
+ /etc/init.d/chronyd || die "doc sed failed"
+ newconfd "${FILESDIR}"/chronyd.conf chronyd || die "newconfd failed"
+
+ keepdir /var/{lib,log}/chrony /etc/chrony
+}
diff --git a/net-misc/chrony/files/chrony-1.21-makefile.diff b/net-misc/chrony/files/chrony-1.21-makefile.diff
new file mode 100644
index 000000000000..9114f6fdeb01
--- /dev/null
+++ b/net-misc/chrony/files/chrony-1.21-makefile.diff
@@ -0,0 +1,15 @@
+--- Makefile.in_old 2006-08-12 17:42:57.000000000 +0200
++++ Makefile.in 2006-08-12 17:44:35.000000000 +0200
+@@ -68,10 +68,10 @@
+ all : chronyd chronyc
+
+ chronyd : $(OBJS) $(EXTRA_OBJS)
+- $(CC) $(OPTFLAGS) -o chronyd $(OBJS) $(EXTRA_OBJS) $(LIBS) $(EXTRA_LIBS)
++ $(CC) $(OPTFLAGS) $(LDFLAGS) -o chronyd $(OBJS) $(EXTRA_OBJS) $(LIBS) $(EXTRA_LIBS)
+
+ chronyc : $(CLI_OBJS)
+- $(CC) $(OPTFLAGS) -o chronyc $(CLI_OBJS) @READLINE_LINK@ $(LIBS) $(EXTRA_CLI_LIBS)
++ $(CC) $(OPTFLAGS) $(LDFLAGS) -o chronyc $(CLI_OBJS) @READLINE_LINK@ $(LIBS) $(EXTRA_CLI_LIBS)
+
+ client.o : client.c
+ $(CC) $(CFLAGS) $(DEFS) @READLINE_COMPILE@ -c $<
diff --git a/net-misc/chrony/files/digest-chrony-1.21-r1 b/net-misc/chrony/files/digest-chrony-1.21-r1
new file mode 100644
index 000000000000..5e86b3f0d71a
--- /dev/null
+++ b/net-misc/chrony/files/digest-chrony-1.21-r1
@@ -0,0 +1,6 @@
+MD5 e5c6003f8be57d1683642eb04c1b9657 chrony-1.21-patches-1.tar.bz2 5093
+RMD160 c278b29087751395e934fc47866f2e377247cfbd chrony-1.21-patches-1.tar.bz2 5093
+SHA256 97568234a0844f54deab250d049c2f30de2dde48c216ca3d12a070e367516dce chrony-1.21-patches-1.tar.bz2 5093
+MD5 84f76a73dff5a3c9e9f11f3c29a4e93b chrony-1.21.tar.gz 310709
+RMD160 5a758608b0ff0d578b3d4597f4ee6ef740492b9b chrony-1.21.tar.gz 310709
+SHA256 baca3d36e6f458bed31c82f08f3c5f9d61b43baafc4d17f3e0a74dec7ff737d3 chrony-1.21.tar.gz 310709