summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWout Mertens <wmertens@gentoo.org>2003-03-18 10:27:05 +0000
committerWout Mertens <wmertens@gentoo.org>2003-03-18 10:27:05 +0000
commite82bc13e9633fd407925d1e0e76be5a7bcce080d (patch)
tree4db29de4bf9ae287a48284b886913f6e07ae5006 /net-misc/chrony
parentfixed bug. (diff)
downloadgentoo-2-e82bc13e9633fd407925d1e0e76be5a7bcce080d.tar.gz
gentoo-2-e82bc13e9633fd407925d1e0e76be5a7bcce080d.tar.bz2
gentoo-2-e82bc13e9633fd407925d1e0e76be5a7bcce080d.zip
Version bump
Diffstat (limited to 'net-misc/chrony')
-rw-r--r--net-misc/chrony/ChangeLog9
-rw-r--r--net-misc/chrony/chrony-1.19.ebuild68
-rw-r--r--net-misc/chrony/files/chrony-1.19-chrony.conf.example-gentoo.diff57
-rw-r--r--net-misc/chrony/files/chrony-1.19-conf.c-gentoo.diff11
-rw-r--r--net-misc/chrony/files/digest-chrony-1.191
5 files changed, 145 insertions, 1 deletions
diff --git a/net-misc/chrony/ChangeLog b/net-misc/chrony/ChangeLog
index 4a187e117712..14adcb1cb44a 100644
--- a/net-misc/chrony/ChangeLog
+++ b/net-misc/chrony/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/chrony
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/ChangeLog,v 1.6 2003/02/12 08:20:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/ChangeLog,v 1.7 2003/03/18 10:27:05 wmertens Exp $
+
+*chrony-1.19 (18 Mar 2003)
+
+ 18 Mar 2003; Wout Mertens <wmertens@gentoo.org> :
+ Version bump, no changes to the ebuild needed.
+ Still wondering whether the drift and rtc files shouldn't go in
+ /var somewhere.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/net-misc/chrony/chrony-1.19.ebuild b/net-misc/chrony/chrony-1.19.ebuild
new file mode 100644
index 000000000000..4b5d3e9f3fa5
--- /dev/null
+++ b/net-misc/chrony/chrony-1.19.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/chrony-1.19.ebuild,v 1.1 2003/03/18 10:27:05 wmertens Exp $
+
+IUSE="readline"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="NTP client and server programs"
+SRC_URI="http://chrony.sunsite.dk/download/${P}.tar.gz"
+HOMEPAGE="http://chrony.sunsite.dk"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 sparc "
+
+DEPEND="virtual/glibc
+ readline? ( >=readline-4.1-r4 )"
+RDEPEND=$DEPEND
+
+# Patch the distribution so that it puts stuff in /etc/chrony/ by default
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp conf.c conf.c.orig
+ patch -p0 < ${FILESDIR}/${P}-conf.c-gentoo.diff
+ cd examples
+ cp chrony.conf.example chrony.conf.example.orig
+ patch -p0 < ${FILESDIR}/${P}-chrony.conf.example-gentoo.diff
+}
+
+src_compile() {
+
+ local myconf
+
+ use readline || myconf="--disable-readline"
+
+ ./configure \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ $myconf || die "./configure failed"
+
+ emake all docs || die
+}
+
+src_install () {
+ # the chrony install is brain-dead so we'll
+ # just do it ourselves.
+
+ dobin chronyc
+ dosbin chronyd
+
+ # documentation
+ dodoc chrony.txt chrony.html COPYING README
+
+ # man pages
+ doman *.{1,5,8}
+
+ # info files
+ doinfo chrony.info*
+
+ # example configuration files
+ dodoc examples/chrony.conf.example
+ dodoc examples/chrony.keys.example
+
+ # system configuration
+ exeinto /etc/init.d ; newexe ${FILESDIR}/chronyd.rc chronyd
+ dodir /etc/chrony
+}
diff --git a/net-misc/chrony/files/chrony-1.19-chrony.conf.example-gentoo.diff b/net-misc/chrony/files/chrony-1.19-chrony.conf.example-gentoo.diff
new file mode 100644
index 000000000000..2194109efeb9
--- /dev/null
+++ b/net-misc/chrony/files/chrony-1.19-chrony.conf.example-gentoo.diff
@@ -0,0 +1,57 @@
+--- chrony.conf.example.orig Sun May 12 18:16:30 2002
++++ chrony.conf.example Sun May 12 18:17:12 2002
+@@ -2,7 +2,7 @@
+ # $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/files/chrony-1.19-chrony.conf.example-gentoo.diff,v 1.1 2003/03/18 10:27:05 wmertens Exp $
+ #
+ # This is an example chrony configuration file. You should copy it to
+-# /etc/chrony.conf after uncommenting and editing the options that you
++# /etc/chrony/chrony.conf after uncommenting and editing the options that you
+ # want to enable. I have not included the more obscure options. Refer
+ # to the documentation for these.
+ #
+@@ -90,7 +90,7 @@
+ # immediately so that it doesn't gain or lose any more time. You
+ # generally want this, so it is uncommented.
+
+-driftfile /etc/chrony.drift
++driftfile /etc/chrony/chrony.drift
+
+ # If you want to use the program called chronyc to configure aspects of
+ # chronyd's operation once it is running (e.g. tell it the Internet link
+@@ -99,7 +99,7 @@
+ # exchanges between cooperating machines.) Again, this option is
+ # assumed by default.
+
+-keyfile /etc/chrony.keys
++keyfile /etc/chrony/chrony.keys
+
+ # Tell chronyd which numbered key in the file is used as the password
+ # for chronyc. (You can pick any integer up to 2**32-1. '1' is just a
+@@ -157,8 +157,8 @@
+ ! logdir /var/log/chrony
+ ! log measurements statistics tracking
+
+-If you have real time clock support enabled (see below), you might want
+-this line instead:
++# If you have real time clock support enabled (see below), you might want
++# this line instead:
+
+ ! log measurements statistics tracking rtc
+
+@@ -268,7 +268,7 @@
+ # You need to have 'enhanced RTC support' compiled into your Linux
+ # kernel. (Note, these options apply only to Linux.)
+
+-! rtcfile /etc/chrony.rtc
++! rtcfile /etc/chrony/chrony.rtc
+
+ # Your RTC can be set to keep Universal Coordinated Time (UTC) or local
+ # time. (Local time means UTC +/- the effect of your timezone.) If you
+@@ -284,6 +284,6 @@
+ # /dev/rtc. If it's accessed somewhere else on your system (e.g. you're
+ # using devfs), uncomment and edit the following line.
+
+-! rtcdevice /dev/misc/rtc
++rtcdevice /dev/misc/rtc
+
+ #######################################################################
diff --git a/net-misc/chrony/files/chrony-1.19-conf.c-gentoo.diff b/net-misc/chrony/files/chrony-1.19-conf.c-gentoo.diff
new file mode 100644
index 000000000000..fabc47097ff9
--- /dev/null
+++ b/net-misc/chrony/files/chrony-1.19-conf.c-gentoo.diff
@@ -0,0 +1,11 @@
+--- conf.c.orig Sun May 12 14:07:31 2002
++++ conf.c Sun May 12 14:07:52 2002
+@@ -45,7 +45,7 @@
+
+ /* ================================================== */
+
+-#define DEFAULT_CONF_FILE "/etc/chrony.conf"
++#define DEFAULT_CONF_FILE "/etc/chrony/chrony.conf"
+
+ /* ================================================== */
+ /* Forward prototypes */
diff --git a/net-misc/chrony/files/digest-chrony-1.19 b/net-misc/chrony/files/digest-chrony-1.19
new file mode 100644
index 000000000000..f419b6ec30ad
--- /dev/null
+++ b/net-misc/chrony/files/digest-chrony-1.19
@@ -0,0 +1 @@
+MD5 d1f55269fe0d6013de5455764752a52d chrony-1.19.tar.gz 311066