summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-08 01:47:43 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-08 01:47:43 +0000
commit68a1595d15d4b722b7036d2663a3b634b13b3bfa (patch)
treeecaadc2c834b600f1b19eb77f7a09b482b04fdfa /net-misc/chrony
parentnon-us keymaps such as qwerty or azerty fail with flex error (diff)
downloadgentoo-2-68a1595d15d4b722b7036d2663a3b634b13b3bfa.tar.gz
gentoo-2-68a1595d15d4b722b7036d2663a3b634b13b3bfa.tar.bz2
gentoo-2-68a1595d15d4b722b7036d2663a3b634b13b3bfa.zip
version bump #25347
Diffstat (limited to 'net-misc/chrony')
-rw-r--r--net-misc/chrony/ChangeLog7
-rw-r--r--net-misc/chrony/chrony-1.19.99.2.ebuild45
-rw-r--r--net-misc/chrony/files/chrony-1.19.99.2-chrony.conf.example-gentoo.diff46
-rw-r--r--net-misc/chrony/files/chrony-1.19.99.2-conf.c-gentoo.diff11
-rw-r--r--net-misc/chrony/files/digest-chrony-1.19.99.21
5 files changed, 109 insertions, 1 deletions
diff --git a/net-misc/chrony/ChangeLog b/net-misc/chrony/ChangeLog
index ea0894dcb842..f30c5f23035e 100644
--- a/net-misc/chrony/ChangeLog
+++ b/net-misc/chrony/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/chrony
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/ChangeLog,v 1.8 2003/06/16 16:08:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/ChangeLog,v 1.9 2003/08/08 01:47:43 vapier Exp $
+
+*chrony-1.19.99.2 (07 Aug 2003)
+
+ 07 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
+ Update to work with newer kernels #25347.
*chrony-1.19 (18 Mar 2003)
diff --git a/net-misc/chrony/chrony-1.19.99.2.ebuild b/net-misc/chrony/chrony-1.19.99.2.ebuild
new file mode 100644
index 000000000000..459e7ed151ae
--- /dev/null
+++ b/net-misc/chrony/chrony-1.19.99.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/chrony-1.19.99.2.ebuild,v 1.1 2003/08/08 01:47:43 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="NTP client and server programs"
+HOMEPAGE="http://chrony.sunsite.dk/"
+SRC_URI="http://chrony.sunsite.dk/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+IUSE="readline"
+
+DEPEND="virtual/glibc
+ readline? ( >=readline-4.1-r4 )"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+
+ epatch ${FILESDIR}/${P}-conf.c-gentoo.diff
+ epatch ${FILESDIR}/${P}-chrony.conf.example-gentoo.diff
+}
+
+src_compile() {
+ econf `use_enable readline` || die
+ emake all docs || die
+}
+
+src_install() {
+ # the chrony install is brain-dead so we'll just do it ourselves
+ dobin chronyc
+ dosbin chronyd
+
+ dodoc chrony.txt README examples/chrony.{conf,keys}.example
+ dohtml chrony.html
+ doman *.{1,5,8}
+ doinfo chrony.info*
+
+ dodir /etc/chrony
+ exeinto /etc/init.d ; newexe ${FILESDIR}/chronyd.rc chronyd
+ insinto /etc/conf.d ; newins ${FILESDIR}/chronyd.conf chronyd
+ dosed "s:the documentation directory:/usr/share/doc/${PF}/:" /etc/init.d/chronyd
+}
diff --git a/net-misc/chrony/files/chrony-1.19.99.2-chrony.conf.example-gentoo.diff b/net-misc/chrony/files/chrony-1.19.99.2-chrony.conf.example-gentoo.diff
new file mode 100644
index 000000000000..7f1f2c9cccfc
--- /dev/null
+++ b/net-misc/chrony/files/chrony-1.19.99.2-chrony.conf.example-gentoo.diff
@@ -0,0 +1,46 @@
+--- examples/chrony.conf.example.orig 2003-06-16 11:59:01.000000000 -0400
++++ examples/chrony.conf.example 2003-06-16 12:00:13.000000000 -0400
+@@ -3,5 +3,5 @@
+ #
+ # This is an example chrony configuration file. You should copy it to
+-# /etc/chrony.conf after uncommenting and editing the options that you
++# /etc/chrony/chrony.conf after uncommenting and editing the options that you
+ # want to enable. I have not included the more obscure options. Refer
+ # to the documentation for these.
+@@ -91,5 +91,5 @@
+ # generally want this, so it is uncommented.
+
+-driftfile /etc/chrony.drift
++driftfile /etc/chrony/chrony.drift
+
+ # If you want to use the program called chronyc to configure aspects of
+@@ -100,5 +100,5 @@
+ # assumed by default.
+
+-keyfile /etc/chrony.keys
++keyfile /etc/chrony/chrony.keys
+
+ # Tell chronyd which numbered key in the file is used as the password
+@@ -158,6 +158,6 @@
+ ! log measurements statistics tracking
+
+-If you have real time clock support enabled (see below), you might want
+-this line instead:
++# If you have real time clock support enabled (see below), you might want
++# this line instead:
+
+ ! log measurements statistics tracking rtc
+@@ -269,5 +269,5 @@
+ # kernel. (Note, these options apply only to Linux.)
+
+-! rtcfile /etc/chrony.rtc
++! rtcfile /etc/chrony/chrony.rtc
+
+ # Your RTC can be set to keep Universal Coordinated Time (UTC) or local
+@@ -285,5 +285,5 @@
+ # using devfs), uncomment and edit the following line.
+
+-! rtcdevice /dev/misc/rtc
++rtcdevice /dev/misc/rtc
+
+ #######################################################################
diff --git a/net-misc/chrony/files/chrony-1.19.99.2-conf.c-gentoo.diff b/net-misc/chrony/files/chrony-1.19.99.2-conf.c-gentoo.diff
new file mode 100644
index 000000000000..fabc47097ff9
--- /dev/null
+++ b/net-misc/chrony/files/chrony-1.19.99.2-conf.c-gentoo.diff
@@ -0,0 +1,11 @@
+--- conf.c.orig Sun May 12 14:07:31 2002
++++ conf.c Sun May 12 14:07:52 2002
+@@ -45,7 +45,7 @@
+
+ /* ================================================== */
+
+-#define DEFAULT_CONF_FILE "/etc/chrony.conf"
++#define DEFAULT_CONF_FILE "/etc/chrony/chrony.conf"
+
+ /* ================================================== */
+ /* Forward prototypes */
diff --git a/net-misc/chrony/files/digest-chrony-1.19.99.2 b/net-misc/chrony/files/digest-chrony-1.19.99.2
new file mode 100644
index 000000000000..952973fcb9ce
--- /dev/null
+++ b/net-misc/chrony/files/digest-chrony-1.19.99.2
@@ -0,0 +1 @@
+MD5 a126c617beb2a6b99861cadd095da0f5 chrony-1.19.99.2.tar.gz 307479