summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-12-10 13:22:06 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-12-10 13:22:06 +0000
commite6e1add70dc6115dbc704de318a2561db7596e10 (patch)
tree7f9fd5b5ec90e1a0f05b4af80ff2fc06f4eb139d /net-misc/cgminer
parentStable for amd64, wrt bug #491278 (diff)
downloadgentoo-2-e6e1add70dc6115dbc704de318a2561db7596e10.tar.gz
gentoo-2-e6e1add70dc6115dbc704de318a2561db7596e10.tar.bz2
gentoo-2-e6e1add70dc6115dbc704de318a2561db7596e10.zip
Version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-misc/cgminer')
-rw-r--r--net-misc/cgminer/ChangeLog8
-rw-r--r--net-misc/cgminer/cgminer-3.8.4.ebuild6
-rw-r--r--net-misc/cgminer/cgminer-3.8.5.ebuild72
3 files changed, 82 insertions, 4 deletions
diff --git a/net-misc/cgminer/ChangeLog b/net-misc/cgminer/ChangeLog
index a50ca5e37f31..54b9df1c6d73 100644
--- a/net-misc/cgminer/ChangeLog
+++ b/net-misc/cgminer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/cgminer
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/cgminer/ChangeLog,v 1.54 2013/12/07 19:01:36 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cgminer/ChangeLog,v 1.55 2013/12/10 13:22:06 blueness Exp $
+
+*cgminer-3.8.5 (10 Dec 2013)
+
+ 10 Dec 2013; Anthony G. Basile <blueness@gentoo.org> +cgminer-3.8.5.ebuild,
+ cgminer-3.8.4.ebuild:
+ Version bump
07 Dec 2013; Anthony G. Basile <blueness@gentoo.org> -cgminer-3.8.3.ebuild,
cgminer-3.8.4.ebuild:
diff --git a/net-misc/cgminer/cgminer-3.8.4.ebuild b/net-misc/cgminer/cgminer-3.8.4.ebuild
index 92da236bfc2a..559848bf8f76 100644
--- a/net-misc/cgminer/cgminer-3.8.4.ebuild
+++ b/net-misc/cgminer/cgminer-3.8.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/cgminer/cgminer-3.8.4.ebuild,v 1.2 2013/12/07 19:01:36 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cgminer/cgminer-3.8.4.ebuild,v 1.3 2013/12/10 13:22:06 blueness Exp $
EAPI=5
@@ -8,8 +8,8 @@ inherit autotools flag-o-matic
DESCRIPTION="Bitcoin CPU/GPU/FPGA/ASIC miner in C"
HOMEPAGE="http://bitcointalk.org/?topic=28402.msg357369 http://github.com/ckolivas/cgminer"
-SRC_URI="http://ck.kolivas.org/apps/cgminer/${P}.tar.bz2"
-#SRC_URI="http://ck.kolivas.org/apps/cgminer/3.8/${P}.tar.bz2"
+#SRC_URI="http://ck.kolivas.org/apps/cgminer/${P}.tar.bz2"
+SRC_URI="http://ck.kolivas.org/apps/cgminer/3.8/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
diff --git a/net-misc/cgminer/cgminer-3.8.5.ebuild b/net-misc/cgminer/cgminer-3.8.5.ebuild
new file mode 100644
index 000000000000..2417d417bbef
--- /dev/null
+++ b/net-misc/cgminer/cgminer-3.8.5.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cgminer/cgminer-3.8.5.ebuild,v 1.1 2013/12/10 13:22:06 blueness Exp $
+
+EAPI=5
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Bitcoin CPU/GPU/FPGA/ASIC miner in C"
+HOMEPAGE="http://bitcointalk.org/?topic=28402.msg357369 http://github.com/ckolivas/cgminer"
+SRC_URI="http://ck.kolivas.org/apps/cgminer/${P}.tar.bz2"
+#SRC_URI="http://ck.kolivas.org/apps/cgminer/3.8/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc examples udev hardened ncurses
+ avalon bflsc bitforce bitfury icarus klondike modminer"
+
+REQUIRED_USE="|| ( avalon bflsc bitforce bitfury icarus klondike modminer )"
+
+RDEPEND="net-misc/curl
+ dev-libs/jansson
+ ncurses? ( sys-libs/ncurses )
+ avalon? ( virtual/libusb:1 )
+ bflsc? ( virtual/libusb:1 )
+ bitforce? ( virtual/libusb:1 )
+ bitfury? ( virtual/libusb:1 )
+ icarus? ( virtual/libusb:1 )
+ modminer? ( virtual/libusb:1 )"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ use hardened && append-cflags "-nopie"
+
+ econf $(use_with ncurses curses) \
+ $(use_enable avalon) \
+ $(use_enable bflsc) \
+ $(use_enable bitforce) \
+ $(use_enable bitfury) \
+ $(use_enable icarus) \
+ $(use_enable klondike) \
+ $(use_enable modminer)
+ # sanitize directories (is this still needed?)
+ sed -i 's~^\(\#define CGMINER_PREFIX \).*$~\1"'"${EPREFIX}/usr/lib/cgminer"'"~' config.h
+}
+
+src_install() { # How about using some make install?
+ dobin cgminer
+ insinto /lib/udev/rules.d
+ use udev && doins 01-cgminer.rules
+ if use doc; then
+ dodoc AUTHORS NEWS README API-README
+ use icarus || use bitforce || use modminer && dodoc FPGA-README
+ use avalon || use bflsc && dodoc ASIC-README
+ fi
+
+ if use modminer; then
+ insinto /usr/lib/cgminer/modminer
+ doins bitstreams/*.ncd
+ dodoc bitstreams/COPYING_fpgaminer
+ fi
+ if use examples; then
+ docinto examples
+ dodoc api-example.php miner.php API.java api-example.c example.conf
+ fi
+}