summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2011-01-30 20:39:30 +0000
committerChristian Ruppert <idl0r@gentoo.org>2011-01-30 20:39:30 +0000
commit568d6a0e5bf5ea6d5b31280ab50ec3bc5948246d (patch)
treeef44fe10007eca9747780df92e993a41620f9b5c /net-misc/cfengine
parentFix typo (diff)
downloadgentoo-2-568d6a0e5bf5ea6d5b31280ab50ec3bc5948246d.tar.gz
gentoo-2-568d6a0e5bf5ea6d5b31280ab50ec3bc5948246d.tar.bz2
gentoo-2-568d6a0e5bf5ea6d5b31280ab50ec3bc5948246d.zip
QDBM and Tokyo Cabinet can't be used together
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/cfengine')
-rw-r--r--net-misc/cfengine/ChangeLog6
-rw-r--r--net-misc/cfengine/cfengine-3.1.2.ebuild16
-rw-r--r--net-misc/cfengine/cfengine-3.1.3.ebuild16
3 files changed, 27 insertions, 11 deletions
diff --git a/net-misc/cfengine/ChangeLog b/net-misc/cfengine/ChangeLog
index ffa06f78abd3..455767078f8d 100644
--- a/net-misc/cfengine/ChangeLog
+++ b/net-misc/cfengine/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/cfengine
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/cfengine/ChangeLog,v 1.125 2011/01/23 15:35:35 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cfengine/ChangeLog,v 1.126 2011/01/30 20:39:29 idl0r Exp $
+
+ 30 Jan 2011; Christian Ruppert <idl0r@gentoo.org> cfengine-3.1.2.ebuild,
+ cfengine-3.1.3.ebuild:
+ QDBM and Tokyo Cabinet can't be used together
23 Jan 2011; Christian Ruppert <idl0r@gentoo.org> cfengine-3.1.2.ebuild,
cfengine-3.1.3.ebuild:
diff --git a/net-misc/cfengine/cfengine-3.1.2.ebuild b/net-misc/cfengine/cfengine-3.1.2.ebuild
index 0fa14d2772fd..aa6b255884a9 100644
--- a/net-misc/cfengine/cfengine-3.1.2.ebuild
+++ b/net-misc/cfengine/cfengine-3.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/cfengine/cfengine-3.1.2.ebuild,v 1.5 2011/01/23 15:35:35 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cfengine/cfengine-3.1.2.ebuild,v 1.6 2011/01/30 20:39:30 idl0r Exp $
EAPI="3"
@@ -29,7 +29,7 @@ DEPEND=">=sys-libs/db-4
postgres? ( dev-db/postgresql-base )
selinux? ( sys-libs/libselinux )
tokyocabinet? ( dev-db/tokyocabinet )
- qdbm? ( dev-db/qdbm )
+ !tokyocabinet? ( qdbm? ( dev-db/qdbm ) )
!tokyocabinet? ( !qdbm? ( >=sys-libs/db-4 ) )
>=dev-libs/openssl-0.9.7
dev-libs/libpcre"
@@ -47,8 +47,16 @@ src_configure() {
myconf="--without-sql"
fi
+ # BDB by default, prefer tokyocabinet above qdbm...
if ! use qdbm && ! use tokyocabinet; then
myconf="${myconf} --with-berkeleydb=/usr"
+ elif use qdbm && use tokyocabinet; then
+ elog "QDBM and Tokyo Cabinet can't be used together, using Tokyo Cabinet by default"
+ myconf="${myconf} --with-tokyocabinet"
+ elif use qdbm && ! use tokyocabinet; then
+ myconf="${myconf} --with-qdbm"
+ elif ! use qdbm && use tokyocabinet; then
+ myconf="${myconf} --with-tokyocabinet"
fi
# Enforce /var/cfengine for historical compatibility
@@ -61,9 +69,7 @@ src_configure() {
$(use_with gd) \
$(use_with graphviz) \
$(use_with ldap) \
- $(use_with qdbm) \
- $(use_enable selinux) \
- $(use_with tokyocabinet)
+ $(use_enable selinux)
# Fix Makefile to skip inputs, see below "examples"
sed -i -e 's/\(SUBDIRS.*\) inputs/\1/' Makefile || die
diff --git a/net-misc/cfengine/cfengine-3.1.3.ebuild b/net-misc/cfengine/cfengine-3.1.3.ebuild
index 4561f9b60509..596bd76b5263 100644
--- a/net-misc/cfengine/cfengine-3.1.3.ebuild
+++ b/net-misc/cfengine/cfengine-3.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/cfengine/cfengine-3.1.3.ebuild,v 1.4 2011/01/23 15:35:35 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cfengine/cfengine-3.1.3.ebuild,v 1.5 2011/01/30 20:39:30 idl0r Exp $
EAPI="3"
@@ -29,7 +29,7 @@ DEPEND=">=sys-libs/db-4
postgres? ( dev-db/postgresql-base )
selinux? ( sys-libs/libselinux )
tokyocabinet? ( dev-db/tokyocabinet )
- qdbm? ( dev-db/qdbm )
+ !tokyocabinet? ( qdbm? ( dev-db/qdbm ) )
!tokyocabinet? ( !qdbm? ( >=sys-libs/db-4 ) )
>=dev-libs/openssl-0.9.7
dev-libs/libpcre"
@@ -47,8 +47,16 @@ src_configure() {
myconf="--without-sql"
fi
+ # BDB by default, prefer tokyocabinet above qdbm...
if ! use qdbm && ! use tokyocabinet; then
myconf="${myconf} --with-berkeleydb=/usr"
+ elif use qdbm && use tokyocabinet; then
+ elog "QDBM and Tokyo Cabinet can't be used together, using Tokyo Cabinet by default"
+ myconf="${myconf} --with-tokyocabinet"
+ elif use qdbm && ! use tokyocabinet; then
+ myconf="${myconf} --with-qdbm"
+ elif ! use qdbm && use tokyocabinet; then
+ myconf="${myconf} --with-tokyocabinet"
fi
# Enforce /var/cfengine for historical compatibility
@@ -61,9 +69,7 @@ src_configure() {
$(use_with gd) \
$(use_with graphviz) \
$(use_with ldap) \
- $(use_with qdbm) \
- $(use_enable selinux) \
- $(use_with tokyocabinet)
+ $(use_enable selinux)
# Fix Makefile to skip inputs, see below "examples"
sed -i -e 's/\(SUBDIRS.*\) inputs/\1/' Makefile || die