summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-05-30 13:13:43 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-05-30 13:13:43 +0000
commit4f53131a3b3c7256e6c0248e503756ecbe608d92 (patch)
treebf6cbdcf776081dcaa71cd21cc178d41c98b3abd /net-misc/bwwhois
parentmasking qt 3.2.0 beta1 (diff)
downloadgentoo-2-4f53131a3b3c7256e6c0248e503756ecbe608d92.tar.gz
gentoo-2-4f53131a3b3c7256e6c0248e503756ecbe608d92.tar.bz2
gentoo-2-4f53131a3b3c7256e6c0248e503756ecbe608d92.zip
clean up and perl-module inheritance
Diffstat (limited to 'net-misc/bwwhois')
-rw-r--r--net-misc/bwwhois/ChangeLog5
-rw-r--r--net-misc/bwwhois/Manifest4
-rw-r--r--net-misc/bwwhois/bwwhois-3.2.ebuild20
3 files changed, 18 insertions, 11 deletions
diff --git a/net-misc/bwwhois/ChangeLog b/net-misc/bwwhois/ChangeLog
index bf503f222b20..e8e438939687 100644
--- a/net-misc/bwwhois/ChangeLog
+++ b/net-misc/bwwhois/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-misc/bwwhois
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/bwwhois/ChangeLog,v 1.2 2003/02/12 08:19:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bwwhois/ChangeLog,v 1.3 2003/05/30 13:13:40 seemant Exp $
+
+ 30 May 2003; Seemant Kulleen <seemant@gentoo.org> bwwhois-3.2.ebuild:
+ ebuild cleanup and inherit perl-module instead of perl-pod
*bwwhois-3.2 (22 Dec 2002)
diff --git a/net-misc/bwwhois/Manifest b/net-misc/bwwhois/Manifest
index 96daf4517cdf..b6834eb7d402 100644
--- a/net-misc/bwwhois/Manifest
+++ b/net-misc/bwwhois/Manifest
@@ -1,3 +1,3 @@
-MD5 68c35786837fae27b0537d31e4c0ed5d ChangeLog 401
-MD5 11107373662d2da1d7594e67c9e38a9a bwwhois-3.2.ebuild 835
+MD5 86b6b4dbabbf9d26d4a33697bb009834 bwwhois-3.2.ebuild 872
+MD5 3e1e777f4c024bfc0599b73a8bfad2f4 ChangeLog 536
MD5 ff6a82dfde2579397ea8c617e1a30c22 files/digest-bwwhois-3.2 57
diff --git a/net-misc/bwwhois/bwwhois-3.2.ebuild b/net-misc/bwwhois/bwwhois-3.2.ebuild
index 591826b310a5..7fd6b74cfd2a 100644
--- a/net-misc/bwwhois/bwwhois-3.2.ebuild
+++ b/net-misc/bwwhois/bwwhois-3.2.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/bwwhois/bwwhois-3.2.ebuild,v 1.3 2003/03/11 21:11:46 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bwwhois/bwwhois-3.2.ebuild,v 1.4 2003/05/30 13:13:40 seemant Exp $
-inherit perl-post
+inherit perl-module
-P=whois-3.2
-S=${WORKDIR}/${P}
-A=${P}.tgz
+MY_P=${P/bw/}
+
+S=${WORKDIR}/${MY_P}
DESCRIPTION="Perl-based whois client designed to work with the new Shared Registration System"
-SRC_URI="http://whois.bw.org/dist/${A}"
+SRC_URI="http://whois.bw.org/dist/${MY_P}.tgz"
HOMEPAGE="http://whois.bw.org/"
SLOT="0"
@@ -23,6 +23,10 @@ src_unpack() {
cd ${S}
}
+src_compile() {
+ einfo "no compilation necessary"
+}
+
src_install () {
exeinto usr/bin
@@ -34,8 +38,8 @@ src_install () {
insinto etc/whois
doins whois.conf tld.conf sd.conf
- perl-post_perlinfo
+ perlinfo
insinto ${SITE_LIB}
doins bwInclude.pm
- perl-post_updatepod
+ updatepod
}