summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2015-05-14 13:01:52 +0000
committerTony Vroon <chainsaw@gentoo.org>2015-05-14 13:01:52 +0000
commit520bcf975102bd12855fdde379c43aa32dbe9913 (patch)
tree6fa9b3abff19a28b664689b3c26fc1611e33ecd0 /net-misc/bird
parentFixed dependency on talloc (bug #549452) (diff)
downloadgentoo-2-520bcf975102bd12855fdde379c43aa32dbe9913.tar.gz
gentoo-2-520bcf975102bd12855fdde379c43aa32dbe9913.tar.bz2
gentoo-2-520bcf975102bd12855fdde379c43aa32dbe9913.zip
Version bump, as requested by Moyaze Shivji in the LINX technology team. This addresses a BGP bug where TX was postponed unreasonably long and hold timers could expire.
(Portage version: 2.2.19/cvs/Linux x86_64, signed Manifest commit with key 0xB5058F9A)
Diffstat (limited to 'net-misc/bird')
-rw-r--r--net-misc/bird/ChangeLog11
-rw-r--r--net-misc/bird/bird-1.5.0.ebuild62
2 files changed, 71 insertions, 2 deletions
diff --git a/net-misc/bird/ChangeLog b/net-misc/bird/ChangeLog
index 30c444afea31..b7d4479c90d8 100644
--- a/net-misc/bird/ChangeLog
+++ b/net-misc/bird/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/bird
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/bird/ChangeLog,v 1.30 2014/10/13 12:44:36 chainsaw Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bird/ChangeLog,v 1.31 2015/05/14 13:01:52 chainsaw Exp $
+
+*bird-1.5.0 (14 May 2015)
+
+ 14 May 2015; Tony Vroon <chainsaw@gentoo.org> +bird-1.5.0.ebuild:
+ Version bump, as requested by Moyaze Shivji in the LINX technology team. This
+ addresses a BGP bug where TX was postponed unreasonably long and hold timers
+ could expire.
*bird-1.4.5 (13 Oct 2014)
diff --git a/net-misc/bird/bird-1.5.0.ebuild b/net-misc/bird/bird-1.5.0.ebuild
new file mode 100644
index 000000000000..d33260fc1ed9
--- /dev/null
+++ b/net-misc/bird/bird-1.5.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bird/bird-1.5.0.ebuild,v 1.1 2015/05/14 13:01:52 chainsaw Exp $
+
+EAPI=5
+
+DESCRIPTION="A routing daemon implementing OSPF, RIPv2 & BGP for IPv4 or IPv6"
+HOMEPAGE="http://bird.network.cz"
+SRC_URI="ftp://bird.network.cz/pub/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug ipv6"
+
+RDEPEND="sys-libs/ncurses
+ sys-libs/readline"
+DEPEND="sys-devel/flex
+ sys-devel/bison
+ sys-devel/m4"
+
+src_prepare() {
+ mkdir ipv6
+ tar c --exclude ipv6 . | tar x -C ipv6
+}
+
+src_configure() {
+ econf \
+ --enable-client \
+ --disable-ipv6 \
+ --localstatedir="${EPREFIX}/var" \
+ $(use_enable debug)
+
+ if use ipv6; then
+ cd ipv6
+ econf \
+ --enable-client \
+ --enable-ipv6 \
+ --localstatedir="${EPREFIX}/var" \
+ $(use_enable debug)
+ fi
+}
+
+src_compile() {
+ emake
+ if use ipv6; then
+ cd ipv6
+ emake
+ fi
+}
+
+src_install() {
+ if use ipv6; then
+ newbin ipv6/birdc birdc6
+ newsbin ipv6/bird bird6
+ newinitd "${FILESDIR}/initd-v6-${PN}-1.3.8" bird6
+ fi
+ dobin birdc
+ dosbin bird
+ newinitd "${FILESDIR}/initd-v4-${PN}-1.3.8" bird
+ dodoc doc/bird.conf.example
+}