summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-02-27 23:49:19 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-02-27 23:49:19 +0000
commitfa346a23ba66dd6c2347181a4d5fbb4b7a687047 (patch)
tree4d255cf3876225f655e6e381587d232f229357ff /net-misc/bcm4400/bcm4400-3.0.14.ebuild
parenthe made me add mirror://gentoo (diff)
downloadgentoo-2-fa346a23ba66dd6c2347181a4d5fbb4b7a687047.tar.gz
gentoo-2-fa346a23ba66dd6c2347181a4d5fbb4b7a687047.tar.bz2
gentoo-2-fa346a23ba66dd6c2347181a4d5fbb4b7a687047.zip
Version bump thanks to Philip Kovacs <kovacsp3@comcast.net> in bug 124304
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'net-misc/bcm4400/bcm4400-3.0.14.ebuild')
-rw-r--r--net-misc/bcm4400/bcm4400-3.0.14.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-misc/bcm4400/bcm4400-3.0.14.ebuild b/net-misc/bcm4400/bcm4400-3.0.14.ebuild
new file mode 100644
index 000000000000..d7144022f299
--- /dev/null
+++ b/net-misc/bcm4400/bcm4400-3.0.14.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bcm4400/bcm4400-3.0.14.ebuild,v 1.1 2006/02/27 23:49:19 genstef Exp $
+
+inherit linux-mod
+
+SRC_URI="http://www.broadcom.com/docs/driver_download/440x/linux-${PV}.zip"
+DESCRIPTION="Driver for the bcm4400 10/100 network card (in the form of kernel modules)."
+HOMEPAGE="http://www.broadcom.com/drivers"
+LICENSE="GPL-2"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+DEPEND="app-arch/unzip"
+S=${WORKDIR}/${P}/src
+
+MODULE_NAMES="bcm4400(net:)"
+BUILD_TARGETS="default"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="BCM_KVER=${KV_MAJOR}.${KV_MINOR} LINUX=${KV_DIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}
+ tar xzpf ${P}.tar.gz
+ convert_to_m ${S}/Makefile
+}
+
+src_install() {
+ linux-mod_src_install
+ doman bcm4400.4
+ dodoc ../DISTRIB.TXT ../README.TXT ../RELEASE.TXT
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ einfo "For more detailed information about this driver:"
+ einfo "man 4 bcm5700"
+}