summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-07-06 15:13:56 +0000
committerJustin Lecher <jlec@gentoo.org>2012-07-06 15:13:56 +0000
commit65c0a5d6721a866397baf26b9755def248ac1a86 (patch)
treee39b111177a20ab2f01f33b6d4477c792bb6b81d /net-misc/axel
parentStable for amd64, wrt bug #425050 (diff)
downloadgentoo-2-65c0a5d6721a866397baf26b9755def248ac1a86.tar.gz
gentoo-2-65c0a5d6721a866397baf26b9755def248ac1a86.tar.bz2
gentoo-2-65c0a5d6721a866397baf26b9755def248ac1a86.zip
net-misc/axel: Move to EAPI=4, fix buildsystem, #424822, fix potential buffer overflow
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/axel')
-rw-r--r--net-misc/axel/ChangeLog10
-rw-r--r--net-misc/axel/axel-2.4-r2.ebuild48
-rw-r--r--net-misc/axel/files/axel-2.4-bffr-overflow.patch16
-rw-r--r--net-misc/axel/files/axel-2.4-buildsystem.patch23
4 files changed, 95 insertions, 2 deletions
diff --git a/net-misc/axel/ChangeLog b/net-misc/axel/ChangeLog
index 1036f5721bdc..cfe36dea4b1d 100644
--- a/net-misc/axel/ChangeLog
+++ b/net-misc/axel/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/axel
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/axel/ChangeLog,v 1.61 2011/11/24 14:13:49 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/axel/ChangeLog,v 1.62 2012/07/06 15:13:56 jlec Exp $
+
+*axel-2.4-r2 (06 Jul 2012)
+
+ 06 Jul 2012; Justin Lecher <jlec@gentoo.org> +axel-2.4-r2.ebuild,
+ +files/axel-2.4-bffr-overflow.patch, +files/axel-2.4-buildsystem.patch:
+ Move to EAPI=4, fix buildsystem, #424822, fix potential buffer overflow
24 Nov 2011; Justin Lecher <jlec@gentoo.org> metadata.xml:
Take the package
diff --git a/net-misc/axel/axel-2.4-r2.ebuild b/net-misc/axel/axel-2.4-r2.ebuild
new file mode 100644
index 000000000000..88cc46196ee2
--- /dev/null
+++ b/net-misc/axel/axel-2.4-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/axel/axel-2.4-r2.ebuild,v 1.1 2012/07/06 15:13:56 jlec Exp $
+
+EAPI=4
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DOWNLOAD_ID=3016
+
+DESCRIPTION="Light Unix download accelerator"
+HOMEPAGE="http://axel.alioth.debian.org/"
+SRC_URI="http://alioth.debian.org/frs/download.php/${DOWNLOAD_ID}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc64-solaris"
+IUSE="debug nls"
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND="nls? ( virtual/libintl )"
+
+DOCS=( API CHANGES CREDITS README axelrc.example )
+
+src_prepare() {
+ append-lfs-flags
+ epatch \
+ "${FILESDIR}"/${P}-buildsystem.patch \
+ "${FILESDIR}"/${P}-bffr-overflow.patch
+ tc-export CC
+}
+
+src_configure() {
+ local myconf=""
+
+ use debug && myconf+=" --debug=1"
+ use nls && myconf+=" --i18n=$(use nls && echo 1 || echo 0)"
+ econf \
+ --strip=0 \
+ ${myconf}
+}
+
+pkg_postinst() {
+ einfo 'To use axel with portage, try these settings in your make.conf'
+ einfo
+ einfo ' FETCHCOMMAND='\''axel -a -o "\${DISTDIR}/\${FILE}.axel" "\${URI}" && mv "\${DISTDIR}/\${FILE}.axel" "\${DISTDIR}/\${FILE}"'\'
+ einfo ' RESUMECOMMAND="${FETCHCOMMAND}"'
+}
diff --git a/net-misc/axel/files/axel-2.4-bffr-overflow.patch b/net-misc/axel/files/axel-2.4-bffr-overflow.patch
new file mode 100644
index 000000000000..24fae8ce19c0
--- /dev/null
+++ b/net-misc/axel/files/axel-2.4-bffr-overflow.patch
@@ -0,0 +1,16 @@
+ http.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/http.c b/http.c
+index 5d64e9b..db91701 100644
+--- a/http.c
++++ b/http.c
+@@ -164,7 +164,7 @@ int http_exec( http_t *conn )
+ {
+ i ++;
+ }
+- strncat( conn->headers, s, MAX_QUERY );
++ strncat( conn->headers, s, MAX_QUERY - 1);
+ }
+
+ #ifdef DEBUG
diff --git a/net-misc/axel/files/axel-2.4-buildsystem.patch b/net-misc/axel/files/axel-2.4-buildsystem.patch
new file mode 100644
index 000000000000..a1571f0fc576
--- /dev/null
+++ b/net-misc/axel/files/axel-2.4-buildsystem.patch
@@ -0,0 +1,23 @@
+ Makefile | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 1c3863a..b43fcff 100644
+--- a/Makefile
++++ b/Makefile
+@@ -51,13 +51,13 @@ uninstall-etc:
+ ### MAIN PROGRAM
+
+ $(OUTFILE): axel.o conf.o conn.o ftp.o http.o search.o tcp.o text.o
+- $(CC) *.o -o $(OUTFILE) $(LFLAGS)
++ $(CC) $(LDFLAGS) *.o -o $(OUTFILE) $(LFLAGS)
+ ifndef DEBUG
+ -$(STRIP) $(OUTFILE)
+ endif
+
+ .c.o:
+- $(CC) -c $*.c -o $*.o -Wall $(CFLAGS)
++ $(CC) $(CPPFLAGS) -c $*.c -o $*.o -Wall $(CFLAGS)
+
+ install-bin:
+ mkdir -p $(DESTDIR)$(BINDIR)/