summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2004-03-12 02:01:30 +0000
committerStefan Knoblich <stkn@gentoo.org>2004-03-12 02:01:30 +0000
commitf613a3d9141950516abfaec0dc28d9507f492f2f (patch)
tree11cbf71833c19dca080b26266005339ad49d338d /net-misc/asterisk-oh323
parentfixes bug #44125 and (hopefully) a lot of other build problems (Manifest reco... (diff)
downloadgentoo-2-f613a3d9141950516abfaec0dc28d9507f492f2f.tar.gz
gentoo-2-f613a3d9141950516abfaec0dc28d9507f492f2f.tar.bz2
gentoo-2-f613a3d9141950516abfaec0dc28d9507f492f2f.zip
version bump + openh323-1.13.* fix, older ebuild blocks openh323-1.13.* now
Diffstat (limited to 'net-misc/asterisk-oh323')
-rw-r--r--net-misc/asterisk-oh323/ChangeLog10
-rw-r--r--net-misc/asterisk-oh323/asterisk-oh323-0.5.10.ebuild35
-rw-r--r--net-misc/asterisk-oh323/asterisk-oh323-0.5.9.ebuild7
-rw-r--r--net-misc/asterisk-oh323/files/asterisk-oh323-0.5.10-Makefile.patch52
-rw-r--r--net-misc/asterisk-oh323/files/asterisk-oh323-0.5.10-asterisk-driver-Makefile.patch10
-rw-r--r--net-misc/asterisk-oh323/files/digest-asterisk-oh323-0.5.101
6 files changed, 111 insertions, 4 deletions
diff --git a/net-misc/asterisk-oh323/ChangeLog b/net-misc/asterisk-oh323/ChangeLog
index 69105a8f3f2a..a78d53699c7c 100644
--- a/net-misc/asterisk-oh323/ChangeLog
+++ b/net-misc/asterisk-oh323/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/asterisk-oh323
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-oh323/ChangeLog,v 1.1 2004/02/18 23:22:06 stkn Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-oh323/ChangeLog,v 1.2 2004/03/12 02:01:30 stkn Exp $
+
+*asterisk-oh323-0.5.10 (12 Mar 2004)
+
+ 12 Mar 2004; Stefan Knoblich <stkn@gentoo.org> asterisk-oh323-0.5.10.ebuild,
+ asterisk-oh323-0.5.9.ebuild, files/asterisk-oh323-0.5.10-Makefile.patch,
+ files/asterisk-oh323-0.5.10-asterisk-driver-Makefile.patch:
+ version bump and some fixes for the new openh323 release.
+ old blocks now with new openh323 installed (won't compile...)
*asterisk-oh323-0.5.9 (19 Feb 2004)
diff --git a/net-misc/asterisk-oh323/asterisk-oh323-0.5.10.ebuild b/net-misc/asterisk-oh323/asterisk-oh323-0.5.10.ebuild
new file mode 100644
index 000000000000..ec6da59f08f6
--- /dev/null
+++ b/net-misc/asterisk-oh323/asterisk-oh323-0.5.10.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-oh323/asterisk-oh323-0.5.10.ebuild,v 1.1 2004/03/12 02:01:30 stkn Exp $
+
+inherit eutils
+
+DESCRIPTION="H.323 Support for the Asterisk soft PBX"
+HOMEPAGE="http://www.inaccessnetworks.com/projects/asterisk-oh323/"
+SRC_URI="http://www.inaccessnetworks.com/projects/asterisk-oh323/download/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=dev-libs/pwlib-1.5.2-r2
+ >=net-libs/openh323-1.12.2-r2
+ >=net-misc/asterisk-0.7.2"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-Makefile.patch
+ epatch ${FILESDIR}/${P}-asterisk-driver-Makefile.patch
+}
+
+src_compile() {
+ # NOTRACE=1 is required (atm)
+ # plugin won't work if this isn't set!
+ # emake breaks version detection for pwlib and openh323
+ make NOTRACE=1 || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}
diff --git a/net-misc/asterisk-oh323/asterisk-oh323-0.5.9.ebuild b/net-misc/asterisk-oh323/asterisk-oh323-0.5.9.ebuild
index 57eceb15d86b..748cfee5f862 100644
--- a/net-misc/asterisk-oh323/asterisk-oh323-0.5.9.ebuild
+++ b/net-misc/asterisk-oh323/asterisk-oh323-0.5.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-oh323/asterisk-oh323-0.5.9.ebuild,v 1.1 2004/02/18 23:22:06 stkn Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-oh323/asterisk-oh323-0.5.9.ebuild,v 1.2 2004/03/12 02:01:30 stkn Exp $
IUSE=""
@@ -16,7 +16,8 @@ KEYWORDS="~x86"
DEPEND=">=dev-libs/pwlib-1.5.2-r2
>=net-libs/openh323-1.12.2-r2
- >=net-misc/asterisk-0.5.0"
+ >=net-misc/asterisk-0.5.0
+ !>=net-libs/openh323-1.13.0"
src_unpack() {
unpack ${A}
@@ -29,7 +30,7 @@ src_unpack() {
src_compile() {
# NOTRACE=1 is required (atm)
# plugin won't work if this isn't set!
- emake NOTRACE=1 || die
+ make NOTRACE=1 || die
}
src_install() {
diff --git a/net-misc/asterisk-oh323/files/asterisk-oh323-0.5.10-Makefile.patch b/net-misc/asterisk-oh323/files/asterisk-oh323-0.5.10-Makefile.patch
new file mode 100644
index 000000000000..7d96dc8ffd56
--- /dev/null
+++ b/net-misc/asterisk-oh323/files/asterisk-oh323-0.5.10-Makefile.patch
@@ -0,0 +1,52 @@
+--- Makefile.orig 2004-02-18 22:09:49.000000000 +0100
++++ Makefile 2004-02-18 22:11:11.000000000 +0100
+@@ -44,13 +44,13 @@
+ # Set PWLIBDIR variable to the directory containing the sources of
+ # PWlib library.
+ #
+-PWLIBDIR=/root/src/oh323/pwlib
++PWLIBDIR=/usr/share/pwlib
+
+ #
+ # Set OPENH323LIBDIR variable to the directory containing the sources of
+ # OpenH323 library.
+ #
+-OPENH323DIR=/root/src/oh323/openh323
++OPENH323DIR=/usr/share/openh323
+
+ #
+ # Set ASTERISKSRCDIR variable to the directory where ASTERISK's source files
+@@ -76,7 +76,7 @@
+ # LD_LIBRARY_PATH shell variable, or to the /etc/ld.so.conf
+ # file and run "ldconfig".
+ #
+-OH323WRAPLIBDIR=$(DESTDIR)/usr/local/lib
++OH323WRAPLIBDIR=$(DESTDIR)/usr/lib
+
+ #
+ # Set SSLINCDIR variable to the directory where ssl/crypto
+@@ -158,7 +158,7 @@
+ OPENH323USERFLAGS += P_PTHREADS=1
+ endif
+ OPENH323FLAGS=$(shell make $(OPENH323USERFLAGS) --no-print-directory -s \
+- -C $(OPENH323DIR) \
++ -C $(OPENH323DIR) -f openh323u.mak \
+ PWLIBDIR=$(PWLIBDIR) OPENH323DIR=$(OPENH323DIR) ccflags)
+ CPPFLAGS=$(OPENH323FLAGS) -Wall
+ ASTERISKINCLUDE=-I$(ASTERISKSRCDIR)/include -I../wrapper
+--- Makefile.orig 2004-03-11 20:07:41.000000000 +0100
++++ Makefile 2004-03-11 20:08:21.000000000 +0100
+@@ -133,10 +133,10 @@
+ TOUCH=touch
+ AR=ar
+ OH323WRAPINCLUDE=-I$(SSLINCDIR) \
+- -I$(PWLIBDIR)/include/ptlib/unix \
+ -I$(PWLIBDIR)/include \
+- -I$(OPENH323DIR)/include \
+- -I$(OPENH323DIR)/include/openh323 \
++ -I$(PWLIBDIR)/include/ptlib/unix \
++ -I/usr/include/openh323 \
++ -I/usr/include \
+ -I../asterisk-driver
+ OPENH323USERFLAGS=
+ ifdef NOVIDEO
diff --git a/net-misc/asterisk-oh323/files/asterisk-oh323-0.5.10-asterisk-driver-Makefile.patch b/net-misc/asterisk-oh323/files/asterisk-oh323-0.5.10-asterisk-driver-Makefile.patch
new file mode 100644
index 000000000000..7f874ed4dab7
--- /dev/null
+++ b/net-misc/asterisk-oh323/files/asterisk-oh323-0.5.10-asterisk-driver-Makefile.patch
@@ -0,0 +1,10 @@
+--- asterisk-driver/Makefile.orig 2003-10-07 14:31:45.000000000 +0200
++++ asterisk-driver/Makefile 2004-02-05 15:51:25.884616624 +0200
+@@ -29,6 +29,7 @@
+ #################################################################################
+
+ TARGET=chan_oh323.so
++OPENH323DIR=/usr
+
+ ifndef SKIP_SUFFIX
+ ifeq ($(WRAPSTAT),1)
diff --git a/net-misc/asterisk-oh323/files/digest-asterisk-oh323-0.5.10 b/net-misc/asterisk-oh323/files/digest-asterisk-oh323-0.5.10
new file mode 100644
index 000000000000..d455198331b4
--- /dev/null
+++ b/net-misc/asterisk-oh323/files/digest-asterisk-oh323-0.5.10
@@ -0,0 +1 @@
+MD5 bd878d8348e804d440588cbe235b091e asterisk-oh323-0.5.10.tar.gz 74857