summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2005-09-29 23:52:02 +0000
committerStefan Knoblich <stkn@gentoo.org>2005-09-29 23:52:02 +0000
commit2c508c9518afe1f492bde35465914bfa9cd14c1c (patch)
tree944410bec470c8e9a92d63c89f42101cd2651fd7 /net-misc/asterisk-app_ldap/asterisk-app_ldap-1.0_rc1.ebuild
parentRemoved old ebuilds. (diff)
downloadgentoo-2-2c508c9518afe1f492bde35465914bfa9cd14c1c.tar.gz
gentoo-2-2c508c9518afe1f492bde35465914bfa9cd14c1c.tar.bz2
gentoo-2-2c508c9518afe1f492bde35465914bfa9cd14c1c.zip
Version bump.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-misc/asterisk-app_ldap/asterisk-app_ldap-1.0_rc1.ebuild')
-rw-r--r--net-misc/asterisk-app_ldap/asterisk-app_ldap-1.0_rc1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-misc/asterisk-app_ldap/asterisk-app_ldap-1.0_rc1.ebuild b/net-misc/asterisk-app_ldap/asterisk-app_ldap-1.0_rc1.ebuild
new file mode 100644
index 000000000000..7c1adb0bbda0
--- /dev/null
+++ b/net-misc/asterisk-app_ldap/asterisk-app_ldap-1.0_rc1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-app_ldap/asterisk-app_ldap-1.0_rc1.ebuild,v 1.1 2005/09/29 23:52:02 stkn Exp $
+
+inherit eutils
+
+MY_PN="app_ldap"
+
+DESCRIPTION="Asterisk application plugin to do lookups in a LDAP directory"
+HOMEPAGE="http://www.mezzo.net/asterisk/"
+SRC_URI="http://www.mezzo.net/asterisk/${MY_PN}-${PV/_/}.tgz"
+
+IUSE=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+# depends on iconv support
+DEPEND="sys-libs/glibc
+ >=net-nds/openldap-2.0.0
+ >=net-misc/asterisk-1.0.7-r1"
+
+S=${WORKDIR}/${MY_PN}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # use asterisk-config...
+ epatch ${FILESDIR}/${MY_PN}-0.9.9-astcfg.diff
+}
+
+src_compile() {
+ emake -j1 clean all || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc CHANGES README ldap.conf.sample
+
+ # fix permissions
+ if [[ -n "$(egetent group asterisk)" ]]; then
+ chown -R root:asterisk ${D}etc/asterisk
+ chmod -R u=rwX,g=rX,o= ${D}etc/asterisk
+ fi
+}