summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-16 21:08:16 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-16 21:08:16 +0000
commit1541cae8c9ee54efa7bf00ea30e17135324ace19 (patch)
tree2ee38cdccce195bb149566ae7482884782c6f00e /net-misc/arpd
parentSlightly updated patch, thanks Kacper Kowalik (Xarthisius) for providing the... (diff)
downloadgentoo-2-1541cae8c9ee54efa7bf00ea30e17135324ace19.tar.gz
gentoo-2-1541cae8c9ee54efa7bf00ea30e17135324ace19.tar.bz2
gentoo-2-1541cae8c9ee54efa7bf00ea30e17135324ace19.zip
Fixed compilation agianst newer libevent, #295746
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/arpd')
-rw-r--r--net-misc/arpd/ChangeLog11
-rw-r--r--net-misc/arpd/arpd-0.2-r1.ebuild42
-rw-r--r--net-misc/arpd/files/arpd-0.2-libevent.patch28
3 files changed, 79 insertions, 2 deletions
diff --git a/net-misc/arpd/ChangeLog b/net-misc/arpd/ChangeLog
index 7f9121dadcdc..fbcc00c63ad9 100644
--- a/net-misc/arpd/ChangeLog
+++ b/net-misc/arpd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/arpd
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/arpd/ChangeLog,v 1.13 2008/11/27 20:47:06 vapier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/arpd/ChangeLog,v 1.14 2010/02/16 21:08:15 jlec Exp $
+
+*arpd-0.2-r1 (16 Feb 2010)
+
+ 16 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org> +arpd-0.2-r1.ebuild,
+ +files/arpd-0.2-libevent.patch:
+ Fix for compilation against new libevent per bug 295746
+ Thanks Kacper Kowalik (Xarthisius) for providing the patch
27 Nov 2008; Mike Frysinger <vapier@gentoo.org> arpd-0.2.ebuild:
Add a blocker on iproute2 #248092 by Diego E. Pettenò.
diff --git a/net-misc/arpd/arpd-0.2-r1.ebuild b/net-misc/arpd/arpd-0.2-r1.ebuild
new file mode 100644
index 000000000000..9f308f3b02ee
--- /dev/null
+++ b/net-misc/arpd/arpd-0.2-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/arpd/arpd-0.2-r1.ebuild,v 1.1 2010/02/16 21:08:15 jlec Exp $
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="ARP server which claims all unassigned addresses (for network monitoring or simulation)"
+HOMEPAGE="http://www.citi.umich.edu/u/provos/honeyd/"
+SRC_URI="http://www.citi.umich.edu/u/provos/honeyd/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/libdnet-1.4
+ >=dev-libs/libevent-0.6
+ net-libs/libpcap
+ !sys-apps/iproute2"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/arpd.c.patch
+ epatch "${FILESDIR}"/${P}-libevent.patch
+
+ sed -i \
+ -e 's|$withval/lib/libevent.a; then||' \
+ -e 's|if test -f $withval/include/event.h -a -f|if test -f $withval/include/event.h -a -f $withval/lib/libevent.a; then|' \
+ configure || die "sed failed"
+}
+
+src_configure() {
+ econf --with-libdnet="${EPREFIX}"/usr --with-libevent="${EPREFIX}"/usr
+}
+
+src_install() {
+ dosbin arpd || die
+ doman arpd.8 || die
+}
diff --git a/net-misc/arpd/files/arpd-0.2-libevent.patch b/net-misc/arpd/files/arpd-0.2-libevent.patch
new file mode 100644
index 000000000000..2d5998f8c8d3
--- /dev/null
+++ b/net-misc/arpd/files/arpd-0.2-libevent.patch
@@ -0,0 +1,28 @@
+--- arpd.orig/arpd.c 2010-02-03 20:03:07.098748175 +0100
++++ arpd/arpd.c 2010-02-03 20:06:24.469749941 +0100
+@@ -445,9 +445,6 @@
+ void
+ terminate_handler(int sig)
+ {
+- extern int event_gotsig;
+-
+- event_gotsig = 1;
+ arpd_sig = sig;
+ }
+
+@@ -464,7 +461,6 @@
+ main(int argc, char *argv[])
+ {
+ struct event recv_ev;
+- extern int (*event_sigcb)(void);
+ char *dev;
+ int c, debug;
+ FILE *fp;
+@@ -524,7 +520,6 @@
+ perror("signal");
+ return (-1);
+ }
+- event_sigcb = arpd_signal;
+
+ event_dispatch();
+