summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuy Martin <gmsoft@gentoo.org>2005-03-27 17:34:09 +0000
committerGuy Martin <gmsoft@gentoo.org>2005-03-27 17:34:09 +0000
commit7287bdd58799f11b626727db05e5e55f2438bc79 (patch)
tree39454c3628c182a0ddc38e0cdc7e8e2ea771110f /net-misc/aiccu/aiccu-2005.01.31.ebuild
parentAdded php support (diff)
downloadgentoo-2-7287bdd58799f11b626727db05e5e55f2438bc79.tar.gz
gentoo-2-7287bdd58799f11b626727db05e5e55f2438bc79.tar.bz2
gentoo-2-7287bdd58799f11b626727db05e5e55f2438bc79.zip
Initital commit of the aiccu ebuild (close #64409).
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-misc/aiccu/aiccu-2005.01.31.ebuild')
-rw-r--r--net-misc/aiccu/aiccu-2005.01.31.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-misc/aiccu/aiccu-2005.01.31.ebuild b/net-misc/aiccu/aiccu-2005.01.31.ebuild
new file mode 100644
index 000000000000..5ca20c75e2a9
--- /dev/null
+++ b/net-misc/aiccu/aiccu-2005.01.31.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/aiccu/aiccu-2005.01.31.ebuild,v 1.1 2005/03/27 17:34:09 gmsoft Exp $
+
+
+DESCRIPTION="AICCU Client to configure an IPv6 tunnel to SixXS."
+HOMEPAGE="http://www.sixxs.net/"
+SRC_URI="http://www.sixxs.net/archive/sixxs/aiccu/unix/aiccu_${PV}.tar.gz"
+
+LICENSE="AICCU"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=""
+S=${WORKDIR}/aiccu
+
+
+src_compile() {
+ cd ${S}
+ export RPM_OPT_FLAGS=${CFLAGS}
+ make || die "Build Failed"
+}
+
+src_install() {
+ dosbin unix-console/aiccu
+ insopts -m 600
+ insinto /etc
+ doins doc/aiccu.conf
+ dodoc doc/{HOWTO,LICENSE,README,changelog}
+ exeinto /etc/init.d
+ newexe doc/aiccu.init.gentoo aiccu
+
+
+}
+
+pkg_postinst() {
+ einfo "The aiccu ebuild installs an init script named 'aiccu'"
+ einfo "To add support for a SixXS connection at startup, do"
+ einfo "edit your /etc/aiccu.conf and do"
+ einfo "# rc-update add aiccu default"
+
+}
+