summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-01-26 10:39:28 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-01-26 10:39:28 +0000
commit3715e1114a241d33e8ce1cf5f164eaa02ed40cc3 (patch)
treeb46b60b71b583dc51ecb1a9573e1c16de027d62e /net-misc/LinNeighborhood
parentbonnie 1.02a ebuild contributed by William McArthur <leknor@leknor.com> (diff)
downloadgentoo-2-3715e1114a241d33e8ce1cf5f164eaa02ed40cc3.tar.gz
gentoo-2-3715e1114a241d33e8ce1cf5f164eaa02ed40cc3.tar.bz2
gentoo-2-3715e1114a241d33e8ce1cf5f164eaa02ed40cc3.zip
LinNeighborhood 0.6.4: ebuild submitted by joao@schim.net (Joao Schim)
Diffstat (limited to 'net-misc/LinNeighborhood')
-rw-r--r--net-misc/LinNeighborhood/LinNeighborhood-0.6.4.ebuild43
-rw-r--r--net-misc/LinNeighborhood/files/digest-LinNeighborhood-0.6.41
2 files changed, 44 insertions, 0 deletions
diff --git a/net-misc/LinNeighborhood/LinNeighborhood-0.6.4.ebuild b/net-misc/LinNeighborhood/LinNeighborhood-0.6.4.ebuild
new file mode 100644
index 000000000000..a0f40b4deb72
--- /dev/null
+++ b/net-misc/LinNeighborhood/LinNeighborhood-0.6.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Joao Schim <joao@schim.net>
+# $HEADER $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="LinNeighborhood is a easy to use frontend to samba/NETBios."
+SRC_URI="http://www.bnro.de/~schmidjo/download/${P}.tar.gz"
+HOMEPAGE="http://www.bnro.de/~schmidjo/index.html"
+
+DEPEND=" >=x11-libs/gtk+-1.2 net-fs/samba
+ nls? ( sys-devel/gettext ) "
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+
+ local mylibs myopts
+
+ use nls || myopts="--disable-nls"
+
+ if [ "`use python`" ]
+ then
+ mylibs=`/usr/bin/python-config`
+
+ cp configure configure.orig
+ sed -e 's:PY_LIBS=".*":PY_LIBS="'"$mylibs"'":' configure.orig > configure || die
+ fi
+
+ ./configure --prefix=/usr \
+ --host=${CHOST} \
+ --enable-ipv6 \
+ ${myopts} || die
+
+ emake || die
+}
+
+src_install() {
+
+ make prefix=${D}/usr install || die
+
+ dodoc README AUTHORS TODO THANKS BUGS NEW COPYING ChangeLog
+}
diff --git a/net-misc/LinNeighborhood/files/digest-LinNeighborhood-0.6.4 b/net-misc/LinNeighborhood/files/digest-LinNeighborhood-0.6.4
new file mode 100644
index 000000000000..1cef679ecb13
--- /dev/null
+++ b/net-misc/LinNeighborhood/files/digest-LinNeighborhood-0.6.4
@@ -0,0 +1 @@
+MD5 6a3379ec90ed261d048c1e89376d3368 LinNeighborhood-0.6.4.tar.gz 389120