summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2007-11-08 18:12:08 +0000
committerAndrej Kacian <ticho@gentoo.org>2007-11-08 18:12:08 +0000
commitfbfcc48aa480a7c489d5bc55e9670f6d07efac71 (patch)
tree280585c25763fb03d5ee34c5f861b07c71d3b46f /net-mail
parentFix repoman warnings also for old ebuild. (diff)
downloadgentoo-2-fbfcc48aa480a7c489d5bc55e9670f6d07efac71.tar.gz
gentoo-2-fbfcc48aa480a7c489d5bc55e9670f6d07efac71.tar.bz2
gentoo-2-fbfcc48aa480a7c489d5bc55e9670f6d07efac71.zip
Version bump.
(Portage version: 2.1.3.15)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/getmail/ChangeLog7
-rw-r--r--net-mail/getmail/files/digest-getmail-4.7.73
-rw-r--r--net-mail/getmail/getmail-4.7.7.ebuild56
3 files changed, 65 insertions, 1 deletions
diff --git a/net-mail/getmail/ChangeLog b/net-mail/getmail/ChangeLog
index 2d2983645135..08a4304935f3 100644
--- a/net-mail/getmail/ChangeLog
+++ b/net-mail/getmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/getmail
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.151 2007/08/09 21:57:37 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.152 2007/11/08 18:12:07 ticho Exp $
+
+*getmail-4.7.7 (08 Nov 2007)
+
+ 08 Nov 2007; Andrej Kacian <ticho@gentoo.org> +getmail-4.7.7.ebuild:
+ Version bump.
*getmail-4.7.6 (09 Aug 2007)
diff --git a/net-mail/getmail/files/digest-getmail-4.7.7 b/net-mail/getmail/files/digest-getmail-4.7.7
new file mode 100644
index 000000000000..7644324794c0
--- /dev/null
+++ b/net-mail/getmail/files/digest-getmail-4.7.7
@@ -0,0 +1,3 @@
+MD5 d6252e8ebe89fb17baaeb9acba707e39 getmail-4.7.7.tar.gz 149137
+RMD160 6217b9a5bfb1c5567544891a0fde685db3964373 getmail-4.7.7.tar.gz 149137
+SHA256 216566c3ad0c62b92c32a42ab3b7fbca82681b7ed07818ee578b284aa7285947 getmail-4.7.7.tar.gz 149137
diff --git a/net-mail/getmail/getmail-4.7.7.ebuild b/net-mail/getmail/getmail-4.7.7.ebuild
new file mode 100644
index 000000000000..33b0b2b9d812
--- /dev/null
+++ b/net-mail/getmail/getmail-4.7.7.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/getmail-4.7.7.ebuild,v 1.1 2007/11/08 18:12:07 ticho Exp $
+
+inherit distutils
+
+IUSE=""
+DESCRIPTION="A POP3 mail retriever with reliable Maildir and mbox delivery"
+HOMEPAGE="http://pyropus.ca/software/getmail/"
+SRC_URI="http://pyropus.ca/software/getmail/old-versions/${P}.tar.gz"
+
+SLOT="4"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-lang/python-2.3.3"
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ distutils_src_install
+
+ if has_version "=net-mail/getmail-3*" ; then
+ mv ${D}/usr/bin/getmail ${D}/usr/bin/getmail4
+ mv ${D}/usr/bin/getmail_maildir ${D}/usr/bin/getmail_maildir4
+ mv ${D}/usr/bin/getmail_mbox ${D}/usr/bin/getmail_mbox4
+ fi
+
+ # handle docs the gentoo way
+ if [ ${P} != ${PF} ]; then
+ mv ${D}/usr/share/doc/${P} ${D}/usr/share/doc/${PF}
+ fi
+
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/share/doc/${PF}/*.html ${D}/usr/share/doc/${PF}/*.css ${D}/usr/share/doc/${PF}/html
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages/getmailcore
+
+ if has_version "=net-mail/getmail-3*" ; then
+ echo
+ ewarn "An already installed instance of getmail v3 was detected. In order to"
+ ewarn "co-exist with it the three main scripts of getmail v4 were renamed to"
+ ewarn "getmail4, getmail_maildir4, getmail_mbox4."
+ echo
+ fi
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}