summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-12-16 19:38:38 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-12-16 19:38:38 +0000
commitfacc43a0576440852b25cd8855871288c31571eb (patch)
tree6391e91a89b4db85c4534f078ea76bc257b2f7dc /net-mail
parentStable for HPPA (bug #296825). (diff)
downloadgentoo-2-facc43a0576440852b25cd8855871288c31571eb.tar.gz
gentoo-2-facc43a0576440852b25cd8855871288c31571eb.tar.bz2
gentoo-2-facc43a0576440852b25cd8855871288c31571eb.zip
Critical bugfix to 1.2.16 that can cause mail loss. Upstream is releasing a 1.2.17 with it soon, but we need it already.
(Portage version: 2.2_rc58/cvs/Linux x86_64)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mlmmj/ChangeLog11
-rw-r--r--net-mail/mlmmj/files/mlmmj-1.2.16-requeue-unlink-fix.patch29
-rw-r--r--net-mail/mlmmj/mlmmj-1.2.16-r1.ebuild63
3 files changed, 101 insertions, 2 deletions
diff --git a/net-mail/mlmmj/ChangeLog b/net-mail/mlmmj/ChangeLog
index fb9b24173501..e9297bedd4f2 100644
--- a/net-mail/mlmmj/ChangeLog
+++ b/net-mail/mlmmj/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/mlmmj
-# Copyright 2004-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mlmmj/ChangeLog,v 1.29 2009/03/18 07:08:18 josejx Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mlmmj/ChangeLog,v 1.30 2009/12/16 19:38:38 robbat2 Exp $
+
+*mlmmj-1.2.16-r1 (16 Dec 2009)
+
+ 16 Dec 2009; Robin H. Johnson <robbat2@gentoo.org>
+ +mlmmj-1.2.16-r1.ebuild, +files/mlmmj-1.2.16-requeue-unlink-fix.patch:
+ Critical bugfix to 1.2.16 that can cause mail loss. Upstream is releasing
+ a 1.2.17 with it soon, but we need it already.
18 Mar 2009; Joseph Jezak <josejx@gentoo.org> mlmmj-1.2.15-r1.ebuild:
Marked ppc stable for bug #249615.
diff --git a/net-mail/mlmmj/files/mlmmj-1.2.16-requeue-unlink-fix.patch b/net-mail/mlmmj/files/mlmmj-1.2.16-requeue-unlink-fix.patch
new file mode 100644
index 000000000000..00664e3c09e4
--- /dev/null
+++ b/net-mail/mlmmj/files/mlmmj-1.2.16-requeue-unlink-fix.patch
@@ -0,0 +1,29 @@
+If the maintd visited more than one mail in the /requeue/ directory, and the
+FIRST one set the fromrequeuedir flag to unlink the mail file, the flag was NOT
+cleared and caused mail in the real archive to be erronously removed.
+
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+
+diff -Nuar --exclude mlmmj-make-ml.sh mlmmj-1.2.16.orig/src/mlmmj-maintd.c mlmmj-1.2.16/src/mlmmj-maintd.c
+--- mlmmj-1.2.16.orig/src/mlmmj-maintd.c 2008-10-31 14:20:51.000000000 +0000
++++ mlmmj-1.2.16/src/mlmmj-maintd.c 2009-12-16 02:11:16.848146214 +0000
+@@ -373,7 +373,7 @@
+ struct stat st;
+ pid_t childpid, pid;
+ time_t t;
+- int status, fromrequeuedir = 0;
++ int status, fromrequeuedir;
+
+ if(chdir(dirname) < 0) {
+ log_error(LOG_ARGS, "Could not chdir(%s)", dirname);
+@@ -408,6 +408,10 @@
+
+ archivefilename = concatstr(3, listdir, "/archive/",
+ dp->d_name);
++
++ /* Explicitly initialize for each mail we examine */
++ fromrequeuedir = 0;
++
+ if(stat(archivefilename, &st) < 0) {
+ /* Might be it's just not moved to the archive
+ * yet because it's still getting sent, so just
diff --git a/net-mail/mlmmj/mlmmj-1.2.16-r1.ebuild b/net-mail/mlmmj/mlmmj-1.2.16-r1.ebuild
new file mode 100644
index 000000000000..2579247932ad
--- /dev/null
+++ b/net-mail/mlmmj/mlmmj-1.2.16-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mlmmj/mlmmj-1.2.16-r1.ebuild,v 1.1 2009/12/16 19:38:38 robbat2 Exp $
+
+inherit eutils
+
+MY_PV="${PV/_rc/-RC}"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="Mailing list managing made joyful"
+HOMEPAGE="http://mlmmj.mmj.dk/"
+SRC_URI="http://mlmmj.mmj.dk/files/${MY_P}.tar.bz2"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+DEPEND="virtual/mta"
+#RDEPEND=""
+S="${WORKDIR}/${MY_P}"
+SHAREDIR="/usr/share/mlmmj"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${PN}-1.2.16-requeue-unlink-fix.patch
+ cd "${S}"
+ for i in "${S}" "${S}"/contrib/recievestrip ; do
+ pushd "${i}"
+ # Ignore errors
+ emake -j1 distclean 2>/dev/null 1>/dev/null
+ popd
+ done
+}
+
+src_compile() {
+ econf
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ dodir ${SHAREDIR}
+ dodir ${SHAREDIR}/texts
+ insinto ${SHAREDIR}/texts
+ doins listtexts/*
+
+ dodoc AUTHORS ChangeLog FAQ README
+ dodoc TODO TUNABLES UPGRADE VERSION README.access
+ dodoc README.sendmail README.exim4 README.security
+
+ insinto /usr/share/mlmmj
+ cd "${S}"/contrib/web
+ doins -r *
+
+ dobin "${S}"/contrib/recievestrip
+}
+
+pkg_postinst() {
+ elog "mlmmj comes with serveral webinterfaces:"
+ elog "- One for user subscribing/unsubscribing"
+ elog "- One for admin tasks"
+ elog "both available in a php and perl module."
+ elog "For more info have a look in /usr/share/mlmmj"
+}