summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2012-07-13 14:02:22 +0000
committerEray Aslan <eras@gentoo.org>2012-07-13 14:02:22 +0000
commite92ce01e54f4ca848b5c2cbcaf64b42e39ed4f43 (patch)
treea98c48807b75e5460808889940a8edc89b4dbe43 /net-mail
parentMask net-mail/dovecot-2.1.8-r1 which includes an experimental patch for (diff)
downloadgentoo-2-e92ce01e54f4ca848b5c2cbcaf64b42e39ed4f43.tar.gz
gentoo-2-e92ce01e54f4ca848b5c2cbcaf64b42e39ed4f43.tar.bz2
gentoo-2-e92ce01e54f4ca848b5c2cbcaf64b42e39ed4f43.zip
Include experimental patch from upstream for linking with gold - masked for now
(Portage version: 2.1.11.5/cvs/Linux x86_64)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/dovecot/ChangeLog9
-rw-r--r--net-mail/dovecot/dovecot-2.1.8-r1.ebuild279
-rw-r--r--net-mail/dovecot/files/dovecot-2.1.8_managesieve_gold.patch39
3 files changed, 326 insertions, 1 deletions
diff --git a/net-mail/dovecot/ChangeLog b/net-mail/dovecot/ChangeLog
index 4461328d32e0..0601fc6dabd8 100644
--- a/net-mail/dovecot/ChangeLog
+++ b/net-mail/dovecot/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/dovecot
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/ChangeLog,v 1.369 2012/07/07 12:28:07 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/ChangeLog,v 1.370 2012/07/13 14:02:22 eras Exp $
+
+*dovecot-2.1.8-r1 (13 Jul 2012)
+
+ 13 Jul 2012; Eray Aslan <eras@gentoo.org> +dovecot-2.1.8-r1.ebuild,
+ +files/dovecot-2.1.8_managesieve_gold.patch:
+ Include experimental patch from upstream for linking with gold - masked for
+ now
07 Jul 2012; Anthony G. Basile <blueness@gentoo.org> dovecot-2.1.7.ebuild,
dovecot-2.1.8.ebuild:
diff --git a/net-mail/dovecot/dovecot-2.1.8-r1.ebuild b/net-mail/dovecot/dovecot-2.1.8-r1.ebuild
new file mode 100644
index 000000000000..737d83fd4138
--- /dev/null
+++ b/net-mail/dovecot/dovecot-2.1.8-r1.ebuild
@@ -0,0 +1,279 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/dovecot-2.1.8-r1.ebuild,v 1.1 2012/07/13 14:02:22 eras Exp $
+
+EAPI=4
+inherit eutils versionator ssl-cert systemd
+
+MY_P="${P/_/.}"
+major_minor="$( get_version_component_range 1-2 )"
+sieve_version="0.3.1"
+SRC_URI="http://www.dovecot.org/releases/${major_minor}/${MY_P}.tar.gz
+ sieve? (
+ http://www.rename-it.nl/dovecot/${major_minor}/dovecot-${major_minor}-pigeonhole-${sieve_version}.tar.gz
+ )
+ managesieve? (
+ http://www.rename-it.nl/dovecot/${major_minor}/dovecot-${major_minor}-pigeonhole-${sieve_version}.tar.gz
+ ) "
+DESCRIPTION="An IMAP and POP3 server written with security primarily in mind"
+HOMEPAGE="http://www.dovecot.org/"
+
+SLOT="0"
+LICENSE="LGPL-2.1 MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="bzip2 caps cydir sdbox doc ipv6 imapc kerberos ldap lucene +maildir managesieve mbox
+mdbox mysql pam postgres sieve sqlite +ssl static-libs suid vpopmail zlib"
+
+DEPEND="caps? ( sys-libs/libcap )
+ kerberos? ( virtual/krb5 )
+ ldap? ( net-nds/openldap )
+ lucene? ( >=dev-cpp/clucene-2.3 )
+ mysql? ( virtual/mysql )
+ pam? ( virtual/pam )
+ postgres? ( dev-db/postgresql-base !dev-db/postgresql-base[ldap,threads] )
+ sqlite? ( dev-db/sqlite )
+ ssl? ( dev-libs/openssl )
+ vpopmail? ( net-mail/vpopmail )
+ virtual/libiconv"
+
+RDEPEND="${DEPEND}
+ >=net-mail/mailbase-0.00-r8"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ if use managesieve && ! use sieve; then
+ ewarn "managesieve USE flag selected but sieve USE flag unselected"
+ ewarn "sieve USE flag will be turned on"
+ fi
+
+ # Add user and group for login process (same as for fedora/redhat)
+ # default internal user
+ enewgroup dovecot 97
+ enewuser dovecot 97 -1 /dev/null dovecot
+ # add "mail" group for suid'ing. Better security isolation.
+ if use suid; then
+ enewgroup mail
+ fi
+ # default login user
+ enewuser dovenull -1 -1 /dev/null
+}
+
+src_prepare() {
+ cd "${WORKDIR}"/dovecot-2.1-pigeonhole* || die
+ epatch "${FILESDIR}/${P}_managesieve_gold.patch"
+}
+
+src_configure() {
+ local conf=""
+
+ if use postgres || use mysql || use sqlite; then
+ conf="${conf} --with-sql"
+ fi
+
+ local storages=""
+ for storage in cydir sdbox mdbox maildir mbox imapc; do
+ use ${storage} && storages="${storage} ${storages}"
+ done
+ [ "${storages}" ] || storages="maildir"
+
+ # turn valgrind tests off. Bug #340791
+ VALGRIND=no econf \
+ --localstatedir="${EPREFIX}/var" \
+ --with-moduledir="${EPREFIX}/usr/$(get_libdir)/dovecot" \
+ $( use_with bzip2 bzlib ) \
+ $( use_with caps libcap ) \
+ $( use_with kerberos gssapi ) \
+ $( use_with ldap ) \
+ $( use_with lucene ) \
+ --without-stemmer \
+ $( use_with mysql ) \
+ $( use_with pam ) \
+ $( use_with postgres pgsql ) \
+ $( use_with sqlite ) \
+ $( use_with ssl ) \
+ $( use_with vpopmail ) \
+ $( use_with zlib ) \
+ $( use_enable static-libs static ) \
+ --with-storages="${storages}" \
+ --disable-rpath \
+ $(systemd_with_unitdir) \
+ ${conf}
+
+ if use sieve || use managesieve ; then
+ # The sieve plugin needs this file to be build to determine the plugin
+ # directory and the list of libraries to link to.
+ emake dovecot-config
+ cd "../dovecot-${major_minor}-pigeonhole-${sieve_version}" || die "cd failed"
+ econf \
+ $( use_enable static-libs static ) \
+ --localstatedir="${EPREFIX}/var" \
+ --enable-shared \
+ --with-dovecot="../${MY_P}" \
+ $( use_with managesieve )
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+
+ if use sieve || use managesieve ; then
+ cd "../dovecot-${major_minor}-pigeonhole-${sieve_version}" || die "cd failed"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+ fi
+}
+
+src_test() {
+ default_src_test
+ if use sieve || use managesieve ; then
+ cd "../dovecot-${major_minor}-pigeonhole-${sieve_version}" || die "cd failed"
+ default_src_test
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${ED}" install
+
+ # insecure:
+ # use suid && fperms u+s /usr/libexec/dovecot/deliver
+ # better:
+ if use suid;then
+ einfo "Changing perms to allow deliver to be suided"
+ fowners root:mail "${EPREFIX}/usr/libexec/dovecot/dovecot-lda"
+ fperms 4750 "${EPREFIX}/usr/libexec/dovecot/dovecot-lda"
+ fi
+
+ newinitd "${FILESDIR}"/dovecot.init-r3 dovecot
+
+ rm -rf "${ED}"/usr/share/doc/dovecot
+
+ dodoc AUTHORS NEWS README TODO
+ dodoc doc/*.{txt,cnf,xml,sh}
+ docinto example-config
+ dodoc doc/example-config/*.{conf,ext}
+ docinto example-config/conf.d
+ dodoc doc/example-config/conf.d/*.{conf,ext}
+ docinto wiki
+ dodoc doc/wiki/*
+ doman doc/man/*.{1,7}
+
+ # Create the dovecot.conf file from the dovecot-example.conf file that
+ # the dovecot folks nicely left for us....
+ local conf="${ED}/etc/dovecot/dovecot.conf"
+ local confd="${ED}/etc/dovecot/conf.d"
+
+ insinto /etc/dovecot
+ doins doc/example-config/*.{conf,ext}
+ insinto /etc/dovecot/conf.d
+ doins doc/example-config/conf.d/*.{conf,ext}
+ fperms 0600 "${EPREFIX}"/etc/dovecot/dovecot-{ldap,sql}.conf.ext
+ rm -f "${confd}/../README"
+
+ # .maildir is the Gentoo default
+ local mail_location="maildir:~/.maildir"
+ if ! use maildir; then
+ if use mbox; then
+ mail_location="mbox:/var/spool/mail/%u:INDEX=/var/dovecot/%u"
+ keepdir /var/dovecot
+ sed -i -e 's|#mail_privileged_group =|mail_privileged_group = mail|' \
+ "${confd}/10-mail.conf" || die "sed failed"
+ elif use sdbox ; then
+ mail_location="sdbox:~/.sdbox"
+ elif use mdbox ; then
+ mail_location="mdbox:~/.mdbox"
+ fi
+ fi
+ sed -i -e \
+ "s|#mail_location =|mail_location = ${mail_location}|" \
+ "${confd}/10-mail.conf" \
+ || die "failed to update mail location settings in 10-mail.conf"
+
+ # We're using pam files (imap and pop3) provided by mailbase
+ if use pam; then
+ sed -i -e '/driver = pam/,/^[ \t]*}/ s|#args = dovecot|args = "\*"|' \
+ "${confd}/auth-system.conf.ext" \
+ || die "failed to update PAM settings in auth-system.conf.ext"
+ # mailbase does not provide a sieve pam file
+ use managesieve && dosym imap /etc/pam.d/sieve
+ sed -i -e \
+ 's/#!include auth-system.conf.ext/!include auth-system.conf.ext/' \
+ "${confd}/10-auth.conf" \
+ || die "failed to update PAM settings in 10-auth.conf"
+ fi
+
+ # Disable ipv6 if necessary
+ if ! use ipv6; then
+ sed -i -e 's/^#listen = \*, ::/listen = \*/g' "${conf}" \
+ || die "failed to update listen settings in dovecot.conf"
+ fi
+
+ # Update ssl cert locations
+ if use ssl; then
+ sed -i -e 's:^#ssl = yes:ssl = yes:' "${confd}/10-ssl.conf" \
+ || die "ssl conf failed"
+ sed -i -e 's:^ssl_cert =.*:ssl_cert = </etc/ssl/dovecot/server.pem:' \
+ -e 's:^ssl_key =.*:ssl_key = </etc/ssl/dovecot/server.key:' \
+ "${confd}/10-ssl.conf" || die "failed to update SSL settings in 10-ssl.conf"
+ fi
+
+ # Install SQL configuration
+ if use mysql || use postgres; then
+ sed -i -e \
+ 's/#!include auth-sql.conf.ext/!include auth-sql.conf.ext/' \
+ "${confd}/10-auth.conf" || die "failed to update SQL settings in \
+ 10-auth.conf"
+ fi
+
+ # Install LDAP configuration
+ if use ldap; then
+ sed -i -e \
+ 's/#!include auth-ldap.conf.ext/!include auth-ldap.conf.ext/' \
+ "${confd}/10-auth.conf" \
+ || die "failed to update ldap settings in 10-auth.conf"
+ fi
+
+ if use vpopmail; then
+ sed -i -e \
+ 's/#!include auth-vpopmail.conf.ext/!include auth-vpopmail.conf.ext/' \
+ "${confd}/10-auth.conf" \
+ || die "failed to update vpopmail settings in 10-auth.conf"
+ fi
+
+ if use sieve || use managesieve ; then
+ cd "../dovecot-${major_minor}-pigeonhole-${sieve_version}" || die "cd failed"
+ emake DESTDIR="${ED}" install
+ sed -i -e \
+ 's/^[[:space:]]*#mail_plugins = $mail_plugins/mail_plugins = sieve/' "${confd}/15-lda.conf" \
+ || die "failed to update sieve settings in 15-lda.conf"
+ rm -rf "${ED}"/usr/share/doc/dovecot
+ dodoc doc/*.txt
+ docinto example-config/conf.d
+ dodoc doc/example-config/conf.d/*.conf
+ insinto /etc/dovecot/conf.d
+ doins doc/example-config/conf.d/90-sieve.conf
+ use managesieve && doins doc/example-config/conf.d/20-managesieve.conf
+ docinto sieve/rfc
+ dodoc doc/rfc/*.txt
+ docinto sieve/devel
+ dodoc doc/devel/DESIGN
+ doman doc/man/*.{1,7}
+ fi
+
+ use static-libs || find "${ED}"/usr/lib* -name '*.la' -delete
+}
+
+pkg_postinst() {
+ if use ssl; then
+ # Let's not make a new certificate if we already have one
+ if ! [[ -e "${ROOT}"/etc/ssl/dovecot/server.pem && \
+ -e "${ROOT}"/etc/ssl/dovecot/server.key ]]; then
+ einfo "Creating SSL certificate"
+ SSL_ORGANIZATION="${SSL_ORGANIZATION:-Dovecot IMAP Server}"
+ install_cert /etc/ssl/dovecot/server
+ fi
+ fi
+
+ elog "Upgrade notes can be found at:"
+ elog "\thttp://wiki2.dovecot.org/Upgrading"
+}
diff --git a/net-mail/dovecot/files/dovecot-2.1.8_managesieve_gold.patch b/net-mail/dovecot/files/dovecot-2.1.8_managesieve_gold.patch
new file mode 100644
index 000000000000..97d12b5a6a50
--- /dev/null
+++ b/net-mail/dovecot/files/dovecot-2.1.8_managesieve_gold.patch
@@ -0,0 +1,39 @@
+
+# HG changeset patch
+# User Stephan Bosch <stephan@rename-it.nl>
+# Date 1342130270 -7200
+# Node ID 6ceeb642123117ed8377f3b0d7d28171f790e911
+# Parent 602d93069d3a1c93866178308bd4d03f20a15f73
+ManageSieve: fixed segfault bug triggered by CHECKSCRIPT command.
+
+diff -r 602d93069d3a -r 6ceeb6421231 src/lib-sievestorage/sieve-storage-save.c
+--- a/src/lib-sievestorage/sieve-storage-save.c Sat May 26 00:16:35 2012 +0200
++++ b/src/lib-sievestorage/sieve-storage-save.c Thu Jul 12 23:57:50 2012 +0200
+@@ -318,19 +318,20 @@
+ bool sieve_storage_save_will_activate
+ (struct sieve_save_context *ctx)
+ {
+- const char *scriptname;
+- int ret = 0;
++ bool result = FALSE;
+
+- T_BEGIN {
++ if ( ctx->scriptname != NULL ) T_BEGIN {
++ const char *scriptname;
++ int ret;
++
+ ret = sieve_storage_get_active_scriptfile(ctx->storage, &scriptname);
+-
+ if ( ret > 0 ) {
+ /* Is the requested script active? */
+- ret = ( strcmp(ctx->scriptname, scriptname) == 0 ? 1 : 0 );
++ result = ( strcmp(ctx->scriptname, scriptname) == 0 );
+ }
+ } T_END;
+
+- return ret;
++ return result;
+ }
+
+ int sieve_storage_save_commit(struct sieve_save_context **ctx)
+