summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-06-30 15:02:29 +0000
committerTim Harder <radhermit@gentoo.org>2015-06-30 15:02:29 +0000
commitd7baa70faf07daee108129f75c0e522f13aea5b2 (patch)
treeb09c0711e34baf0bcd4322d90b095adbdaa7bc59 /net-mail
parentbump; ebuild submitted via bug #548388 by proxy maintainer (diff)
downloadgentoo-2-d7baa70faf07daee108129f75c0e522f13aea5b2.tar.gz
gentoo-2-d7baa70faf07daee108129f75c0e522f13aea5b2.tar.bz2
gentoo-2-d7baa70faf07daee108129f75c0e522f13aea5b2.zip
Version bump (bug #549632).
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 4F064CA3)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/offlineimap/ChangeLog7
-rw-r--r--net-mail/offlineimap/offlineimap-6.5.7.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/net-mail/offlineimap/ChangeLog b/net-mail/offlineimap/ChangeLog
index 0410a85ce9c7..a496c078c1ac 100644
--- a/net-mail/offlineimap/ChangeLog
+++ b/net-mail/offlineimap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/offlineimap
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/offlineimap/ChangeLog,v 1.102 2015/06/11 14:15:35 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/offlineimap/ChangeLog,v 1.103 2015/06/30 15:02:29 radhermit Exp $
+
+*offlineimap-6.5.7 (30 Jun 2015)
+
+ 30 Jun 2015; Tim Harder <radhermit@gentoo.org> +offlineimap-6.5.7.ebuild:
+ Version bump (bug #549632).
11 Jun 2015; Agostino Sarubbo <ago@gentoo.org> offlineimap-6.5.6.ebuild:
Stable for ppc, wrt bug #535590
diff --git a/net-mail/offlineimap/offlineimap-6.5.7.ebuild b/net-mail/offlineimap/offlineimap-6.5.7.ebuild
new file mode 100644
index 000000000000..46c39eaf37a7
--- /dev/null
+++ b/net-mail/offlineimap/offlineimap-6.5.7.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/offlineimap/offlineimap-6.5.7.ebuild,v 1.1 2015/06/30 15:02:29 radhermit Exp $
+
+EAPI=5
+
+# Normally you need only one version of this.
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads,sqlite?,ssl?"
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Powerful IMAP/Maildir synchronization and reader support"
+HOMEPAGE="http://offlineimap.org"
+SRC_URI="https://github.com/OfflineIMAP/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc ssl sqlite"
+
+DEPEND="doc? ( dev-python/docutils )"
+
+src_prepare() {
+ distutils-r1_src_prepare
+ # see http://pogma.com/2009/09/09/snow-leopard-and-offlineimap/ and bug 284925
+ epatch "${FILESDIR}"/"${PN}-6.5.3.1"-darwin10.patch
+}
+
+src_compile() {
+ distutils-r1_src_compile
+ if use doc ; then
+ cd docs
+ rst2man.py MANUAL.rst offlineimap.1 || die "building manpage failed"
+ fi
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc offlineimap.conf offlineimap.conf.minimal
+ if use doc ; then
+ cd docs
+ doman offlineimap.1
+ fi
+}
+
+pkg_postinst() {
+ echo
+ elog "You will need to configure offlineimap by creating ~/.offlineimaprc"
+ elog "Sample configurations are in /usr/share/doc/${PF}/"
+ elog ""
+ elog "If you connect via ssl/tls and don't use CA cert checking, it will"
+ elog "display the server's cert fingerprint and require you to add it to the"
+ elog "configuration file to be sure it connects to the same server every"
+ elog "time. This serves to help fixing CVE-2010-4532 (offlineimap doesn't"
+ elog "check SSL server certificate) in cases where you have no CA cert."
+ echo
+
+ if use sqlite ; then
+ elog "The sqlite USE flag only enables a dependency on sqlite. To use"
+ elog "the sqlite backend you need to enable it in your .offlineimaprc"
+ fi
+}