summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJared H.Hudson <jhhudso@gentoo.org>2002-04-15 20:14:57 +0000
committerJared H.Hudson <jhhudso@gentoo.org>2002-04-15 20:14:57 +0000
commitc785f58ac854ac5d42dc4e217ba461a06d7682b3 (patch)
tree5b1fee21737bd55a5b8bd69680bc7c68214f8557 /net-mail
parentFixed bug #1759 (uw-imap didn't provide enough headers for proper php (diff)
downloadgentoo-2-c785f58ac854ac5d42dc4e217ba461a06d7682b3.tar.gz
gentoo-2-c785f58ac854ac5d42dc4e217ba461a06d7682b3.tar.bz2
gentoo-2-c785f58ac854ac5d42dc4e217ba461a06d7682b3.zip
Removed PROVIDE of virtual/imapUW
Removed include of imapd, imap headers, and imap static library. These files should be DEPEND'ed on from >=net-mail/uw-imap-2001a-r1 for now on.
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/pine/ChangeLog10
-rw-r--r--net-mail/pine/files/digest-pine-4.44-r41
-rw-r--r--net-mail/pine/pine-4.44-r4.ebuild90
3 files changed, 100 insertions, 1 deletions
diff --git a/net-mail/pine/ChangeLog b/net-mail/pine/ChangeLog
index b3f215200e26..2efe1d544a8d 100644
--- a/net-mail/pine/ChangeLog
+++ b/net-mail/pine/ChangeLog
@@ -1,7 +1,15 @@
# ChangeLog for net-mail/pine
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/pine/ChangeLog,v 1.2 2002/02/21 22:24:41 g2boojum Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/pine/ChangeLog,v 1.3 2002/04/15 20:14:57 jhhudso Exp $
+*pine-4.44-r4 (15 Apr 2002)
+
+ 15 Apr 2002; Jared H. Hudson <jhhudso@gentoo.org> :
+
+ Changed the ebuild so that it no longer PROVIDEs virtual/imapUW or
+ the imap headers. These imap headers and static library will be provided
+ by net-mail/uw-imap exclusively now.
+
*pine-4.44-r1 (21 Feb 2002)
21 Feb 2002; Grant Goodyear <g2boojum@gentoo.org> :
diff --git a/net-mail/pine/files/digest-pine-4.44-r4 b/net-mail/pine/files/digest-pine-4.44-r4
new file mode 100644
index 000000000000..d23758358512
--- /dev/null
+++ b/net-mail/pine/files/digest-pine-4.44-r4
@@ -0,0 +1 @@
+MD5 bb405bd52b9fd84b9a981626847cc098 pine4.44.tar.gz 3478476
diff --git a/net-mail/pine/pine-4.44-r4.ebuild b/net-mail/pine/pine-4.44-r4.ebuild
new file mode 100644
index 000000000000..73a5c369ea9f
--- /dev/null
+++ b/net-mail/pine/pine-4.44-r4.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/pine/pine-4.44-r4.ebuild,v 1.1 2002/04/15 20:14:57 jhhudso Exp $
+
+S=${WORKDIR}/${PN}${PV}
+DESCRIPTION="A tool for reading, sending and managing electronic messages."
+SRC_URI="ftp://ftp.cac.washington.edu/${PN}/${PN}${PV}.tar.gz"
+HOMEPAGE="http://www.washington.edu/pine/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/pam-0.72
+ ssl? ( dev-libs/openssl )
+ ldap? ( net-nds/openldap )"
+
+src_unpack() {
+ unpack ${A}
+
+ # RH patches, although I've ignored the "RH" patch itself
+ patch -d ${S} -p1 < ${FILESDIR}/pine-4.21-fixhome.patch
+ patch -d ${S} -p0 < ${FILESDIR}/imap-4.7c2-flock.patch
+ cp ${FILESDIR}/flock.c ${S}/imap/src/osdep/unix
+ patch -d ${S} -p1 < ${FILESDIR}/pine-4.21-passwd.patch
+ if [ "`use ldap`" ] ; then
+ patch -d ${S} -p1 < ${FILESDIR}/pine-4.30-ldap.patch
+ mkdir ${S}/ldap
+ ln -s /usr/lib ${S}/ldap/libraries
+ ln -s /usr/include ${S}/ldap/include
+ fi
+ patch -d ${S} -p0 < ${FILESDIR}/pine-4.40-boguswarning.patch
+ patch -d ${S} -p1 < ${FILESDIR}/pine-4.31-segfix.patch
+ patch -d ${S} -p0 < ${FILESDIR}/pine-4.40-lockfile-perm.patch
+ patch -d ${S} -p1 < ${FILESDIR}/imap-2000-time.patch
+ patch -d ${S} -p1 < ${FILESDIR}/pine-4.33-whitespace.patch
+ patch -d ${S} -p1 < ${FILESDIR}/pine-4.44-multibyte.patch
+
+ cd ${S}/pine
+ cp makefile.lnx makefile.orig
+ sed -e "s:-g -DDEBUG:${CFLAGS}:" makefile.orig > makefile.lnx
+
+ cd ${S}/pico
+ cp makefile.lnx makefile.orig
+ sed -e "s:-g -DDEBUG:${CFLAGS}:" makefile.orig > makefile.lnx
+}
+
+src_compile() {
+ BUILDOPTS=""
+ if [ "`use ssl`" ]
+ then
+ BUILDOPTS="${BUILDOPTS} SSLDIR=/usr/ssl SSLINCLUDE=/usr/include/openssl"
+ BUILDOPTS="${BUILDOPTS} SSLLIB=/usr/lib SSLTYPE=unix"
+ else
+ BUILDOPTS="${BUILDOPTS} NOSSL"
+ fi
+ if [ "`use ldap`" ]
+ then
+ ./contrib/ldap-setup lnp lnp
+ else
+ BUILDOPTS="${BUILDOPTS} NOLDAP"
+ fi
+
+ ./build ${BUILDOPTS} lnp || die
+}
+
+src_install() {
+ into /usr
+ dobin bin/pine bin/pico bin/pilot bin/mtest bin/rpdump bin/rpload
+
+ doman doc/pine.1 doc/pico.1 doc/pilot.1 doc/rpdump.1 doc/rpload.1
+
+ insinto /etc
+ doins doc/mime.types
+ donewins doc/mailcap.unx mailcap
+
+ dodoc CPYRIGHT README doc/brochure.txt doc/tech-notes.txt
+
+ docinto imap
+ dodoc imap/docs/*.txt imap/docs/CONFIG imap/docs/FAQ imap/docs/RELNOTES
+
+ docinto imap/rfc
+ dodoc imap/docs/rfc/*.txt
+
+ docinto html/tech-notes
+ dodoc doc/tech-notes/*.html
+}
+
+
+
+